aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-07 06:35:16 +0800
committergerald <gerald@FreeBSD.org>2009-01-07 06:35:16 +0800
commit754ec19f3a2e528360f6b0001d6cbfa9cb8abca8 (patch)
treee97f92a6bb75c5634bc3787df5d30331a4a83455
parent7c0c149b6d979f75d2b0c3da04307ca46dd7e641 (diff)
downloadfreebsd-ports-gnome-754ec19f3a2e528360f6b0001d6cbfa9cb8abca8.tar.gz
freebsd-ports-gnome-754ec19f3a2e528360f6b0001d6cbfa9cb8abca8.tar.zst
freebsd-ports-gnome-754ec19f3a2e528360f6b0001d6cbfa9cb8abca8.zip
Use ${FC} instead of hard coding gfortran42 (which would need to be
gfortran43 nowadays). Remove F77=${FC} from CONFIGURE_ENV since this provided by Mk/bsd.gcc.mk. Add USE_GCC=4.3 since this port uses both C and Fortran frontends.
-rw-r--r--net/mpich/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index acfd75eef99e..d7bee186f527 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -23,10 +23,11 @@ USE_BZIP2= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -prefix=${PREFIX}/mpich
USE_FORTRAN= yes
+USE_GCC= 4.3
F90FLAGS+= ${FFLAGS}
-FORTRANLIBDIR= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``
-FORTRANLIBDIR2= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``/../../../
-CONFIGURE_ENV+= F90=${FC} F90FLAGS=${F90FLAGS} F77=${FC} \
+FORTRANLIBDIR= `${DIRNAME} \`${FC} -print-libgcc-file-name\``
+FORTRANLIBDIR2= `${DIRNAME} \`${FC} -print-libgcc-file-name\``/../../../
+CONFIGURE_ENV+= F90=${FC} F90FLAGS=${F90FLAGS} \
LIBS="-L${FORTRANLIBDIR} -L${FORTRANLIBDIR2} -lgfortranbegin -lgfortran -L${LOCALBASE}/lib -lf2c"
OPTIONS= X11 "Enable MPE graphics" on \