aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-16 19:37:55 +0800
committerwg <wg@FreeBSD.org>2013-06-16 19:37:55 +0800
commit7a51f7b457d1a64593dcceebb868847b82826726 (patch)
tree29ffccbcb001d0979c3285760f3e94d5efc41846
parent10e46f03f2b94bde30b6aa7322907cbdccdf17b1 (diff)
downloadfreebsd-ports-gnome-7a51f7b457d1a64593dcceebb868847b82826726.tar.gz
freebsd-ports-gnome-7a51f7b457d1a64593dcceebb868847b82826726.tar.zst
freebsd-ports-gnome-7a51f7b457d1a64593dcceebb868847b82826726.zip
devel/pharmacy: fix build with clang
- Fix build with clang, -Wno-return-type - Add LICENSE (GPLv2) Approved by: culot / jpaetzel (mentors, implicit)
-rw-r--r--devel/pharmacy/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/pharmacy/Makefile b/devel/pharmacy/Makefile
index ef7acfa95cdd..b32c1fc7deb4 100644
--- a/devel/pharmacy/Makefile
+++ b/devel/pharmacy/Makefile
@@ -10,10 +10,13 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME frontend for CVS
+LICENSE= GPLv2
+
USE_GMAKE= yes
-USES= pathfix gettext
+USES= pathfix gettext
USE_GNOME= gnomeprefix gnomelibs
GNU_CONFIGURE= yes
+CPPFLAGS+= -Wno-return-type
CONFIGURE_ENV+= CPPCFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"