aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-06-09 11:16:07 +0800
committerpetef <petef@FreeBSD.org>2002-06-09 11:16:07 +0800
commit7f53da36025cef0d03667a5450cdf9badd4d5a09 (patch)
tree50f4e6f7b3649044b0ff8c836bd1cfeaad102bec
parent155d29f4182c8b443de984cb16efa0f463aeebc3 (diff)
downloadfreebsd-ports-gnome-7f53da36025cef0d03667a5450cdf9badd4d5a09.tar.gz
freebsd-ports-gnome-7f53da36025cef0d03667a5450cdf9badd4d5a09.tar.zst
freebsd-ports-gnome-7f53da36025cef0d03667a5450cdf9badd4d5a09.zip
Unbreak: use TCL 8.3 (and actually add the dependency on it).
While I'm here, unbreak compile on -current with gcc 3.1.
-rw-r--r--net/nam/Makefile11
-rw-r--r--net/nam/files/patch-aa24
2 files changed, 21 insertions, 14 deletions
diff --git a/net/nam/Makefile b/net/nam/Makefile
index 40a3b5cc7d8b..f3980e58a381 100644
--- a/net/nam/Makefile
+++ b/net/nam/Makefile
@@ -13,21 +13,26 @@ DISTFILES= nam-src-${PORTVERSION}.tar.gz
MAINTAINER= obonilla@fisicc-ufm.edu
-BROKEN= "Cannot find TCL"
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
MAN1= nam.1
MANCOMPRESSED= no
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl-ver=8.2 --with-tk-ver=8.2
+CONFIGURE_ARGS= --with-tcl-ver=8.3 --with-tk-ver=8.3
ALL_TARGET=
+post-patch:
+ @${SED} -e 's,friend Queue,friend class Queue,' < ${WRKSRC}/queue.h > \
+ ${WRKSRC}/queue.h.new
+ @${MV} ${WRKSRC}/queue.h.new ${WRKSRC}/queue.h
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nam ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/nam.1 ${PREFIX}/man/man1
${MKDIR} ${PREFIX}/share/examples/nam
${INSTALL_DATA} ${WRKSRC}/ex/* ${PREFIX}/share/examples/nam
+
.include <bsd.port.mk>
diff --git a/net/nam/files/patch-aa b/net/nam/files/patch-aa
index b6487d4e53b9..a5def1988d5a 100644
--- a/net/nam/files/patch-aa
+++ b/net/nam/files/patch-aa
@@ -1,11 +1,13 @@
---- configure.orig Thu Jan 6 21:27:09 2000
-+++ configure Sun Jul 16 13:35:32 2000
-@@ -2598,7 +2598,7 @@
- # $d/unix works if $d is the 8.0 distribution
- # $d/bin is for the ns-allinone distribution (kind of hacky, isn't it?)
- PATH=$d/unix:$d/bin:$PATH
--for ac_prog in tclsh$TCL_VERS tclsh$TCL_HI_VERS tclsh tclsh$TCL_OLD_VERS
-+for ac_prog in tclsh$TCL_VERS tclsh$TCL_HI_VERS tclsh8.2 tclsh$TCL_OLD_VERS
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
+$FreeBSD$
+
+--- configure.orig Sat Jun 8 23:00:16 2002
++++ configure Sat Jun 8 23:00:41 2002
+@@ -2041,7 +2041,7 @@
+ EOF
+
+
+- V_INCLUDES="$V_INCLUDE_ZLIB $V_INCLUDES"
++ V_INCLUDES="$V_INCLUDES"
+ V_DEFINES="-D$ac_tr_hdr $V_DEFINES"
+
+ NS_PACKAGE_zlib_UNDERWAY=true