aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-04-06 03:06:26 +0800
committermarcus <marcus@FreeBSD.org>2004-04-06 03:06:26 +0800
commit828789a01b5a66cb4e1e28ed896c1f1a6801cb71 (patch)
treef00171b3ecdd5a2c09a0fdb3d63f3e1ff27bf239
parent961f45a97aa62e08100cb586897a3150eb24a9ba (diff)
downloadfreebsd-ports-gnome-828789a01b5a66cb4e1e28ed896c1f1a6801cb71.tar.gz
freebsd-ports-gnome-828789a01b5a66cb4e1e28ed896c1f1a6801cb71.tar.zst
freebsd-ports-gnome-828789a01b5a66cb4e1e28ed896c1f1a6801cb71.zip
Fix a crash with GNOME 2.6.
PR: 65222 Submitted by: maintainer
-rw-r--r--x11/gcursor/Makefile2
-rw-r--r--x11/gcursor/files/patch-src::gcursor.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/x11/gcursor/Makefile b/x11/gcursor/Makefile
index 8df8bddc2341..4062c481c19f 100644
--- a/x11/gcursor/Makefile
+++ b/x11/gcursor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcursor
PORTVERSION= 0.04
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= http://download.qballcow.nl/programs/gcursor/
diff --git a/x11/gcursor/files/patch-src::gcursor.c b/x11/gcursor/files/patch-src::gcursor.c
index 39d9e8cfe601..9fab694b05a3 100644
--- a/x11/gcursor/files/patch-src::gcursor.c
+++ b/x11/gcursor/files/patch-src::gcursor.c
@@ -1,5 +1,5 @@
---- src/gcursor.c.orig Fri Mar 26 17:51:58 2004
-+++ src/gcursor.c Fri Mar 26 17:55:16 2004
+--- src/gcursor.c.orig Fri Mar 26 12:54:55 2004
++++ src/gcursor.c Mon Apr 5 13:21:52 2004
@@ -16,7 +16,7 @@
GConfClient *client;
XcursorImage * cursor = NULL;
@@ -20,3 +20,12 @@
"%s/.icons/"
};
+@@ -348,7 +346,7 @@
+ GTK_STOCK_DIALOG_QUESTION, GTK_ICON_SIZE_LARGE_TOOLBAR);
+ }
+
+- if(animations[1].image->images != NULL && animations[1].image->nimage != 0)
++ if(animations[1].image != NULL && animations[1].image->nimage != 0)
+ {
+ pixbuf = get_pixbuf_from_cursor_image(animations[1].image->images[animations[1].pos]);
+ gtk_image_set_from_pixbuf(GTK_IMAGE(glade_xml_get_widget(main_window, "example_2")),