aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2007-01-13 18:55:37 +0800
committerdinoex <dinoex@FreeBSD.org>2007-01-13 18:55:37 +0800
commit82af21c11e2b2d17e2a79ba6683289f0561a9a6e (patch)
treefa6cdf5ac8e4e8bf2827bb1594b1633e8d8735ca
parentbce8d257997c4a8d04b0f37aef80674b64e1d38e (diff)
downloadfreebsd-ports-gnome-82af21c11e2b2d17e2a79ba6683289f0561a9a6e.tar.gz
freebsd-ports-gnome-82af21c11e2b2d17e2a79ba6683289f0561a9a6e.tar.zst
freebsd-ports-gnome-82af21c11e2b2d17e2a79ba6683289f0561a9a6e.zip
- use new macros
-rw-r--r--databases/fortytwo-bdb/Makefile2
-rw-r--r--deskutils/etoile-extendedworkspacekit/Makefile2
-rw-r--r--deskutils/etoile-panekit/Makefile2
-rw-r--r--deskutils/etoile-servicesbarkit/Makefile2
-rw-r--r--deskutils/etoile-systemconfig/Makefile2
-rw-r--r--deskutils/etoile-trackerkit/Makefile2
-rw-r--r--deskutils/etoile-ui/Makefile2
-rw-r--r--deskutils/gnustep-wrapper/Makefile2
-rw-r--r--deskutils/gworkspace/Makefile4
-rw-r--r--deskutils/toolboxkit/Makefile2
-rw-r--r--devel/etoile-collectionkit/Makefile2
-rw-r--r--devel/etoile-foundation/Makefile2
-rw-r--r--devel/etoile-unitkit/Makefile2
-rw-r--r--devel/fortytwo-encore/Makefile2
-rw-r--r--devel/highlighterkit/Makefile2
-rw-r--r--devel/objectivelib/Makefile2
-rw-r--r--graphics/camerakit/Makefile2
-rw-r--r--graphics/fortytwo/Makefile2
-rw-r--r--multimedia/etoile-multimediakit/Makefile2
-rw-r--r--net/tryst/Makefile2
-rw-r--r--sysutils/etoile-behavior/Makefile2
-rw-r--r--textproc/etoile-lucenekit/Makefile2
-rw-r--r--textproc/etoile-ogrekit/Makefile2
-rw-r--r--www/etoile-bookmarkkit/Makefile2
-rw-r--r--www/etoile-rsskit/Makefile2
-rw-r--r--x11-themes/etoile-iconkit/Makefile2
-rw-r--r--x11-toolkits/gtoolkit/Makefile2
-rw-r--r--x11/etoile-xwindowserverkit/Makefile4
28 files changed, 30 insertions, 30 deletions
diff --git a/databases/fortytwo-bdb/Makefile b/databases/fortytwo-bdb/Makefile
index 45f7f8da9638..fb5a76e51dd8 100644
--- a/databases/fortytwo-bdb/Makefile
+++ b/databases/fortytwo-bdb/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= Encore:${ENCORE_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_BDB= 43
WRKSRC= ${WRKDIR}/BDB-${PORTVERSION}
diff --git a/deskutils/etoile-extendedworkspacekit/Makefile b/deskutils/etoile-extendedworkspacekit/Makefile
index 5be78a396df9..d658a0ce3aaf 100644
--- a/deskutils/etoile-extendedworkspacekit/Makefile
+++ b/deskutils/etoile-extendedworkspacekit/Makefile
@@ -25,7 +25,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_SYSTEM_LIBS+= TrackerKit:${TRACKERKIT_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/deskutils/etoile-panekit/Makefile b/deskutils/etoile-panekit/Makefile
index 0080cb948fbf..6785affb8a9f 100644
--- a/deskutils/etoile-panekit/Makefile
+++ b/deskutils/etoile-panekit/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/deskutils/etoile-servicesbarkit/Makefile b/deskutils/etoile-servicesbarkit/Makefile
index 2bafe2de8964..48492994bcf6 100644
--- a/deskutils/etoile-servicesbarkit/Makefile
+++ b/deskutils/etoile-servicesbarkit/Makefile
@@ -25,7 +25,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= UnitKit:${UNITKIT_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/deskutils/etoile-systemconfig/Makefile b/deskutils/etoile-systemconfig/Makefile
index a11aa05cb965..a705726a1e13 100644
--- a/deskutils/etoile-systemconfig/Makefile
+++ b/deskutils/etoile-systemconfig/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/deskutils/etoile-trackerkit/Makefile b/deskutils/etoile-trackerkit/Makefile
index 00eba8ed7802..e6b7222ce092 100644
--- a/deskutils/etoile-trackerkit/Makefile
+++ b/deskutils/etoile-trackerkit/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/deskutils/etoile-ui/Makefile b/deskutils/etoile-ui/Makefile
index 26b64e8d05ce..9be0cc3e8cad 100644
--- a/deskutils/etoile-ui/Makefile
+++ b/deskutils/etoile-ui/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/deskutils/gnustep-wrapper/Makefile b/deskutils/gnustep-wrapper/Makefile
index 274439243b02..686372402393 100644
--- a/deskutils/gnustep-wrapper/Makefile
+++ b/deskutils/gnustep-wrapper/Makefile
@@ -20,7 +20,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
post-patch:
${REINPLACE_CMD} -e 's|cp -u|cp -p|' \
diff --git a/deskutils/gworkspace/Makefile b/deskutils/gworkspace/Makefile
index d7169395fd90..74a6032f69e8 100644
--- a/deskutils/gworkspace/Makefile
+++ b/deskutils/gworkspace/Makefile
@@ -20,7 +20,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
WRKSRC= ${WRKDIR}/GWorkspace-${PORTVERSION}
GNU_CONFIGURE= yes
@@ -38,6 +38,6 @@ USE_GHOSTSCRIPT= yes
post-install:
${CP} ${WRKSRC}/Inspector/ContentViewersProtocol.h \
- ${SYSTEMDIR}/Library/Frameworks/Inspector.framework/Versions/A/Headers/ContentViewersProtocol.h
+ ${GNUSTEP_SYSTEM_ROOT}/Library/Frameworks/Inspector.framework/Versions/A/Headers/ContentViewersProtocol.h
.include <bsd.port.mk>
diff --git a/deskutils/toolboxkit/Makefile b/deskutils/toolboxkit/Makefile
index 270df112774b..8b4a9c014d2c 100644
--- a/deskutils/toolboxkit/Makefile
+++ b/deskutils/toolboxkit/Makefile
@@ -20,7 +20,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
WRKSRC= ${WRKDIR}/Toolbox
USE_GNUSTEP_MAKE_DIRS+= Toolbox
diff --git a/devel/etoile-collectionkit/Makefile b/devel/etoile-collectionkit/Makefile
index a9f21840d005..0470646a4b74 100644
--- a/devel/etoile-collectionkit/Makefile
+++ b/devel/etoile-collectionkit/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/devel/etoile-foundation/Makefile b/devel/etoile-foundation/Makefile
index 1471feacd79a..737d2a455a0f 100644
--- a/devel/etoile-foundation/Makefile
+++ b/devel/etoile-foundation/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/devel/etoile-unitkit/Makefile b/devel/etoile-unitkit/Makefile
index 626fe6c63d97..4390fbb68e4d 100644
--- a/devel/etoile-unitkit/Makefile
+++ b/devel/etoile-unitkit/Makefile
@@ -23,7 +23,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/devel/fortytwo-encore/Makefile b/devel/fortytwo-encore/Makefile
index d1b40649d7ae..4674cc79a1c9 100644
--- a/devel/fortytwo-encore/Makefile
+++ b/devel/fortytwo-encore/Makefile
@@ -23,7 +23,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
WRKSRC= ${WRKDIR}/Encore-${PORTVERSION}
DOCSDIR= ${GNUSTEP_PREFIX}/Local/Library/Documentation/Encore
diff --git a/devel/highlighterkit/Makefile b/devel/highlighterkit/Makefile
index cdb51129102f..ce0fe2374e25 100644
--- a/devel/highlighterkit/Makefile
+++ b/devel/highlighterkit/Makefile
@@ -20,6 +20,6 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
.include <bsd.port.mk>
diff --git a/devel/objectivelib/Makefile b/devel/objectivelib/Makefile
index 2861293937c2..8afe0d90154c 100644
--- a/devel/objectivelib/Makefile
+++ b/devel/objectivelib/Makefile
@@ -21,7 +21,7 @@ USE_GNUSTEP_BASE= yes
USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
WRKSRC= ${WRKDIR}
diff --git a/graphics/camerakit/Makefile b/graphics/camerakit/Makefile
index 6070304257f0..8a269338007b 100644
--- a/graphics/camerakit/Makefile
+++ b/graphics/camerakit/Makefile
@@ -22,7 +22,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
WRKSRC= ${WRKDIR}/CameraKit
diff --git a/graphics/fortytwo/Makefile b/graphics/fortytwo/Makefile
index 21c502057ff1..71caca238d23 100644
--- a/graphics/fortytwo/Makefile
+++ b/graphics/fortytwo/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= Encore:${ENCORE_PORT}
USE_GNUSTEP_LOCAL_LIBS+= BDB:${FORTYTWO_BDB_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_BDB= 43
WRKSRC= ${WRKDIR}/FT-${PORTVERSION}
diff --git a/multimedia/etoile-multimediakit/Makefile b/multimedia/etoile-multimediakit/Makefile
index 5ddd5063b233..2df96ee3f58f 100644
--- a/multimedia/etoile-multimediakit/Makefile
+++ b/multimedia/etoile-multimediakit/Makefile
@@ -25,7 +25,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LCOAL_APPS+= Mplayer:${GNUSTEP_MPLAYER_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/net/tryst/Makefile b/net/tryst/Makefile
index a9e2abb51381..faf41a0a45b9 100644
--- a/net/tryst/Makefile
+++ b/net/tryst/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
WRKSRC= ${WRKDIR}/Tryst-108.pl4
diff --git a/sysutils/etoile-behavior/Makefile b/sysutils/etoile-behavior/Makefile
index bf59c461c804..364a2b5a645f 100644
--- a/sysutils/etoile-behavior/Makefile
+++ b/sysutils/etoile-behavior/Makefile
@@ -27,6 +27,6 @@ USE_GNUSTEP_INSTALL= yes
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
USE_GNUSTEP_MAKE_DIRS+= Bundles/EtoileBehavior
-MAKE_ENV+= GNUSTEP_INSTALLATION_DIR="${SYSTEMDIR}"
+MAKE_ENV+= GNUSTEP_INSTALLATION_DIR="${GNUSTEP_SYSTEM_ROOT}"
.include <bsd.port.mk>
diff --git a/textproc/etoile-lucenekit/Makefile b/textproc/etoile-lucenekit/Makefile
index 651c981b492f..052fa0f12a37 100644
--- a/textproc/etoile-lucenekit/Makefile
+++ b/textproc/etoile-lucenekit/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= OgreKit:${OGREKIT_PORT}
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/textproc/etoile-ogrekit/Makefile b/textproc/etoile-ogrekit/Makefile
index ea021927bba9..a8cb2039e205 100644
--- a/textproc/etoile-ogrekit/Makefile
+++ b/textproc/etoile-ogrekit/Makefile
@@ -25,7 +25,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/www/etoile-bookmarkkit/Makefile b/www/etoile-bookmarkkit/Makefile
index f61ebf754101..720292a1f9b3 100644
--- a/www/etoile-bookmarkkit/Makefile
+++ b/www/etoile-bookmarkkit/Makefile
@@ -25,7 +25,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= CollectionKit:${COLLECTIONKIT_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/www/etoile-rsskit/Makefile b/www/etoile-rsskit/Makefile
index 4b0285b23728..9b7f86da4cb9 100644
--- a/www/etoile-rsskit/Makefile
+++ b/www/etoile-rsskit/Makefile
@@ -23,7 +23,7 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/x11-themes/etoile-iconkit/Makefile b/x11-themes/etoile-iconkit/Makefile
index 06c681d274a6..8974d0c16810 100644
--- a/x11-themes/etoile-iconkit/Makefile
+++ b/x11-themes/etoile-iconkit/Makefile
@@ -25,7 +25,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= UnitKit:${UNITKIT_PORT}
DEFAULT_LIBVERSION= 0.1
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
diff --git a/x11-toolkits/gtoolkit/Makefile b/x11-toolkits/gtoolkit/Makefile
index 717e03f4f386..4f65d1f8cb32 100644
--- a/x11-toolkits/gtoolkit/Makefile
+++ b/x11-toolkits/gtoolkit/Makefile
@@ -22,7 +22,7 @@ USE_GNUSTEP_BASE= yes
USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
GNU_CONFIGURE= yes
USE_GNOME= gtk12
diff --git a/x11/etoile-xwindowserverkit/Makefile b/x11/etoile-xwindowserverkit/Makefile
index 001524ef6c23..366f1ae77698 100644
--- a/x11/etoile-xwindowserverkit/Makefile
+++ b/x11/etoile-xwindowserverkit/Makefile
@@ -23,13 +23,13 @@ USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
SNAPSHOT= 20061221
WRKSRC= ${WRKDIR}/Etoile/
USE_GNUSTEP_MAKE_DIRS+= Frameworks/XWindowServerKit
ADDITIONAL_OBJCFLAGS+= -I${X11BASE}/include
ADDITIONAL_LDFLAGS+= -L${X11BASE}/lib
-MAKE_ENV+= GNUSTEP_INSTALLATION_DIR="${SYSTEMDIR}"
+MAKE_ENV+= GNUSTEP_INSTALLATION_DIR="${GNUSTEP_SYSTEM_ROOT}"
.include <bsd.port.mk>