aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-03 02:17:54 +0800
committeraaron <aaron@FreeBSD.org>2006-06-03 02:17:54 +0800
commit8621fcc74aa1bf0ff2614591d0e48bcb3196efff (patch)
tree71da0e90372a7a042393e0a033b23901fd32f5f1
parentd13d88fcc4bd15ba8d67579767b3d42eb3bbd41e (diff)
downloadfreebsd-ports-gnome-8621fcc74aa1bf0ff2614591d0e48bcb3196efff.tar.gz
freebsd-ports-gnome-8621fcc74aa1bf0ff2614591d0e48bcb3196efff.tar.zst
freebsd-ports-gnome-8621fcc74aa1bf0ff2614591d0e48bcb3196efff.zip
- Update from v0.82 to v0.84
0.84 May29, 2006 - The XS version of the code used Carp::croak to report failures, while the Perl version used Carp::confess. The module has always been documented as using confess, so now the XS version uses this. - The new compiler detection code always returned false if you didn't have ExtUtils::CBuilder installed. 0.83 May 28, 2006 - Change how C compiler detection is done in the Makefile.PL so it does not rely on having make on the system. The new way should work on (most?) Unix and Win32 systems. Suggested by David Golden. See RT 18969 (for DateTime.pm, but equally applicable to this module). Will hopefully fix RT 17644. - Previously, if a parameter was undefined, regex checks for that parameter always failed. However, it's quite possible for a regex to successfully match an undefined value (qr/^$/, for example). Now the code treats undef as an empty string ('') in regex checks. Reported by Duncan Salada. PR: ports/98304 Submitted by: aaron Reviewed by: maintainer Approved by: maintainer, tobez (implicit)
-rw-r--r--devel/p5-Params-Validate/Makefile6
-rw-r--r--devel/p5-Params-Validate/distinfo6
-rw-r--r--devel/p5-Params-Validate/pkg-descr2
3 files changed, 10 insertions, 4 deletions
diff --git a/devel/p5-Params-Validate/Makefile b/devel/p5-Params-Validate/Makefile
index 6664005d9ccb..b357cb5d596c 100644
--- a/devel/p5-Params-Validate/Makefile
+++ b/devel/p5-Params-Validate/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Params-Validate
-PORTVERSION= 0.82
+PORTVERSION= 0.84
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Devel/DROLSKY
@@ -27,4 +27,8 @@ BUILD_DEPENDS+= ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribut
RUN_DEPENDS+= ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
.endif
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-Params-Validate/distinfo b/devel/p5-Params-Validate/distinfo
index 809a3ae852b8..8c74c83fc3ca 100644
--- a/devel/p5-Params-Validate/distinfo
+++ b/devel/p5-Params-Validate/distinfo
@@ -1,3 +1,3 @@
-MD5 (Params-Validate-0.82.tar.gz) = f83a21a6674890f243d2c43f98fe236c
-SHA256 (Params-Validate-0.82.tar.gz) = b4fb2bed367c5da758bf267c1ab6bf303af0a9a7a0dac8aa76b11f8d04412c36
-SIZE (Params-Validate-0.82.tar.gz) = 55542
+MD5 (Params-Validate-0.84.tar.gz) = a05efe9864d7cae546697374ee35bc47
+SHA256 (Params-Validate-0.84.tar.gz) = ca31209bc6a100a1daf309d9815fa6685f9f585530d6d793f4872b3cb74a9497
+SIZE (Params-Validate-0.84.tar.gz) = 56224
diff --git a/devel/p5-Params-Validate/pkg-descr b/devel/p5-Params-Validate/pkg-descr
index 0cb4e84af933..40e74f05af9e 100644
--- a/devel/p5-Params-Validate/pkg-descr
+++ b/devel/p5-Params-Validate/pkg-descr
@@ -7,3 +7,5 @@ that it is an object of a certain class hierarchy, that it possesses
certain methods, or applying validation callbacks to arguments.
WWW: http://search.cpan.org/dist/Params-Validate/
+Authors: Dave Rolsky, <autarch@urth.org>
+ Ilya Martynov <ilya@martynov.org>