aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2005-10-29 15:13:29 +0800
committerdougb <dougb@FreeBSD.org>2005-10-29 15:13:29 +0800
commit88c5a531cb6a6005e92562b2b543a866d3024bd4 (patch)
tree9f4b172b88f694477d0b20d2473a1005ed584ce4
parent829ba133c8622e0339248b7f0d74725e152e5bad (diff)
downloadfreebsd-ports-gnome-88c5a531cb6a6005e92562b2b543a866d3024bd4.tar.gz
freebsd-ports-gnome-88c5a531cb6a6005e92562b2b543a866d3024bd4.tar.zst
freebsd-ports-gnome-88c5a531cb6a6005e92562b2b543a866d3024bd4.zip
For the ports that I maintain, do the following as appropriate:
1. Add myself as a backup master site (Sourceforge and CPAN ports already have good enough coverage, so skip them). 2. For all ports that have them, download the PGP signature files. 3. For ports in 2, add a verify target to the Makefile 4. For ports where I was already providing a master site, update the URL. 5. Pet portlint in a couple of places.
-rw-r--r--dns/bind8/Makefile11
-rw-r--r--dns/bind8/distinfo4
-rw-r--r--dns/bind84/Makefile7
-rw-r--r--dns/bind9/Makefile6
-rw-r--r--dns/bind94/Makefile6
-rw-r--r--dns/bind95/Makefile6
-rw-r--r--dns/bind96/Makefile6
-rw-r--r--dns/fpdns/Makefile6
-rw-r--r--editors/pico/Makefile3
-rw-r--r--irc/sirc/Makefile2
-rw-r--r--mail/pine-pgp-filters/Makefile5
-rw-r--r--mail/pine4/Makefile3
-rw-r--r--sysutils/shlock/Makefile10
-rw-r--r--sysutils/shlock/distinfo2
-rw-r--r--textproc/htdig/Makefile3
-rw-r--r--x11-wm/windowmaker/Makefile4
-rw-r--r--x11/xscreensaver/Makefile3
17 files changed, 68 insertions, 19 deletions
diff --git a/dns/bind8/Makefile b/dns/bind8/Makefile
index f0ea22eeb1d9..72497326f109 100644
--- a/dns/bind8/Makefile
+++ b/dns/bind8/Makefile
@@ -13,10 +13,13 @@
PORTNAME= bind
PORTVERSION= 8.3.7
CATEGORIES?= dns net
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind/src/${PORTVERSION}
-DISTFILES= bind-src.tar.gz bind-doc.tar.gz
+DISTFILES= bind-src.tar.gz bind-doc.tar.gz \
+ bind-src.tar.gz.asc bind-doc.tar.gz.asc
DIST_SUBDIR= bind-${PORTVERSION}
+EXTRACT_ONLY= bind-src.tar.gz bind-doc.tar.gz
MAINTAINER?= DougB@FreeBSD.org
COMMENT= The Berkeley Internet Name Domain, an implementation of DNS
@@ -53,6 +56,10 @@ PATCH_DIST_ARGS= -s -d ${WRKDIR}
WRKSRC= ${WRKDIR}/src
+verify: checksum
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-src.tar.gz.asc
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-doc.tar.gz.asc
+
post-patch:
@${SED} -e "s#\'DESTETC=.*#'DESTETC=${BIND_DESTETC}'#" \
-e "s#-O2 -g#${CFLAGS}#" \
diff --git a/dns/bind8/distinfo b/dns/bind8/distinfo
index 454da4fbcd5a..0fe316310d6a 100644
--- a/dns/bind8/distinfo
+++ b/dns/bind8/distinfo
@@ -2,3 +2,7 @@ MD5 (bind-8.3.7/bind-src.tar.gz) = 36cc1660eb7d73e872a1e5af6f832167
SIZE (bind-8.3.7/bind-src.tar.gz) = 1417083
MD5 (bind-8.3.7/bind-doc.tar.gz) = b7ccbde30d8c43202eabf61a51366852
SIZE (bind-8.3.7/bind-doc.tar.gz) = 1492990
+MD5 (bind-8.3.7/bind-src.tar.gz.asc) = f4814a77210b1035706702abd76e2df8
+SIZE (bind-8.3.7/bind-src.tar.gz.asc) = 187
+MD5 (bind-8.3.7/bind-doc.tar.gz.asc) = 97261ecda0ad770c359db9229b61b375
+SIZE (bind-8.3.7/bind-doc.tar.gz.asc) = 187
diff --git a/dns/bind84/Makefile b/dns/bind84/Makefile
index d06cf8d9892b..3c6f55108b73 100644
--- a/dns/bind84/Makefile
+++ b/dns/bind84/Makefile
@@ -13,7 +13,8 @@
PORTNAME= bind84
PORTVERSION= 8.4.6
CATEGORIES?= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind/src/${PORTVERSION}
DISTFILES= bind-src.tar.gz bind-doc.tar.gz \
bind-src.tar.gz.asc bind-doc.tar.gz.asc
@@ -55,6 +56,10 @@ PATCH_DIST_ARGS= -s -d ${WRKDIR}
WRKSRC= ${WRKDIR}/src
+verify: checksum
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-src.tar.gz.asc
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-doc.tar.gz.asc
+
post-patch:
@${SED} -e "s#\'DESTETC=.*#'DESTETC=${BIND_DESTETC}'#" \
-e "s#-O2 -g#${CFLAGS}#" \
diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/bind94/Makefile b/dns/bind94/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind94/Makefile
+++ b/dns/bind94/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
index 8792a0b42e67..1260e6068239 100644
--- a/dns/fpdns/Makefile
+++ b/dns/fpdns/Makefile
@@ -8,7 +8,8 @@
PORTNAME= fpdns
PORTVERSION= 0.9.3
CATEGORIES= dns net perl5
-MASTER_SITES= http://www.rfc.se/fpdns/distfiles/
+MASTER_SITES= http://www.rfc.se/fpdns/distfiles/ \
+ http://dougbarton.us/Downloads/
DISTNAME= Net-DNS-Fingerprint-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -28,6 +29,9 @@ MAN1= fpdns.1
IGNORE= Requires at least Perl version 5.6.0
.endif
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
+
file= ${WRKSRC}/blib/man1/fpdns.1
post-build:
@${SED} -e 's#\\&\\fIperl\\fR\\|(1), \\fINet::DNS\\fR\\|(1)#&, http://www.rfc.se/fpdns/#' \
diff --git a/editors/pico/Makefile b/editors/pico/Makefile
index 4d08ef82e4d7..d0ebdb26e8b3 100644
--- a/editors/pico/Makefile
+++ b/editors/pico/Makefile
@@ -15,7 +15,8 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
ftp://ftp.uni-magdeburg.de/pub/mirror/ftp.cac.washington.edu/pine/ \
ftp://ftp.fu-berlin.de/unix/mail/pine/ \
ftp://ftp.ut.ee/pub/unix/mail/pine/ \
- ftp://gd.tuwien.ac.at/infosys/mail/pine/
+ ftp://gd.tuwien.ac.at/infosys/mail/pine/ \
+ http://dougbarton.us/Downloads/
DISTNAME= pine${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
diff --git a/irc/sirc/Makefile b/irc/sirc/Makefile
index 128f06b8feb0..2ac6ad1df3dc 100644
--- a/irc/sirc/Makefile
+++ b/irc/sirc/Makefile
@@ -15,7 +15,7 @@ PORTNAME= sirc
PORTVERSION= 2.211
CATEGORIES= irc
MASTER_SITES= http://www.iagora.com/~espel/sirc/ \
- http://dougbarton.net/FreeBSD/Downloads/
+ http://dougbarton.us/Downloads/
MAINTAINER= DougB@FreeBSD.org
COMMENT= Small (150k), fast, perl-based IRC client
diff --git a/mail/pine-pgp-filters/Makefile b/mail/pine-pgp-filters/Makefile
index 0d5a2bed8d6d..0bb4503813d7 100644
--- a/mail/pine-pgp-filters/Makefile
+++ b/mail/pine-pgp-filters/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pine-pgp-filters
PORTVERSION= 1.2
CATEGORIES= mail security
-MASTER_SITES= http://dougbarton.net/FreeBSD/Downloads/ \
+MASTER_SITES= http://dougbarton.us/Downloads/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dougb
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -17,6 +17,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= DougB@FreeBSD.org
COMMENT= Simple, fast, sh-based filters to integrate Pine with gnupg, or pgp6
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
do-build:
cd ${WRKSRC} && ./configure --prefix=${PREFIX}
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index 3cdf57904951..837355f11201 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
ftp://ftp.uni-magdeburg.de/pub/mirror/ftp.cac.washington.edu/pine/ \
ftp://ftp.fu-berlin.de/unix/mail/pine/ \
ftp://ftp.ut.ee/pub/unix/mail/pine/ \
- ftp://gd.tuwien.ac.at/infosys/mail/pine/
+ ftp://gd.tuwien.ac.at/infosys/mail/pine/ \
+ http://dougbarton.us/Downloads/
DISTNAME= pine${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
diff --git a/sysutils/shlock/Makefile b/sysutils/shlock/Makefile
index 5089e46547e4..99bbaab4a816 100644
--- a/sysutils/shlock/Makefile
+++ b/sysutils/shlock/Makefile
@@ -8,10 +8,11 @@
PORTNAME= shlock
PORTVERSION= 2.3.5
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR=inn
-
-DISTFILES= inn-${PORTVERSION}${EXTRACT_SUFX}
+DISTFILES= inn-${PORTVERSION}${EXTRACT_SUFX} \
+ inn-${PORTVERSION}${EXTRACT_SUFX}.asc
MAINTAINER= DougB@FreeBSD.org
COMMENT= Create lock files for use in shell scripts
@@ -23,6 +24,9 @@ PLIST_FILES= bin/shlock
WRKSRC= ${WRKDIR}/inn-${PORTVERSION}
+verify: checksum
+ gpg --verify ${DISTDIR}/inn-${PORTVERSION}${EXTRACT_SUFX}.asc
+
do-build:
cd ${WRKSRC}/backends && ${MAKE} shlock
diff --git a/sysutils/shlock/distinfo b/sysutils/shlock/distinfo
index 33a1a0d7ebc3..4c55ca18c2b7 100644
--- a/sysutils/shlock/distinfo
+++ b/sysutils/shlock/distinfo
@@ -1,2 +1,4 @@
MD5 (inn-2.3.5.tar.gz) = 97223e05d37e568f2ba95793b8133246
SIZE (inn-2.3.5.tar.gz) = 1421702
+MD5 (inn-2.3.5.tar.gz.asc) = f4c9574b9fd12ef7388372acc824086f
+SIZE (inn-2.3.5.tar.gz.asc) = 187
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index ad63552ec3f9..631667284b54 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://htdig.sourceforge.net/files/ \
http://www.htdig.org/files/ \
ftp://netmirror.org/ftp.htdig.org/ \
ftp://gnu.kookel.org/pub/htdig/ftp.htdig.org/files/ \
- ftp://ftp.ntua.gr/pub/www/htdig/
+ ftp://ftp.ntua.gr/pub/www/htdig/ \
+ http://dougbarton.us/Downloads/
DISTNAME= htdig-3.2.0b6
MAINTAINER= DougB@FreeBSD.org
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index d78388947fd2..fa6df89923b4 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -43,12 +43,12 @@ MANLANG= "" sk
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x
-.include <bsd.port.pre.mk>
-
OPTIONS= XINERAMA "Enable xinerama support" off \
XKB_STATUS "XKB keyboard language status support" off \
WM_LINGUAS "Enable support for additional locales" off
+.include <bsd.port.pre.mk>
+
.if ${ARCH} == amd64
CONFIGURE_ENV+= ac_cv_c_inline_asm=no
.endif
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 5f9a91228518..e4cec7e4fc82 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -8,7 +8,8 @@
PORTNAME= xscreensaver
PORTVERSION= 4.22
CATEGORIES?= x11
-MASTER_SITES= http://www.jwz.org/xscreensaver/
+MASTER_SITES= http://www.jwz.org/xscreensaver/ \
+ http://dougbarton.us/Downloads/
MAINTAINER?= DougB@FreeBSD.org
COMMENT= Save your screen while you entertain your cat