aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2001-06-12 23:14:58 +0800
committermarkp <markp@FreeBSD.org>2001-06-12 23:14:58 +0800
commit890166acebfab3b0265996104ddab1366db296b1 (patch)
tree669a5a66370ddf3552335243b1ed0de8324463e9
parente6aba9d427ee7606696027af81c99b14294569cc (diff)
downloadfreebsd-ports-gnome-890166acebfab3b0265996104ddab1366db296b1.tar.gz
freebsd-ports-gnome-890166acebfab3b0265996104ddab1366db296b1.tar.zst
freebsd-ports-gnome-890166acebfab3b0265996104ddab1366db296b1.zip
Add nc 1.0.1, network aware cat
-rw-r--r--net/Makefile1
-rw-r--r--net/nc/Makefile24
-rw-r--r--net/nc/distinfo1
-rw-r--r--net/nc/pkg-comment1
-rw-r--r--net/nc/pkg-descr5
-rw-r--r--net/nc/pkg-plist1
6 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b9c658d26196..b29b9832566e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -196,6 +196,7 @@
SUBDIR += naim
SUBDIR += nam
SUBDIR += nat
+ SUBDIR += nc
SUBDIR += ncat
SUBDIR += ncplib
SUBDIR += nemesis
diff --git a/net/nc/Makefile b/net/nc/Makefile
new file mode 100644
index 000000000000..83af3764ccf9
--- /dev/null
+++ b/net/nc/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: nc
+# Date created: Apr 27, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nc
+PORTVERSION= 1.0.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= utils/file
+DISTNAME= ncat-${PORTVERSION}
+
+MAINTAINER= markp@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+MAN1= ncat.1
+
+.include <bsd.port.mk>
diff --git a/net/nc/distinfo b/net/nc/distinfo
new file mode 100644
index 000000000000..c651e0a43a40
--- /dev/null
+++ b/net/nc/distinfo
@@ -0,0 +1 @@
+MD5 (ncat-1.0.1.tar.gz) = ffba82845f9fdd4ce30147cefa3436e4
diff --git a/net/nc/pkg-comment b/net/nc/pkg-comment
new file mode 100644
index 000000000000..fab389337acb
--- /dev/null
+++ b/net/nc/pkg-comment
@@ -0,0 +1 @@
+Network aware cat
diff --git a/net/nc/pkg-descr b/net/nc/pkg-descr
new file mode 100644
index 000000000000..d8dd52249b4f
--- /dev/null
+++ b/net/nc/pkg-descr
@@ -0,0 +1,5 @@
+Ncat concatenates data streams similar to "cat" except the streams can
+be files or TCP connections. Ncat makes it easy to pipe data between
+hosts.
+
+WWW: http://www.kyne.com.au/~mark/software/ncat.php
diff --git a/net/nc/pkg-plist b/net/nc/pkg-plist
new file mode 100644
index 000000000000..91563faf3729
--- /dev/null
+++ b/net/nc/pkg-plist
@@ -0,0 +1 @@
+bin/ncat