aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-22 04:56:00 +0800
committermiwi <miwi@FreeBSD.org>2008-11-22 04:56:00 +0800
commit932b6fa9d4eef071d7f32772b34fcbd654f8ed14 (patch)
treedee244794a7fde4920d844d95dc0672cab6d8f58
parent7328de776dfd4157bbe1e976431856df93bedb62 (diff)
downloadfreebsd-ports-gnome-932b6fa9d4eef071d7f32772b34fcbd654f8ed14.tar.gz
freebsd-ports-gnome-932b6fa9d4eef071d7f32772b34fcbd654f8ed14.tar.zst
freebsd-ports-gnome-932b6fa9d4eef071d7f32772b34fcbd654f8ed14.zip
Mapnik is a Free Toolkit for developing mapping applications. It's
written in C++ and there are Python bindings to facilitate fast-paced agile development. It can comfortably be used for both desktop and web development, which was something wanted from the beginning. Mapnik is about making beautiful maps. It uses the AGG library and offers world class anti-aliasing rendering with subpixel accuracy for geographic data. It is written from scratch in modern C++ and doesn't suffer from design decisions made a decade ago. When it comes to handling common software tasks such as memory management, filesystem access, regular expressions, parsing and so on, Mapnik doesn't re-invent the wheel, but utilizes best of breed industry standard libraries from boost.org. WWW: http://www.mapnik.org/ PR: ports/128746 Submitted by: Wen Heping <wenheping at gmail.com>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/mapnik/Makefile36
-rw-r--r--graphics/mapnik/distinfo3
-rw-r--r--graphics/mapnik/pkg-descr15
-rw-r--r--graphics/mapnik/pkg-plist143
5 files changed, 198 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 27a83bb524bd..2a1103093aeb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -458,6 +458,7 @@
SUBDIR += lphoto
SUBDIR += lprof-devel
SUBDIR += makehuman
+ SUBDIR += mapnik
SUBDIR += mapserver
SUBDIR += mapyrus
SUBDIR += maverik
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
new file mode 100644
index 000000000000..319ad0e4db7a
--- /dev/null
+++ b/graphics/mapnik/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mapnik
+# Date created: Nov 10, 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mapnik
+PORTVERSION= 0.5.1
+CATEGORIES= graphics geography
+MASTER_SITES= ${MASTER_SITE_BERLIOS}/${PORTNAME}/
+DISTNAME= mapnik_src-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Free Toolkit For Developing Mapping Applications
+
+LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
+ proj:${PORTSDIR}/graphics/proj \
+ ltdl:${PORTSDIR}/devel/libltdl15 \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ iconv:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
+ ${LOCALBASE}/include/boost/python.hpp:${PORTSDIR}/devel/boost-python
+
+NO_BUILD= yes
+USE_PYTHON= 2.4+
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} scons/scons.py install
+
+.include <bsd.port.post.mk>
diff --git a/graphics/mapnik/distinfo b/graphics/mapnik/distinfo
new file mode 100644
index 000000000000..b778f4e1754f
--- /dev/null
+++ b/graphics/mapnik/distinfo
@@ -0,0 +1,3 @@
+MD5 (mapnik_src-0.5.1.tar.gz) = fa484bdb5cf1faf0720f17129a43038b
+SHA256 (mapnik_src-0.5.1.tar.gz) = 7682bba5f578dbb5dd5103d72876e0745e3f2da2eba8fd268cd81f400625812d
+SIZE (mapnik_src-0.5.1.tar.gz) = 6517825
diff --git a/graphics/mapnik/pkg-descr b/graphics/mapnik/pkg-descr
new file mode 100644
index 000000000000..7a59c514f313
--- /dev/null
+++ b/graphics/mapnik/pkg-descr
@@ -0,0 +1,15 @@
+Mapnik is a Free Toolkit for developing mapping applications. It's
+written in C++ and there are Python bindings to facilitate fast-paced
+agile development. It can comfortably be used for both desktop and web
+development, which was something wanted from the beginning.
+
+Mapnik is about making beautiful maps. It uses the AGG library and
+offers world class anti-aliasing rendering with subpixel accuracy for
+geographic data. It is written from scratch in modern C++ and doesn't
+suffer from design decisions made a decade ago. When it comes to
+handling common software tasks such as memory management, filesystem
+access, regular expressions, parsing and so on, Mapnik doesn't re-invent
+the wheel, but utilizes best of breed industry standard libraries from
+boost.org.
+
+WWW: http://www.mapnik.org/
diff --git a/graphics/mapnik/pkg-plist b/graphics/mapnik/pkg-plist
new file mode 100644
index 000000000000..c93213ed9ab4
--- /dev/null
+++ b/graphics/mapnik/pkg-plist
@@ -0,0 +1,143 @@
+bin/shapeindex
+include/mapnik/wkb.hpp
+include/mapnik/coord.hpp
+include/mapnik/utils.hpp
+include/mapnik/filter.hpp
+include/mapnik/pool.hpp
+include/mapnik/image_util.hpp
+include/mapnik/rule.hpp
+include/mapnik/load_map.hpp
+include/mapnik/datasource_cache.hpp
+include/mapnik/text_path.hpp
+include/mapnik/arrow.hpp
+include/mapnik/memory_datasource.hpp
+include/mapnik/query.hpp
+include/mapnik/math_expr.hpp
+include/mapnik/filter_factory.hpp
+include/mapnik/label_collision_detector.hpp
+include/mapnik/fill.hpp
+include/mapnik/geometry.hpp
+include/mapnik/filter_featureset.hpp
+include/mapnik/attribute.hpp
+include/mapnik/line_pattern_symbolizer.hpp
+include/mapnik/point_symbolizer.hpp
+include/mapnik/params.hpp
+include/mapnik/regex_filter.hpp
+include/mapnik/libxml2_loader.hpp
+include/mapnik/image_view.hpp
+include/mapnik/feature_factory.hpp
+include/mapnik/local_datasource.hpp
+include/mapnik/style_factory.hpp
+include/mapnik/attribute_collector.hpp
+include/mapnik/text_symbolizer.hpp
+include/mapnik/line_symbolizer.hpp
+include/mapnik/raster.hpp
+include/mapnik/polygon_symbolizer.hpp
+include/mapnik/css_color_parser.hpp
+include/mapnik/geom_util.hpp
+include/mapnik/image_reader.hpp
+include/mapnik/config_error.hpp
+include/mapnik/polygon_pattern_symbolizer.hpp
+include/mapnik/image_data.hpp
+include/mapnik/octree.hpp
+include/mapnik/ellipsoid.hpp
+include/mapnik/raster_symbolizer.hpp
+include/mapnik/vertex.hpp
+include/mapnik/scale_denominator.hpp
+include/mapnik/stroke.hpp
+include/mapnik/expression.hpp
+include/mapnik/value.hpp
+include/mapnik/logical.hpp
+include/mapnik/datasource.hpp
+include/mapnik/map.hpp
+include/mapnik/placement_finder.hpp
+include/mapnik/unicode.hpp
+include/mapnik/coord_array.hpp
+include/mapnik/factory.hpp
+include/mapnik/graphics.hpp
+include/mapnik/style.hpp
+include/mapnik/jpeg_io.hpp
+include/mapnik/color_factory.hpp
+include/mapnik/plugin.hpp
+include/mapnik/gamma.hpp
+include/mapnik/feature.hpp
+include/mapnik/hit_test_filter.hpp
+include/mapnik/symbolizer.hpp
+include/mapnik/png_io.hpp
+include/mapnik/feature_layer_desc.hpp
+include/mapnik/layer.hpp
+include/mapnik/filter_expression.hpp
+include/mapnik/label_placement.hpp
+include/mapnik/envelope.hpp
+include/mapnik/markers_converter.hpp
+include/mapnik/filter_parser.hpp
+include/mapnik/font_engine_freetype.hpp
+include/mapnik/quad_tree.hpp
+include/mapnik/enumeration.hpp
+include/mapnik/memory_featureset.hpp
+include/mapnik/agg_renderer.hpp
+include/mapnik/filter_parser_ast.hpp
+include/mapnik/feature_style_processor.hpp
+include/mapnik/attribute_descriptor.hpp
+include/mapnik/projection.hpp
+include/mapnik/feature_type_style.hpp
+include/mapnik/ptree_helpers.hpp
+include/mapnik/global.hpp
+include/mapnik/config.hpp
+include/mapnik/ctrans.hpp
+include/mapnik/spatial.hpp
+include/mapnik/color.hpp
+include/mapnik/vertex_transform.hpp
+include/mapnik/vertex_vector.hpp
+include/mapnik/markers_symbolizer.hpp
+include/mapnik/save_map.hpp
+include/mapnik/shield_symbolizer.hpp
+include/mapnik/memory.hpp
+include/mapnik/filter_visitor.hpp
+include/mapnik/comparison.hpp
+include/mapnik/proj_transform.hpp
+include/mapnik/distance.hpp
+lib/libmapnik.so
+lib/libmapnik.so.0.5
+lib/libmapnik.so.0.5.0
+lib/mapnik/input/raster.input
+lib/mapnik/input/shape.input
+lib/mapnik/fonts/DejaVuSansMono-Oblique.ttf
+lib/mapnik/fonts/DejaVuSerifCondensed-Bold.ttf
+lib/mapnik/fonts/DejaVuSansCondensed-Oblique.ttf
+lib/mapnik/fonts/DejaVuSansCondensed-Bold.ttf
+lib/mapnik/fonts/DejaVuSans-Oblique.ttf
+lib/mapnik/fonts/DejaVuSerifCondensed-BoldOblique.ttf
+lib/mapnik/fonts/DejaVuSansCondensed.ttf
+lib/mapnik/fonts/DejaVuSansMono-Bold.ttf
+lib/mapnik/fonts/DejaVuSans.ttf
+lib/mapnik/fonts/DejaVuSans-Bold.ttf
+lib/mapnik/fonts/DejaVuSerifCondensed-Oblique.ttf
+lib/mapnik/fonts/DejaVuSerif-Oblique.ttf
+lib/mapnik/fonts/DejaVuSans-ExtraLight.ttf
+lib/mapnik/fonts/DejaVuSerif.ttf
+lib/mapnik/fonts/DejaVuSerif-BoldOblique.ttf
+lib/mapnik/fonts/DejaVuSerifCondensed.ttf
+lib/mapnik/fonts/DejaVuSansCondensed-BoldOblique.ttf
+lib/mapnik/fonts/DejaVuSansMono-BoldOblique.ttf
+lib/mapnik/fonts/DejaVuSans-BoldOblique.ttf
+lib/mapnik/fonts/DejaVuSerif-Bold.ttf
+lib/mapnik/fonts/DejaVuSansMono.ttf
+%%PYTHON_SITELIBDIR%%/mapnik/__init__.py
+%%PYTHON_SITELIBDIR%%/mapnik/paths.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/wms130.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/WMS.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/wms111.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/cgiserver.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/__init__.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/common.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/configparser.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/exceptions.py
+%%PYTHON_SITELIBDIR%%/mapnik/ogcserver/wsgi.py
+%%PYTHON_SITELIBDIR%%/mapnik/_mapnik.so
+@dirrm %%PYTHON_SITELIBDIR%%/mapnik/ogcserver
+@dirrm %%PYTHON_SITELIBDIR%%/mapnik
+@dirrm lib/mapnik/input
+@dirrm lib/mapnik/fonts
+@dirrm lib/mapnik
+@dirrm include/mapnik