aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-10-12 03:08:02 +0800
committermarino <marino@FreeBSD.org>2015-10-12 03:08:02 +0800
commit939e01005e87fb4173b48027b276b2068a190b49 (patch)
treea2d466e6c7c0ef74c17ac289af88c9e106dd08e3
parent43e20a5bc73d1b2d0bfb1e197004f6463f4380c6 (diff)
downloadfreebsd-ports-gnome-939e01005e87fb4173b48027b276b2068a190b49.tar.gz
freebsd-ports-gnome-939e01005e87fb4173b48027b276b2068a190b49.tar.zst
freebsd-ports-gnome-939e01005e87fb4173b48027b276b2068a190b49.zip
lang/fpc-units: Finally fix default build on FreeBSD 9
On FreeBSD9, libEGL is built by GCC which requires binutils as a run depends. fpc-cairo requires libEGL. fpc-libbfd and binutils conflict with each other due to both installing the same header. Thus, on FreeBSD 9, the BFD and CAIRO options cannot coexist. Since both were set on by default, no binary package for fpc-units has built for months. Since there is no mechanism to set options by release, I use bmake's exist() function to check for /usr/include/lwres which only exists on FreeBSD 9. If it's present, the BFD option is disabled by default. This should restore the building of the fpc-units package on FreeBSD 9. Reported by: pkg-fallout (for months)
-rw-r--r--lang/fpc-units/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/fpc-units/Makefile b/lang/fpc-units/Makefile
index 6daa31f39763..7f70acecdec7 100644
--- a/lang/fpc-units/Makefile
+++ b/lang/fpc-units/Makefile
@@ -96,7 +96,7 @@ X11_DESC= Interface to X windows server
XFORMS_DESC= Interface to X-Forms
ZLIB_DESC= Interface to the zlib compression library
-OPTIONS_DEFAULT=A52 ASPELL BFD BZIP2 CAIRO CHM DBUS DBLIB DTS FASTCGI FCL-ASYNC FCL-BASE \
+OPTIONS_DEFAULT=A52 ASPELL BZIP2 CAIRO CHM DBUS DBLIB DTS FASTCGI FCL-ASYNC FCL-BASE \
FCL-EXTRA FCL-DB FCL-FPCUNIT FCL-IMAGE FCL-JS FCL-JSON FCL-NET FCL-PASSRC \
FCL-PROCESS FCL-REGISTRY FCL-RES FCL-WEB FCL-XML FFTW FPINDEXER \
FPMKUNIT FPPKG FV GDBM GMP GTK2 HERMES ICONVENC \
@@ -105,6 +105,12 @@ OPTIONS_DEFAULT=A52 ASPELL BFD BZIP2 CAIRO CHM DBUS DBLIB DTS FASTCGI FCL-ASYNC
PXLIB RSVG REXX SDL SNDFILE SVGALIB SYMBOLIC SYSLOG TCL UNZIP USERS \
UTMP UUID X11 XFORMS ZLIB
+.if !exists(/usr/include/lwres) # directory only exists on FreeBSD 9
+# On FreeBSD 9, CAIRO is built with GCC which pulls in binutils
+# binutils and BFD conflict, so BFD and CAIRO cannot coexist of F9
+OPTIONS_DEFAULT+= BFD
+.endif
+
.include <bsd.port.options.mk>
UNITS_SELECTED= #