aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-06-13 13:23:12 +0800
committerknu <knu@FreeBSD.org>2004-06-13 13:23:12 +0800
commit9e5c6b77f130b9b52858c0e2bd21819bbf6971e8 (patch)
tree7840c725fd45bd313d7225c00158908ce5e51d8b
parent1aa08fc99bac38dc52e061faa056716955738709 (diff)
downloadfreebsd-ports-gnome-9e5c6b77f130b9b52858c0e2bd21819bbf6971e8.tar.gz
freebsd-ports-gnome-9e5c6b77f130b9b52858c0e2bd21819bbf6971e8.tar.zst
freebsd-ports-gnome-9e5c6b77f130b9b52858c0e2bd21819bbf6971e8.zip
Add p5-Template-Plugin-MP3, a TT Plugin that wraps around the
MP3::Info module.
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Plugin-MP3/Makefile26
-rw-r--r--www/p5-Template-Plugin-MP3/distinfo2
-rw-r--r--www/p5-Template-Plugin-MP3/pkg-descr4
-rw-r--r--www/p5-Template-Plugin-MP3/pkg-plist4
5 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c60f19480544..c00442a5d222 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -482,6 +482,7 @@
SUBDIR += p5-Sledge-SessionManager-CookieStore
SUBDIR += p5-Sledge-Template-Expr
SUBDIR += p5-Template-Plugin-Comma
+ SUBDIR += p5-Template-Plugin-MP3
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
SUBDIR += p5-WWW-Automate
diff --git a/www/p5-Template-Plugin-MP3/Makefile b/www/p5-Template-Plugin-MP3/Makefile
new file mode 100644
index 000000000000..cc3a2cbf5783
--- /dev/null
+++ b/www/p5-Template-Plugin-MP3/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Template-Plugin-MP3
+# Date created: 13 June 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Plugin-MP3
+PORTVERSION= 1.01
+CATEGORIES= www textproc audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= TT Plugin that wraps around the MP3::Info module
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Plugin::MP3.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Plugin-MP3/distinfo b/www/p5-Template-Plugin-MP3/distinfo
new file mode 100644
index 000000000000..38c093cfa8a9
--- /dev/null
+++ b/www/p5-Template-Plugin-MP3/distinfo
@@ -0,0 +1,2 @@
+MD5 (Template-Plugin-MP3-1.01.tar.gz) = b19c9ca6448a0dd971ee0b41d89f5247
+SIZE (Template-Plugin-MP3-1.01.tar.gz) = 17613
diff --git a/www/p5-Template-Plugin-MP3/pkg-descr b/www/p5-Template-Plugin-MP3/pkg-descr
new file mode 100644
index 000000000000..0de9cdece061
--- /dev/null
+++ b/www/p5-Template-Plugin-MP3/pkg-descr
@@ -0,0 +1,4 @@
+Template::Plugin::MP3 is a plugin for TT, which provides a simple
+wrapper for using "MP3::Info" in object oriented mode.
+
+WWW: http://search.cpan.org/search?dist=Template-Plugin-MP3
diff --git a/www/p5-Template-Plugin-MP3/pkg-plist b/www/p5-Template-Plugin-MP3/pkg-plist
new file mode 100644
index 000000000000..c5b03974e4ef
--- /dev/null
+++ b/www/p5-Template-Plugin-MP3/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/MP3/.packlist
+%%SITE_PERL%%/Template/Plugin/MP3.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/MP3
+@unexec rmdir %D/%%SITE_PERL%%/Template/Plugin 2>/dev/null || true