aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-02-12 11:08:53 +0800
committerlioux <lioux@FreeBSD.org>2001-02-12 11:08:53 +0800
commit9fdac51448c019711339f0e816314d153e8786c9 (patch)
tree9923d9e0008f73061f6fdb37ba80c65f850c4658
parent4a3d42b0bd3eebf5a44ce7e642d1f89cef79d2ab (diff)
downloadfreebsd-ports-gnome-9fdac51448c019711339f0e816314d153e8786c9.tar.gz
freebsd-ports-gnome-9fdac51448c019711339f0e816314d153e8786c9.tar.zst
freebsd-ports-gnome-9fdac51448c019711339f0e816314d153e8786c9.zip
Add initial revision of port of a patch to stock qmail supporting
MySQL queries from within qmail MySQL patch version 1.1.1. The author does not advise the use of the latest patch version 1.1.6 under FreeBSD This is a meta port both including and dependent on the main port qmail Makefile
-rw-r--r--mail/Makefile1
-rw-r--r--mail/qmail-mysql/Makefile46
-rw-r--r--mail/qmail-mysql/pkg-comment1
-rw-r--r--mail/qmail-mysql/pkg-descr11
-rw-r--r--mail/qmail-mysql/pkg-message19
5 files changed, 78 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4dbc32db2d74..81591677abf9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -119,6 +119,7 @@
SUBDIR += qmail
SUBDIR += qmail-contrib
SUBDIR += qmail-ldap
+ SUBDIR += qmail-mysql
SUBDIR += qmail-tls
SUBDIR += qmailadmin
SUBDIR += qmailanalog
diff --git a/mail/qmail-mysql/Makefile b/mail/qmail-mysql/Makefile
new file mode 100644
index 000000000000..7b4cee0094d3
--- /dev/null
+++ b/mail/qmail-mysql/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: qmail-mysql
+# Date created: 6 Feb 2001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmail
+PORTVERSION= ${QMAIL_VERSION}.${MYSQL_PATCH_VERSION}
+CATEGORIES= mail
+PKGNAMESUFFIX= -mysql
+
+PATCH_SITES+= http://iain.cx/unix/qmail/download/
+PATCHFILES+= qmail-mysql-${MYSQL_PATCH_VERSION}.patch
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+MYSQL_PATCH_VERSION= 1.1.1
+
+.if !defined(PRE_MK_INCLUDED)
+.include <bsd.port.pre.mk>
+.endif
+
+#PREFIX= /var/qmail-mysql
+
+# Yet anther ugly hack (works due to code inside the main qmail port)
+yetanotherone-post-patch: qmail-mysql-post-patch
+
+qmail-mysql-post-patch:
+ @${PERL} -pi -ne \
+ "s|/usr/local/mysql/lib|${LOCALBASE}/lib|;s|/usr/local/mysql/include|${LOCALBASE}/include|;s|-lm|-lm -lz|" \
+ ${WRKSRC}/Makefile
+
+# Local overrides
+MASTERDIR= ${PORTSDIR}/mail/qmail
+#MASTERDIR= ${.CURDIR}/../qmail
+PKGDIR_LOCAL= ${.CURDIR}
+COMMENT= ${PKGDIR_LOCAL}/pkg-comment
+DESCR= ${PKGDIR_LOCAL}/pkg-descr
+PKGMESSAGE= ${PKGDIR_LOCAL}/pkg-message
+
+PRE_MK_INCLUDED= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/qmail-mysql/pkg-comment b/mail/qmail-mysql/pkg-comment
new file mode 100644
index 000000000000..00bcf9585dd0
--- /dev/null
+++ b/mail/qmail-mysql/pkg-comment
@@ -0,0 +1 @@
+A SECURE, reliable, and FAST MTA for UNIX systems WITH MySQL support
diff --git a/mail/qmail-mysql/pkg-descr b/mail/qmail-mysql/pkg-descr
new file mode 100644
index 000000000000..b9a9449176c5
--- /dev/null
+++ b/mail/qmail-mysql/pkg-descr
@@ -0,0 +1,11 @@
+What is is: [excerpt from the patch homepage]
+
+A few people have done qmail - MySQL integration and this is my
+crack at it. My work is based on takeshi@softagency.co.jp's patches,
+which you can find at http://www.softagency.co.jp/mysql/qmail.en.html.
+However I wanted to tidy up some of the code to make it use strallocs
+and do more error checking. I also wanted to simplify the configuration,
+whilst at the same time allowing more flexibility. Plus there were
+some things I just didn't want: quotas and APOP support for example...
+
+WWW: http://iain.cx/unix/qmail/mysql.php
diff --git a/mail/qmail-mysql/pkg-message b/mail/qmail-mysql/pkg-message
new file mode 100644
index 000000000000..3eeb0f503464
--- /dev/null
+++ b/mail/qmail-mysql/pkg-message
@@ -0,0 +1,19 @@
+ ATTENTIONATTENTION:
+
+Please make sure that you read /var/qmail/doc/PORT_NOTES.
+It contains important information about testing and configuring
+qmail, and finally replacing sendmail with qmail.
+
+You should also add /var/qmail/man to your MANPATH (see manpath(1)
+or login.conf(5)).
+
+Do not forget to read http://iain.cx/unix/qmail/mysql.php. After all,
+this is NOT our old stock qmail.
+
+You can enable qmail as your default mailer:
+
+# this will disable the default MTA
+1) do "make disable-sendmail"
+
+# enable qmail as your default MTA
+2) do "make enable-qmail"