aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-07-21 20:56:52 +0800
committerpi <pi@FreeBSD.org>2015-07-21 20:56:52 +0800
commita0d2f23a4f488a49ff56a6fb604ab405159a62f5 (patch)
treedc4f1f44e7690a60a861e567dbe9474d26071c48
parent25a6847c934a161eab9239138f6a45079a4cad8b (diff)
downloadfreebsd-ports-gnome-a0d2f23a4f488a49ff56a6fb604ab405159a62f5.tar.gz
freebsd-ports-gnome-a0d2f23a4f488a49ff56a6fb604ab405159a62f5.tar.zst
freebsd-ports-gnome-a0d2f23a4f488a49ff56a6fb604ab405159a62f5.zip
mail/spamassassin, japanese/spamassassin: fix bug with dns/p5-Net-DNS change
Now that a port dns/p5-Net-DNS has been upgraded to version 1.01, this revealed an incompatibility with DNS resolving in SpamAssassin. In short: Net::DNS::Packet->new no longer sets the RD (recursion desired) bit in new packets, so essentially DNS queries no longer work. Details at: https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7223 To bridge the time until SpamAssassin 3.4.2 gets released, the attached patch is needed ( equivalent to https://svn.apache.org/viewvc?view=rev&rev=1691992 ). For earlier version of dns/p5-Net-DNS this patch is redundant, but does no harm. PR: 201741 Submitted by: Mark.Martinec@ijs.si
-rw-r--r--japanese/spamassassin/Makefile2
-rw-r--r--mail/spamassassin/Makefile2
-rw-r--r--mail/spamassassin/files/patch-DnsResolver.pm12
3 files changed, 14 insertions, 2 deletions
diff --git a/japanese/spamassassin/Makefile b/japanese/spamassassin/Makefile
index ac413ec1a61b..dae8e33d7609 100644
--- a/japanese/spamassassin/Makefile
+++ b/japanese/spamassassin/Makefile
@@ -1,7 +1,7 @@
# Created by: TAOKA Fumiyoshi
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= japanese mail perl5
PKGNAMEPREFIX= ja-
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index 5b8ee16200ea..d16ca91ecae9 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.1
-PORTREVISION?= 1 # also bump japanese/spamassassin
+PORTREVISION?= 2 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= APACHE/spamassassin/source CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
diff --git a/mail/spamassassin/files/patch-DnsResolver.pm b/mail/spamassassin/files/patch-DnsResolver.pm
new file mode 100644
index 000000000000..f72975de63b7
--- /dev/null
+++ b/mail/spamassassin/files/patch-DnsResolver.pm
@@ -0,0 +1,12 @@
+--- lib/Mail/SpamAssassin/DnsResolver.pm 2015/07/20 18:23:18 1691991
++++ lib/Mail/SpamAssassin/DnsResolver.pm 2015/07/20 18:24:48 1691992
+@@ -592,6 +592,9 @@
+ };
+
+ if ($packet) {
++ # RD flag needs to be set explicitly since Net::DNS 1.01, Bug 7223
++ $packet->header->rd(1);
++
+ # my $udp_payload_size = $self->{res}->udppacketsize;
+ my $udp_payload_size = $self->{conf}->{dns_options}->{edns};
+ if ($udp_payload_size && $udp_payload_size > 512) {