aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-12-02 02:39:18 +0800
committerbarner <barner@FreeBSD.org>2005-12-02 02:39:18 +0800
commita8d6eb1cbafe948072ed6a8a49d940f59b4ff844 (patch)
tree60805b182e31a7a82df09b2958df0d28c3c64046
parentda02b082445efec409ea2f837d9b9d048e4ea227 (diff)
downloadfreebsd-ports-gnome-a8d6eb1cbafe948072ed6a8a49d940f59b4ff844.tar.gz
freebsd-ports-gnome-a8d6eb1cbafe948072ed6a8a49d940f59b4ff844.tar.zst
freebsd-ports-gnome-a8d6eb1cbafe948072ed6a8a49d940f59b4ff844.zip
- Fix detection of device list by avoiding a conflict of the global ports
collection variable ${ARCH} and a variable of the same name in this port's Makefile - Bump PORTREVISION Reported by: Rudi Kramer <derth@wbs.co.za> on freebsd-ports: http://lists.freebsd.org/pipermail/freebsd-ports/2005-November/027809.html
-rw-r--r--dns/noip/Makefile1
-rw-r--r--dns/noip/files/patch-Makefile14
2 files changed, 6 insertions, 9 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index 493490c9b572..8b0d51bb067c 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= noip
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/
diff --git a/dns/noip/files/patch-Makefile b/dns/noip/files/patch-Makefile
index de226c616f08..685fc7cd614b 100644
--- a/dns/noip/files/patch-Makefile
+++ b/dns/noip/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Thu May 8 23:13:28 2003
-+++ Makefile Fri Aug 29 10:22:57 2003
-@@ -1,16 +1,16 @@
+--- Makefile.orig Sat Aug 2 05:56:55 2003
++++ Makefile Wed Nov 30 01:35:17 2005
+@@ -1,13 +1,13 @@
TGT=noip2
-CC=gcc
+MYCC=${CC}
@@ -19,17 +19,13 @@
+#ARCH=linux
# for BSD systems that have getifaddr(), uncomment the next line
--#ARCH=bsd_with_getifaddrs
-+ARCH=bsd_with_getifaddrs
-
- # for early BSD systems without getifaddrs(), uncomment the next line
- #ARCH=bsd
+ #ARCH=bsd_with_getifaddrs
@@ -21,7 +21,7 @@
# ARCH=sun
${TGT}: Makefile ${TGT}.c
- ${CC} -Wall -g -O2 -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
-+ ${MYCC} ${CFLAGS} -D${ARCH} -DPREFIX=\"${MYPREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
++ ${MYCC} ${CFLAGS} -Dbsd_with_getifaddrs -DPREFIX=\"${MYPREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
install: ${TGT}
if [ ! -d ${BINDIR} ]; then mkdir -p ${BINDIR};fi