aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-12 02:22:15 +0800
committernork <nork@FreeBSD.org>2003-07-12 02:22:15 +0800
commitaa245c91d5201483715c3cf8b2c83a6267bc9cd8 (patch)
tree48c42c3498b518d86d7ac1155c2220ffc42d0339
parent9dff52f9d78aa1c03450d464ae480bcce59c2bea (diff)
downloadfreebsd-ports-gnome-aa245c91d5201483715c3cf8b2c83a6267bc9cd8.tar.gz
freebsd-ports-gnome-aa245c91d5201483715c3cf8b2c83a6267bc9cd8.tar.zst
freebsd-ports-gnome-aa245c91d5201483715c3cf8b2c83a6267bc9cd8.zip
Fix build.
PR: ports/53766 Submitted by: Ports Fury
-rw-r--r--deskutils/bulb/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/deskutils/bulb/Makefile b/deskutils/bulb/Makefile
index 1eb7c90f9d04..1828ed4a670d 100644
--- a/deskutils/bulb/Makefile
+++ b/deskutils/bulb/Makefile
@@ -14,15 +14,15 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME applet to warn about task terminations
USE_X_PREFIX= yes
-USE_GNOME= yes
+USE_GNOME= gnomelibs gnomeprefix libpanel
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
.include <bsd.port.mk>