aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-06-11 03:03:48 +0800
committermarcus <marcus@FreeBSD.org>2006-06-11 03:03:48 +0800
commitc4628cd5cac0e117d77bf01e5120433fda2de717 (patch)
tree0673312f8ad22748ddd9fb1c56085d2c1634ae6a
parent35ac6dab6add718e1e03f692b84638acc7c2ed37 (diff)
downloadfreebsd-ports-gnome-c4628cd5cac0e117d77bf01e5120433fda2de717.tar.gz
freebsd-ports-gnome-c4628cd5cac0e117d77bf01e5120433fda2de717.tar.zst
freebsd-ports-gnome-c4628cd5cac0e117d77bf01e5120433fda2de717.zip
* Rename our rc.d stop_postcmd function to be consistent with other scripts
* Create the directory to hold the dbus pidfile before starting as MFS-mounted /var's will not have this directory [1] PR: 98580 [1]
-rw-r--r--devel/dbus/Makefile2
-rw-r--r--devel/dbus/files/dbus.in10
2 files changed, 9 insertions, 3 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index ec287c2bdf43..9b816b0351f6 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dbus
PORTVERSION= 0.61
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/
diff --git a/devel/dbus/files/dbus.in b/devel/dbus/files/dbus.in
index 02d9c577595d..61638229f36b 100644
--- a/devel/dbus/files/dbus.in
+++ b/devel/dbus/files/dbus.in
@@ -21,9 +21,15 @@ rcvar=`set_rcvar`
command="%%PREFIX%%/bin/dbus-daemon"
pidfile="/var/run/dbus/${name}.pid"
-stop_postcmd=stop_postcmd
+start_precmd="dbus_prestart"
+stop_postcmd="dbus_poststop"
-stop_postcmd()
+dbus_prestart()
+{
+ mkdir -p $(dirname $pidfile)
+}
+
+dbus_poststop()
{
rm -f $pidfile
}