aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-12-12 05:31:40 +0800
committerkris <kris@FreeBSD.org>2004-12-12 05:31:40 +0800
commitd83d55ff31d54c1627fee6fa379c4cfaa9f91106 (patch)
tree44b6af407713d354c34ecb1d9e0a5634609a133e
parent6c3a5f46e7bec221b13b44a9a5dc1ef1b684154f (diff)
downloadfreebsd-ports-gnome-d83d55ff31d54c1627fee6fa379c4cfaa9f91106.tar.gz
freebsd-ports-gnome-d83d55ff31d54c1627fee6fa379c4cfaa9f91106.tar.zst
freebsd-ports-gnome-d83d55ff31d54c1627fee6fa379c4cfaa9f91106.zip
BROKEN on 4.x: Does not compile
-rw-r--r--graphics/evolvotron/Makefile8
-rw-r--r--lang/gcl/Makefile4
2 files changed, 11 insertions, 1 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 6cb4b29048a1..1ec5929136ed 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -28,6 +28,12 @@ MAKE_ENV= QTDIR="${QT_PREFIX}" \
CONFIGURE_ENV= QTDIR="${QT_PREFIX}" \
QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' ${WRKSRC}/common.pro
@${REINPLACE_CMD} -e 's,bin/bash,bin/sh,' ${WRKSRC}/configure
@@ -41,4 +47,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/evolvotron.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/gcl/Makefile b/lang/gcl/Makefile
index dcc929a39d0b..bd451df2f807 100644
--- a/lang/gcl/Makefile
+++ b/lang/gcl/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB= GCL_VER=${PORTVERSION}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
pre-configure:
${RM} -f ${WRKSRC}/configure
${SED} -i '' \