aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-06-02 15:24:33 +0800
committerdirk <dirk@FreeBSD.org>1999-06-02 15:24:33 +0800
commitd89ca43b1b20cc414c473844966a2d8b2ee3f304 (patch)
tree122446043c770ca0e20b027474add45c900bd5e3
parented950ee7b7ad28a976fa1fdce1ef75d046179ac0 (diff)
downloadfreebsd-ports-gnome-d89ca43b1b20cc414c473844966a2d8b2ee3f304.tar.gz
freebsd-ports-gnome-d89ca43b1b20cc414c473844966a2d8b2ee3f304.tar.zst
freebsd-ports-gnome-d89ca43b1b20cc414c473844966a2d8b2ee3f304.zip
include ${PREFIX}/include/openssl due to openssl upgrade.
-rw-r--r--ftp/curl/Makefile5
-rw-r--r--security/slush/files/patch-aa2
2 files changed, 4 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 712508f30a39..86e26d8eac53 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 December 1998
# Whom: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
#
-# $Id: Makefile,v 1.5 1999/05/06 14:09:05 flathill Exp $
+# $Id: Makefile,v 1.6 1999/05/27 12:33:09 kris Exp $
DISTNAME= curl-5.9
CATEGORIES= net www
@@ -20,7 +20,8 @@ BUILD_DEPENDS= ${PREFIX}/lib/libssl.a:${PORTSDIR}/security/openssl \
.endif
.if defined(USE_SSL)
-CONFIGURE_ENV+= CPPFLAGS='-I${PREFIX}/include' LDFLAGS='-L${PREFIX}/lib'
+CONFIGURE_ENV+= CPPFLAGS='-I${PREFIX}/include -I${PREFIX}/include/openssl' \
+ LDFLAGS='-L${PREFIX}/lib'
.endif
GNU_CONFIGURE= yes
diff --git a/security/slush/files/patch-aa b/security/slush/files/patch-aa
index 61c6f4332ea2..792cb9a4f523 100644
--- a/security/slush/files/patch-aa
+++ b/security/slush/files/patch-aa
@@ -14,7 +14,7 @@
CC=@CC@
INSTALL=@INSTALL@
-! CFLAGS=@CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -I/usr/local/include
+! CFLAGS=@CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -I/usr/local/include -I/usr/local/include/openssl
! LIBS=@LIBS@ -L/usr/local/lib -lssl -lcrypto $(EXTRA_SSL_LIBS) -lutil
all: slush slushd