aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-06-14 15:07:01 +0800
committerflo <flo@FreeBSD.org>2013-06-14 15:07:01 +0800
commite845ccde2c4943806f0b1d5f56e683d01dda43e5 (patch)
treee19afd2240e50e6700bab27b8a5260e21724b4d4
parent0b60e77ebe6f25258b28849ffbc0ff893416b9ea (diff)
downloadfreebsd-ports-gnome-e845ccde2c4943806f0b1d5f56e683d01dda43e5.tar.gz
freebsd-ports-gnome-e845ccde2c4943806f0b1d5f56e683d01dda43e5.tar.zst
freebsd-ports-gnome-e845ccde2c4943806f0b1d5f56e683d01dda43e5.zip
- create missing directories before chowning them [1]
- asterisk depends on gmake so use gmake to run the menuselect.makeopts target [1] - disable res_timing_kqueue module until we can figure out what's wrong with it [2] Submitted by: John Marino <draco@marino.st> [1] Reported by: Ian FREISLICH <ianf@clue.co.za>, [2] Alejandro Imass <ait@p2ee.org>, [2] Amr Elsharqawi <aelsharqawi@live.com> [2]
-rw-r--r--net/asterisk/Makefile7
-rw-r--r--net/asterisk/pkg-plist1
-rw-r--r--net/asterisk10/Makefile3
-rw-r--r--net/asterisk11/Makefile7
-rw-r--r--net/asterisk11/files/patch-main__Makefile15
5 files changed, 25 insertions, 8 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index cccdcd2445a1..3b27308d03e7 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= asterisk
PORTVERSION= 1.8.22.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -285,8 +286,8 @@ post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
post-configure:
-.if !empty(PORT_OPTIONS:MMYSQL) || !empty(PORT_OPTIONS:MNEWG711) || !empty(PORT_OPTIONS:MOOH323)
- @cd ${WRKSRC} && make menuselect.makeopts
+ @cd ${WRKSRC} && gmake menuselect.makeopts
+ @cd ${WRKSRC} && ./menuselect/menuselect --disable res_timing_kqueue menuselect.makeopts
.if ${PORT_OPTIONS:MMYSQL}
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --enable app_mysql menuselect.makeopts
@@ -298,9 +299,9 @@ post-configure:
.if ${PORT_OPTIONS:MNEWG711}
@cd ${WRKSRC} && ./menuselect/menuselect --enable G711_NEW_ALGORITHM menuselect.makeopts
.endif
-.endif
post-install:
+ @${MKDIR} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
@${CHOWN} -R ${ASTERISK_USER}:${ASTERISK_GROUP} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
.include <bsd.port.post.mk>
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index 0f49a54310da..7174e108f1d7 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -467,7 +467,6 @@ lib/asterisk/modules/res_realtime.so
%%WITH_SRTP%%lib/asterisk/modules/res_srtp.so
%%WITH_DAHDI%%lib/asterisk/modules/res_timing_dahdi.so
lib/asterisk/modules/res_timing_pthread.so
-lib/asterisk/modules/res_timing_kqueue.so
lib/asterisk/modules/app_adsiprog.so
lib/asterisk/modules/app_alarmreceiver.so
lib/asterisk/modules/app_amd.so
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 04c1694a3503..976bd839ebcc 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -279,7 +279,7 @@ post-patch:
post-configure:
.if !empty(PORT_OPTIONS:MMYSQL) || !empty(PORT_OPTIONS:MNEWG711) || !empty(PORT_OPTIONS:MOOH323) || !empty(PORT_OPTIONS:MH323)
- @cd ${WRKSRC} && make menuselect.makeopts
+ @cd ${WRKSRC} && gmake menuselect.makeopts
.if ${PORT_OPTIONS:MMYSQL}
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --enable app_mysql menuselect.makeopts
@@ -297,6 +297,7 @@ post-configure:
.endif
post-install:
+ @${MKDIR} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
@${CHOWN} -R ${ASTERISK_USER}:${ASTERISK_GROUP} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
.include <bsd.port.post.mk>
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 13d29e49af08..52ba34a5812b 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -2,6 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 11.4.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -269,8 +270,8 @@ post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
post-configure:
-.if !empty(PORT_OPTIONS:MMYSQL) || !empty(PORT_OPTIONS:MNEWG711) || !empty(PORT_OPTIONS:MOOH323)
- @cd ${WRKSRC} && make menuselect.makeopts
+ @cd ${WRKSRC} && gmake menuselect.makeopts
+ @cd ${WRKSRC} && ./menuselect/menuselect --disable res_timing_kqueue menuselect.makeopts
.if ${PORT_OPTIONS:MMYSQL}
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --enable app_mysql menuselect.makeopts
@@ -282,9 +283,9 @@ post-configure:
.if ${PORT_OPTIONS:MNEWG711}
@cd ${WRKSRC} && ./menuselect/menuselect --enable G711_NEW_ALGORITHM menuselect.makeopts
.endif
-.endif
post-install:
+ @${MKDIR} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
@${CHOWN} -R ${ASTERISK_USER}:${ASTERISK_GROUP} ${VARDIR}/db/asterisk ${VARDIR}/log/asterisk ${VARDIR}/spool/asterisk
.include <bsd.port.post.mk>
diff --git a/net/asterisk11/files/patch-main__Makefile b/net/asterisk11/files/patch-main__Makefile
new file mode 100644
index 000000000000..62555f5aa611
--- /dev/null
+++ b/net/asterisk11/files/patch-main__Makefile
@@ -0,0 +1,15 @@
+--- main/Makefile.orig 2013-06-13 19:07:52.590762266 +0200
++++ main/Makefile 2013-06-13 19:07:24.770763707 +0200
+@@ -215,9 +215,9 @@
+ endif
+ $(ECHO_PREFIX) echo " [LD] $^ -> $@"
+ $(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(CC_LDFLAGS_SO) $^ $(CC_LIBS)
+-ifneq ($(LDCONFIG),)
+- $(LDCONFIG) $(LDCONFIG_FLAGS) .
+-endif
++#ifneq ($(LDCONFIG),)
++# $(LDCONFIG) $(LDCONFIG_FLAGS) .
++#endif
+
+ $(ASTSSL_LIB): $(ASTSSL_LIB).$(ASTSSL_SO_VERSION)
+ $(LN) -sf $< $@