aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-27 16:48:03 +0800
committermiwi <miwi@FreeBSD.org>2014-02-27 16:48:03 +0800
commitec871593230618d554ef69e467d1302e7d0073ae (patch)
tree25fe5cd6561684cf374306620fea2bf07e89af8e
parente9ca59f522c5bec6bbd153a3be9f195a0e0ea822 (diff)
downloadfreebsd-ports-gnome-ec871593230618d554ef69e467d1302e7d0073ae.tar.gz
freebsd-ports-gnome-ec871593230618d554ef69e467d1302e7d0073ae.tar.zst
freebsd-ports-gnome-ec871593230618d554ef69e467d1302e7d0073ae.zip
- Stage support
- Update MASTER_SITES and WWW: line PR: 187043 Submitted by: Ports fury
-rw-r--r--x11-fonts/manu-gothica/Makefile27
-rw-r--r--x11-fonts/manu-gothica/pkg-descr2
-rw-r--r--x11-fonts/manu-gothica/pkg-plist14
3 files changed, 20 insertions, 23 deletions
diff --git a/x11-fonts/manu-gothica/Makefile b/x11-fonts/manu-gothica/Makefile
index 2c3b2c759063..0e7c36681f89 100644
--- a/x11-fonts/manu-gothica/Makefile
+++ b/x11-fonts/manu-gothica/Makefile
@@ -3,18 +3,16 @@
PORTNAME= manu-gothica
DISTVERSION= 0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-fonts
-MASTER_SITES= http://www.bryld.info/filer/
+MASTER_SITES= http://www.bryld.dk/filer/ \
+ http://www.kswla.org/KATG%20Page%20Files/
DISTNAME= manugot19
EXTRACT_SUFX= .ttf
MAINTAINER= ports@FreeBSD.org
COMMENT= Old German blackletter handwriting (Suetterlin)
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-10
-
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -23,21 +21,16 @@ RESTRICTED= The font is free for personal use
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKSRC}
-NO_BUILD= yes
+NO_BUILD= yes
NO_WRKSUBDIR= yes
-FONTSDIR= lib/X11/fonts/TTF/
-PLIST_SUB+= FONTSDIR=${FONTSDIR}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/${FONTSDIR}
- ${INSTALL_DATA} ${WRKSRC}/manugot19.ttf ${PREFIX}/${FONTSDIR}/manugot19.ttf
-
-post-install:
- @${ECHO_MSG} "===> Running fc-cache"
- -${LOCALBASE}/bin/fc-cache -f -v ${PREFIX}/${FONTSDIR}
- @${ECHO_MSG}
- @${ECHO_MSG}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} manugot19.ttf \
+ ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/fonts/TTF
+ @${LN} -sf ${DATADIR}/manugot19.ttf \
+ ${STAGEDIR}${PREFIX}/lib/X11/fonts/TTF
.include <bsd.port.mk>
diff --git a/x11-fonts/manu-gothica/pkg-descr b/x11-fonts/manu-gothica/pkg-descr
index 29adaf8cb0dd..a8be48b6dd67 100644
--- a/x11-fonts/manu-gothica/pkg-descr
+++ b/x11-fonts/manu-gothica/pkg-descr
@@ -2,3 +2,5 @@ This True Type Font has been based on the Old German handwriting as it
was taught in Schleswig and Germany around Year 1900 (Suetterlin). If
you study sources from that time and before, it is important to be
familiar with this writing style. The font is free for personal use.
+
+WWW: http://www.bryld.dk/hent-filer/
diff --git a/x11-fonts/manu-gothica/pkg-plist b/x11-fonts/manu-gothica/pkg-plist
index 862fd8a08fad..44971ffc4b41 100644
--- a/x11-fonts/manu-gothica/pkg-plist
+++ b/x11-fonts/manu-gothica/pkg-plist
@@ -1,6 +1,8 @@
-%%FONTSDIR%%/manugot19.ttf
-@exec %D/bin/fc-cache -f -v %D/%%FONTSDIR%% 2>/dev/null || true
-@unexec rm %D/%%FONTSDIR%%/fonts.cache-1 2>/dev/null || true
-@unexec %D/bin/fc-cache -f -v %D/%%FONTSDIR%% 2>/dev/null || true
-@unexec if [ -e %D/%%FONTSDIR%%/fonts.cache-1 -a ! -s %D/%%FONTSDIR%%/fonts.cache-1 ]; then rm %D/%%FONTSDIR%%/fonts.cache-1; fi
-@dirrmtry %%FONTSDIR%%
+lib/X11/fonts/TTF/manugot19.ttf
+%%DATADIR%%/manugot19.ttf
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/lib/X11/fonts/TTF 2>/dev/null || true
+@unexec rm %D/lib/X11/fonts/TTF/fonts.cache-1 2>/dev/null || true
+@unexec %%LOCALBASE%%/bin/fc-cache -f -v %D/lib/X11/fonts/TTF 2>/dev/null || true
+@unexec if [ -e %D/lib/X11/fonts/TTF/fonts.cache-1 -a ! -s %D/lib/X11/fonts/TTF/fonts.cache-1 ]; then rm %D/lib/X11/fonts/TTF/fonts.cache-1; fi
+@dirrm %%DATADIR%%
+@dirrmtry lib/X11/fonts/TTF