aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-05-20 06:07:31 +0800
committermakc <makc@FreeBSD.org>2009-05-20 06:07:31 +0800
commitfc93bfe9f42d19c1975dd8f7241096546f29391e (patch)
tree3303f8ceff7c964e953b094e2f6555c5649ba6cd
parent892f5a2beb4bfff81d8ba28095796c94a2c3a6b4 (diff)
downloadfreebsd-ports-gnome-fc93bfe9f42d19c1975dd8f7241096546f29391e.tar.gz
freebsd-ports-gnome-fc93bfe9f42d19c1975dd8f7241096546f29391e.tar.zst
freebsd-ports-gnome-fc93bfe9f42d19c1975dd8f7241096546f29391e.zip
Fix build with python26
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/calligra/files/patch-configure44
-rw-r--r--editors/koffice-kde3/Makefile3
-rw-r--r--editors/koffice-kde3/files/patch-configure44
-rw-r--r--editors/koffice-kde4/Makefile3
-rw-r--r--editors/koffice-kde4/files/patch-configure44
6 files changed, 99 insertions, 42 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index d6361464b759..7f7fdf9deef0 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -50,4 +50,7 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
--with-pqxx-includes=${LOCALBASE}/include \
--with-pqxx-libraries=${LOCALBASE}/lib
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PYTHON_VER%%|${PYTHON_VER}|g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/editors/calligra/files/patch-configure b/editors/calligra/files/patch-configure
index 0d12a4a75ae3..98de59b3654b 100644
--- a/editors/calligra/files/patch-configure
+++ b/editors/calligra/files/patch-configure
@@ -1,14 +1,6 @@
-One solution proposed on the ports mailing list was to uninstall the ImageMagick port, rebuild editors/koffice-kde3 and then reinstall ImageMagick, while this works it is unacceptable to have to uninstall a port to get another port to build.
-
-The correct solution is to patch the source configure script to skip the detection of ImageMagick when GraphicsMagick is installed. see attached patch:
-
-Patch attached with submission follows:
-
---- configure.orig 2007-05-30 16:56:35.000000000 -0500
-+++ configure 2008-07-10 05:51:45.898085206 -0500
-@@ -33900,8 +33900,10 @@
-
- # Check for ImageMagick...
+--- ./configure.orig 2007-05-31 01:56:35.000000000 +0400
++++ ./configure 2009-05-20 01:27:42.000000000 +0400
+@@ -33902,6 +33902,8 @@
have_imagemagick=no
@@ -17,7 +9,7 @@ Patch attached with submission follows:
{ echo "$as_me:$LINENO: checking for Magick-config" >&5
echo $ECHO_N "checking for Magick-config... $ECHO_C" >&6; }
if test -n "$MAGICK_CONFIG"; then
-@@ -34014,7 +34017,7 @@
+@@ -34014,7 +34016,7 @@
LIBMAGICK_RPATH=
fi
@@ -26,5 +18,29 @@ Patch attached with submission follows:
-
-
+@@ -38922,10 +38924,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5
+@@ -51126,10 +51128,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index d6361464b759..7f7fdf9deef0 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -50,4 +50,7 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
--with-pqxx-includes=${LOCALBASE}/include \
--with-pqxx-libraries=${LOCALBASE}/lib
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PYTHON_VER%%|${PYTHON_VER}|g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/editors/koffice-kde3/files/patch-configure b/editors/koffice-kde3/files/patch-configure
index 0d12a4a75ae3..98de59b3654b 100644
--- a/editors/koffice-kde3/files/patch-configure
+++ b/editors/koffice-kde3/files/patch-configure
@@ -1,14 +1,6 @@
-One solution proposed on the ports mailing list was to uninstall the ImageMagick port, rebuild editors/koffice-kde3 and then reinstall ImageMagick, while this works it is unacceptable to have to uninstall a port to get another port to build.
-
-The correct solution is to patch the source configure script to skip the detection of ImageMagick when GraphicsMagick is installed. see attached patch:
-
-Patch attached with submission follows:
-
---- configure.orig 2007-05-30 16:56:35.000000000 -0500
-+++ configure 2008-07-10 05:51:45.898085206 -0500
-@@ -33900,8 +33900,10 @@
-
- # Check for ImageMagick...
+--- ./configure.orig 2007-05-31 01:56:35.000000000 +0400
++++ ./configure 2009-05-20 01:27:42.000000000 +0400
+@@ -33902,6 +33902,8 @@
have_imagemagick=no
@@ -17,7 +9,7 @@ Patch attached with submission follows:
{ echo "$as_me:$LINENO: checking for Magick-config" >&5
echo $ECHO_N "checking for Magick-config... $ECHO_C" >&6; }
if test -n "$MAGICK_CONFIG"; then
-@@ -34014,7 +34017,7 @@
+@@ -34014,7 +34016,7 @@
LIBMAGICK_RPATH=
fi
@@ -26,5 +18,29 @@ Patch attached with submission follows:
-
-
+@@ -38922,10 +38924,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5
+@@ -51126,10 +51128,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index d6361464b759..7f7fdf9deef0 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -50,4 +50,7 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
--with-pqxx-includes=${LOCALBASE}/include \
--with-pqxx-libraries=${LOCALBASE}/lib
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PYTHON_VER%%|${PYTHON_VER}|g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/editors/koffice-kde4/files/patch-configure b/editors/koffice-kde4/files/patch-configure
index 0d12a4a75ae3..98de59b3654b 100644
--- a/editors/koffice-kde4/files/patch-configure
+++ b/editors/koffice-kde4/files/patch-configure
@@ -1,14 +1,6 @@
-One solution proposed on the ports mailing list was to uninstall the ImageMagick port, rebuild editors/koffice-kde3 and then reinstall ImageMagick, while this works it is unacceptable to have to uninstall a port to get another port to build.
-
-The correct solution is to patch the source configure script to skip the detection of ImageMagick when GraphicsMagick is installed. see attached patch:
-
-Patch attached with submission follows:
-
---- configure.orig 2007-05-30 16:56:35.000000000 -0500
-+++ configure 2008-07-10 05:51:45.898085206 -0500
-@@ -33900,8 +33900,10 @@
-
- # Check for ImageMagick...
+--- ./configure.orig 2007-05-31 01:56:35.000000000 +0400
++++ ./configure 2009-05-20 01:27:42.000000000 +0400
+@@ -33902,6 +33902,8 @@
have_imagemagick=no
@@ -17,7 +9,7 @@ Patch attached with submission follows:
{ echo "$as_me:$LINENO: checking for Magick-config" >&5
echo $ECHO_N "checking for Magick-config... $ECHO_C" >&6; }
if test -n "$MAGICK_CONFIG"; then
-@@ -34014,7 +34017,7 @@
+@@ -34014,7 +34016,7 @@
LIBMAGICK_RPATH=
fi
@@ -26,5 +18,29 @@ Patch attached with submission follows:
-
-
+@@ -38922,10 +38924,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5
+@@ -51126,10 +51128,10 @@
+
+
+
+-if test -z ""2.5""; then
++if test -z ""%%PYTHON_VER%%""; then
+ version="1.5"
+ else
+- version=""2.5""
++ version=""%%PYTHON_VER%%""
+ fi
+
+ { echo "$as_me:$LINENO: checking for Python$version" >&5