aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-11 06:29:46 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-11 06:29:46 +0800
commit001e04c61d3baf3269b03c425636d5ad54d13872 (patch)
tree35d52e5afd7c3b6cc5cfbcd65a342a6e1aec5863
parentf1905967fd2ad342f79d7e22df6d7e32451f49cf (diff)
downloadfreebsd-ports-gnome-001e04c61d3baf3269b03c425636d5ad54d13872.tar.gz
freebsd-ports-gnome-001e04c61d3baf3269b03c425636d5ad54d13872.tar.zst
freebsd-ports-gnome-001e04c61d3baf3269b03c425636d5ad54d13872.zip
gecko: attempt to unbreak aarch64
../../xpcom/reflect/xptcall/xptcall.o:(.data.rel.ro._ZTV14nsXPTCStubBase+0x28): undefined reference to `nsXPTCStubBase::Stub3()' ../../xpcom/reflect/xptcall/xptcall.o:(.data.rel.ro._ZTV14nsXPTCStubBase+0x30): undefined reference to `nsXPTCStubBase::Stub4()' [...] ../../xpcom/build/Unified_cpp_xpcom_build0.o:(.data.rel.ro._ZL16kFrozenFunctions+0x180): undefined reference to `NS_InvokeByIndex' ../../js/xpconnect/src/Unified_cpp_js_xpconnect_src1.o: In function `XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)': obj-aarch64-unknown-freebsd11.0/js/xpconnect/src/Unified_cpp_js_xpconnect_src1.cpp:(.text._ZN16XPCWrappedNative10CallMethodER14XPCCallContextNS_8CallModeE+0xd24): undefined reference to `NS_InvokeByIndex' ../../dom/xslt/xpath/Unified_cpp_dom_xslt_xpath2.o: In function `txXPCOMExtensionFunctionCall::evaluate(txIEvalContext*, txAExprResult**)': obj-aarch64-unknown-freebsd11.0/dom/xslt/xpath/Unified_cpp_dom_xslt_xpath2.cpp:(.text._ZN28txXPCOMExtensionFunctionCall8evaluateEP14txIEvalContextPP13txAExprResult+0xa5c): undefined reference to `NS_InvokeByIndex' /usr/bin/ld: libxul.so: hidden symbol `_ZN14nsXPTCStubBase7Stub234Ev' isn't defined /usr/bin/ld: final link failed: Bad value Reported by: pkg-fallout
-rw-r--r--mail/thunderbird/files/patch-bug133011913
-rw-r--r--www/firefox-esr/files/patch-bug133011913
-rw-r--r--www/firefox/files/patch-bug133011913
-rw-r--r--www/libxul/files/patch-bug133011913
-rw-r--r--www/seamonkey/files/patch-bug133011913
5 files changed, 65 insertions, 0 deletions
diff --git a/mail/thunderbird/files/patch-bug1330119 b/mail/thunderbird/files/patch-bug1330119
new file mode 100644
index 000000000000..17bf191ff961
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1330119
@@ -0,0 +1,13 @@
+diff --git xpcom/reflect/xptcall/md/unix/moz.build xpcom/reflect/xptcall/md/unix/moz.build
+index 019487bd69a2..a54026e70412 100644
+--- mozilla/xpcom/reflect/xptcall/md/unix/moz.build
++++ mozilla/xpcom/reflect/xptcall/md/unix/moz.build
+@@ -151,7 +151,7 @@ if CONFIG['OS_ARCH'] == 'NetBSD':
+ 'xptcstubs_netbsd_m68k.cpp'
+ ]
+
+-if CONFIG['OS_ARCH'] == 'Linux':
++if CONFIG['OS_ARCH'] in ('Linux', 'FreeBSD', 'NetBSD', 'OpenBSD'):
+ if CONFIG['OS_TEST'] == 'aarch64':
+ SOURCES += [
+ 'xptcinvoke_aarch64.cpp',
diff --git a/www/firefox-esr/files/patch-bug1330119 b/www/firefox-esr/files/patch-bug1330119
new file mode 100644
index 000000000000..012282795220
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1330119
@@ -0,0 +1,13 @@
+diff --git xpcom/reflect/xptcall/md/unix/moz.build xpcom/reflect/xptcall/md/unix/moz.build
+index 019487bd69a2..a54026e70412 100644
+--- xpcom/reflect/xptcall/md/unix/moz.build
++++ xpcom/reflect/xptcall/md/unix/moz.build
+@@ -151,7 +151,7 @@ if CONFIG['OS_ARCH'] == 'NetBSD':
+ 'xptcstubs_netbsd_m68k.cpp'
+ ]
+
+-if CONFIG['OS_ARCH'] == 'Linux':
++if CONFIG['OS_ARCH'] in ('Linux', 'FreeBSD', 'NetBSD', 'OpenBSD'):
+ if CONFIG['OS_TEST'] == 'aarch64':
+ SOURCES += [
+ 'xptcinvoke_aarch64.cpp',
diff --git a/www/firefox/files/patch-bug1330119 b/www/firefox/files/patch-bug1330119
new file mode 100644
index 000000000000..012282795220
--- /dev/null
+++ b/www/firefox/files/patch-bug1330119
@@ -0,0 +1,13 @@
+diff --git xpcom/reflect/xptcall/md/unix/moz.build xpcom/reflect/xptcall/md/unix/moz.build
+index 019487bd69a2..a54026e70412 100644
+--- xpcom/reflect/xptcall/md/unix/moz.build
++++ xpcom/reflect/xptcall/md/unix/moz.build
+@@ -151,7 +151,7 @@ if CONFIG['OS_ARCH'] == 'NetBSD':
+ 'xptcstubs_netbsd_m68k.cpp'
+ ]
+
+-if CONFIG['OS_ARCH'] == 'Linux':
++if CONFIG['OS_ARCH'] in ('Linux', 'FreeBSD', 'NetBSD', 'OpenBSD'):
+ if CONFIG['OS_TEST'] == 'aarch64':
+ SOURCES += [
+ 'xptcinvoke_aarch64.cpp',
diff --git a/www/libxul/files/patch-bug1330119 b/www/libxul/files/patch-bug1330119
new file mode 100644
index 000000000000..012282795220
--- /dev/null
+++ b/www/libxul/files/patch-bug1330119
@@ -0,0 +1,13 @@
+diff --git xpcom/reflect/xptcall/md/unix/moz.build xpcom/reflect/xptcall/md/unix/moz.build
+index 019487bd69a2..a54026e70412 100644
+--- xpcom/reflect/xptcall/md/unix/moz.build
++++ xpcom/reflect/xptcall/md/unix/moz.build
+@@ -151,7 +151,7 @@ if CONFIG['OS_ARCH'] == 'NetBSD':
+ 'xptcstubs_netbsd_m68k.cpp'
+ ]
+
+-if CONFIG['OS_ARCH'] == 'Linux':
++if CONFIG['OS_ARCH'] in ('Linux', 'FreeBSD', 'NetBSD', 'OpenBSD'):
+ if CONFIG['OS_TEST'] == 'aarch64':
+ SOURCES += [
+ 'xptcinvoke_aarch64.cpp',
diff --git a/www/seamonkey/files/patch-bug1330119 b/www/seamonkey/files/patch-bug1330119
new file mode 100644
index 000000000000..17bf191ff961
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1330119
@@ -0,0 +1,13 @@
+diff --git xpcom/reflect/xptcall/md/unix/moz.build xpcom/reflect/xptcall/md/unix/moz.build
+index 019487bd69a2..a54026e70412 100644
+--- mozilla/xpcom/reflect/xptcall/md/unix/moz.build
++++ mozilla/xpcom/reflect/xptcall/md/unix/moz.build
+@@ -151,7 +151,7 @@ if CONFIG['OS_ARCH'] == 'NetBSD':
+ 'xptcstubs_netbsd_m68k.cpp'
+ ]
+
+-if CONFIG['OS_ARCH'] == 'Linux':
++if CONFIG['OS_ARCH'] in ('Linux', 'FreeBSD', 'NetBSD', 'OpenBSD'):
+ if CONFIG['OS_TEST'] == 'aarch64':
+ SOURCES += [
+ 'xptcinvoke_aarch64.cpp',
span class='deletions'>-0/+1 * Add hyphenation dictionaries to the slave ports.mbr2003-04-092-0/+2 * Rejoice, for the long awaited upgrade to kde 3.1.1 is here!alane2003-04-066-4/+8 * - make portlint happierdinoex2003-04-052-2/+8 * Clear moonlight beckons.ade2003-03-0710-5/+5 * Remove pkg-comment from remaining master/slave port sets.ade2003-03-078-4/+4 * Add LANG to Makefile.mbr2003-03-022-0/+12 * Fix COMMENT and de-pkg-comment. Formerly there was no COMMENTFILEknu2003-02-212-1/+1 * De-pkg-comment.knu2003-02-212-1/+1 * De-pkg-comment.knu2003-02-212-1/+1 * De-pkg-comment.knu2003-02-214-2/+2 * Finish repo copy move from misc category: link to buildlioux2003-01-291-0/+2 * Update to KDE 3.1 releaselioux2003-01-298-264/+2214 * Fix dependency: editors/openoffice-pt -> portuguese/openofficelioux2002-12-092-2/+2 * Finish repo copy move: remove from old category, link into new, addlioux2002-12-071-0/+1 * Finish repo copy move: remove from old category, link into new, addlioux2002-12-071-0/+4 * After repo copy to newly created portuguese category, update alllioux2002-12-066-11/+15 * BROKEN: Does not build on 5.0kris2002-12-021-1/+7 * Remove www as secondary category. It is redundant in the slave port since mas...lioux2002-11-272-2/+2 * o Make PKGNAMEPREFIX language variant specific (i.e., pt_BR)lioux2002-11-272-4/+4 * added webalizer slave-ports.dinoex2002-11-243-0/+34 * Move br-ispell to portuguese category as ispell-pt_BR after repolioux2002-11-221-0/+1 * Update with appropriate info for portuguese category after repolioux2002-11-221-2/+3 * Repo-move textproc/pt-aspell to portuguese/aspell.knu2002-11-223-5/+7 * Set the default value of PKGNAMEPREFIX to "pt-".knu2002-11-181-0/+4 * Add several new real categories.knu2002-11-181-0/+5 * Add several new real categories.knu2002-11-181-0/+1 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-114-4/+2 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-074-2/+4 * The release notes say:trevor2002-10-151-0/+3 * I remove the linux-netscape6 ports from ports/french, ports/german,trevor2002-10-145-48/+52 * 1. Removed comments from pkg-plist files per will's request.alane2002-10-114-4/+4 * build aspell with dictionarydinoex2002-09-106-0/+46 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-258-16/+12 * Add OpenOffice.org spelling dictionary ports. They are based on MySpell,mbr2002-08-126-2/+38 * 1. Changed the lib depends on gettext to a build depends. This will meanalane2002-08-034-8/+8 * Bump PORTREVISION. KDE is fragile enough in its dependencies; we don'talane2002-08-024-0/+4 * Chase shlib rev of devel/gettextade2002-08-024-4/+4 * Add support for spelling dictionaries. Remove the pkg-plist for thembr2002-07-162-0/+2 * Fix MASTER_SITE_SUBDIR.will2002-07-104-4/+4