aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-08 04:42:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-08 04:42:38 +0800
commit00820f555cca8eab9f8edc70cc8a1d73c92a9ed8 (patch)
tree384c9432d138c3956ae11f8e8f3a9e8f703276d5
parentf383441b64eb856f9f44e5c066a4c188a070a4b1 (diff)
downloadfreebsd-ports-gnome-00820f555cca8eab9f8edc70cc8a1d73c92a9ed8.tar.gz
freebsd-ports-gnome-00820f555cca8eab9f8edc70cc8a1d73c92a9ed8.tar.zst
freebsd-ports-gnome-00820f555cca8eab9f8edc70cc8a1d73c92a9ed8.zip
- Convert USE_BZIP2 and USE_DOS2UNIX to USES
-rw-r--r--converters/osm2mp/Makefile3
-rw-r--r--devel/bennugd-core/Makefile4
-rw-r--r--devel/bennugd-modules/Makefile6
-rw-r--r--devel/gnucflow/Makefile3
-rw-r--r--devel/love5/Makefile5
-rw-r--r--devel/py-ode/Makefile3
-rw-r--r--games/blackshadeselite/Makefile3
-rw-r--r--games/bloodfrontier/Makefile3
-rw-r--r--games/caph/Makefile3
-rw-r--r--games/critterding/Makefile7
-rw-r--r--games/diameter/Makefile3
11 files changed, 14 insertions, 29 deletions
diff --git a/converters/osm2mp/Makefile b/converters/osm2mp/Makefile
index fe628adc67fe..55b3060233db 100644
--- a/converters/osm2mp/Makefile
+++ b/converters/osm2mp/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
LICENSE= GPLv2
-USE_BZIP2= yes
-USES= perl5
+USES= tar:bzip2 perl5
USE_PERL5= run
NO_BUILD= yes
diff --git a/devel/bennugd-core/Makefile b/devel/bennugd-core/Makefile
index d2121d3fb2d1..966a7ff902af 100644
--- a/devel/bennugd-core/Makefile
+++ b/devel/bennugd-core/Makefile
@@ -11,12 +11,12 @@ DISTNAME= bennugd-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= High level open source game development suite, core libs
-USE_BZIP2= yes
+USES= tar:bzip2 dos2unix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/libexec"
SUB_FILES= bgdc bgdi
USE_LDCONFIG= yes
-USE_DOS2UNIX= *.c *.h
+DOS2UNIX_GLOB= *.c *.h
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Segfaults on !i386
diff --git a/devel/bennugd-modules/Makefile b/devel/bennugd-modules/Makefile
index 4d8b15677d5e..601812e04f72 100644
--- a/devel/bennugd-modules/Makefile
+++ b/devel/bennugd-modules/Makefile
@@ -14,16 +14,14 @@ COMMENT= High level open source game development suite, modules
LIB_DEPENDS= libbgdrtm.so:${PORTSDIR}/devel/bennugd-core \
libpng.so:${PORTSDIR}/graphics/png
-USE_BZIP2= yes
+USES= tar:bzip2 dos2unix pkgconfig
USE_SDL= sdl mixer
GNU_CONFIGURE= yes
-USES= pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/bennugd"
CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
-
-USE_DOS2UNIX= *.c
+DOS2UNIX_GLOB= *.c
WRKSRC= ${WRKDIR}/bennugd/${PORTNAME}
diff --git a/devel/gnucflow/Makefile b/devel/gnucflow/Makefile
index 821e44c04d1b..3aa8946789ba 100644
--- a/devel/gnucflow/Makefile
+++ b/devel/gnucflow/Makefile
@@ -13,9 +13,8 @@ COMMENT= Tool to chart control flow within the C program
CONFLICTS= bsdcflow-[0-9]* cflow-[0-9]*
-USE_BZIP2= yes
+USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
-USES= gmake
INFO= cflow
diff --git a/devel/love5/Makefile b/devel/love5/Makefile
index 417bed595f0b..fab261f7f63b 100644
--- a/devel/love5/Makefile
+++ b/devel/love5/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
libfreetype.so:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake dos2unix
USE_SDL= sdl mixer
USE_GL= gl glu
USE_LUA= 5.1+
@@ -27,7 +26,7 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=5
-USE_DOS2UNIX= yes
+DOS2UNIX_FILES= src/system/love_system.cpp
PLIST_FILES= bin/love5
diff --git a/devel/py-ode/Makefile b/devel/py-ode/Makefile
index a20cdf864f03..26c4f9f5222d 100644
--- a/devel/py-ode/Makefile
+++ b/devel/py-ode/Makefile
@@ -15,8 +15,7 @@ COMMENT= Python bindings for The Open Dynamics Engine
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
-USE_BZIP2= yes
-
+USES= tar:bzip2
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= PyODE
diff --git a/games/blackshadeselite/Makefile b/games/blackshadeselite/Makefile
index 7eaf9f56dc94..c650781cd98f 100644
--- a/games/blackshadeselite/Makefile
+++ b/games/blackshadeselite/Makefile
@@ -13,8 +13,7 @@ COMMENT= Psychic Bodyguard FPS - protect the VIP
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= gmake openal:al,alut
-USE_BZIP2= yes
+USES= tar:bzip2 gmake openal:al,alut
USE_SDL= sdl
USE_GL= yes
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index 6b695c633a14..bf7f127fbd5d 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -13,9 +13,8 @@ COMMENT= Single- and multi-player first-person shooter based on Cube 2
LICENSE= ZLIB
-USES= gmake
+USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
-USE_BZIP2= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/caph/Makefile b/games/caph/Makefile
index 69a575cb1312..de1ab070a499 100644
--- a/games/caph/Makefile
+++ b/games/caph/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-USES= iconv
-USE_BZIP2= yes
+USES= tar:bzip2 iconv
USE_SDL= sdl
USE_GL= gl
diff --git a/games/critterding/Makefile b/games/critterding/Makefile
index e9c62604586a..cb6a4e7caf56 100644
--- a/games/critterding/Makefile
+++ b/games/critterding/Makefile
@@ -12,8 +12,7 @@ COMMENT= Evolving Artificial Life
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USE_BZIP2= yes
-USES= pkgconfig
+USES= tar:bzip2 pkgconfig
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env libtool
USE_SDL= sdl
@@ -27,8 +26,6 @@ PORTDOCS= README AUTHORS Changelog
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|../share/critterding|${DATADIR}|' \
${WRKSRC}/src/gui/textprinter.cpp ${WRKSRC}/src/gl/glwindow.cpp
@@ -36,12 +33,10 @@ post-patch:
pre-configure:
cd ${WRKSRC} && ${AUTORECONF} -fi
-.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/diameter/Makefile b/games/diameter/Makefile
index 1d385b297c31..e0e0878284ea 100644
--- a/games/diameter/Makefile
+++ b/games/diameter/Makefile
@@ -13,9 +13,8 @@ COMMENT= Arcade-style game with elements of economy and adventure
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libguichan.so:${PORTSDIR}/devel/guichan
-USE_BZIP2= yes
+USES= tar:bzip2 gmake pkgconfig
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
USE_GL= gl
USE_SDL= sdl mixer image
USE_PYTHON= yes