aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 20:40:05 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 20:40:05 +0800
commit0385f709d9a3e00e9489c735a96157d8b62d3419 (patch)
treebd0e67defd6871bf90e4a59d494be6a5b724c4b2
parent559d7b1606cb081435ceefe0b902726511638c23 (diff)
downloadfreebsd-ports-gnome-0385f709d9a3e00e9489c735a96157d8b62d3419.tar.gz
freebsd-ports-gnome-0385f709d9a3e00e9489c735a96157d8b62d3419.tar.zst
freebsd-ports-gnome-0385f709d9a3e00e9489c735a96157d8b62d3419.zip
Convert to USES=pgsql
While here: - stage support for pg_rman - stage support for pgagent - stage support for hashtypes
-rw-r--r--databases/apq-pgsql/Makefile4
-rw-r--r--databases/cppdb/Makefile2
-rw-r--r--databases/hashtypes/Makefile7
-rw-r--r--databases/p5-Pg/Makefile3
-rw-r--r--databases/pg_rman/Makefile7
-rw-r--r--databases/pgadmin3/Makefile4
-rw-r--r--databases/pgagent/Makefile5
7 files changed, 11 insertions, 21 deletions
diff --git a/databases/apq-pgsql/Makefile b/databases/apq-pgsql/Makefile
index e0f57274217a..1ad0ef1c8b49 100644
--- a/databases/apq-pgsql/Makefile
+++ b/databases/apq-pgsql/Makefile
@@ -18,8 +18,8 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/gnat/apq.gpr:${PORTSDIR}/databases/apq
RUN_DEPENDS= ${LOCALBASE}/lib/gnat/apq.gpr:${PORTSDIR}/databases/apq
-USES= ada tar:bzip2
-USE_PGSQL= yes
+USES= ada tar:bzip2 pgsql
+WANT_PGSQL= lib
HAS_CONFIGURE= yes
WRKPATH= ${WRKDIR}/build
CONFIGURE_ARGS= --prefix=${PREFIX} \
diff --git a/databases/cppdb/Makefile b/databases/cppdb/Makefile
index ac5bd7126917..37f30c06931c 100644
--- a/databases/cppdb/Makefile
+++ b/databases/cppdb/Makefile
@@ -76,7 +76,7 @@ PLIST_SUB+= ODBC=""
CMAKE_ARGS+= -DDISABLE_PQ:BOOL=ON
PLIST_SUB+= PGSQL="@comment "
.else
-USE_PGSQL= yes
+USES+= pgsql
CMAKE_ARGS+= -DDISABLE_PQ:BOOL=OFF
.if ${PORT_OPTIONS:MPGSQL_INTERNAL}
CMAKE_ARGS+= -DPQ_BACKEND_INTERNAL:BOOL=ON
diff --git a/databases/hashtypes/Makefile b/databases/hashtypes/Makefile
index 7c669e0c6228..5f1112cc8510 100644
--- a/databases/hashtypes/Makefile
+++ b/databases/hashtypes/Makefile
@@ -11,15 +11,12 @@ MASTER_SITES= http://api.pgxn.org/dist/hashtypes/${PORTVERSION}/ \
MAINTAINER= oss-contrib@dreamindustries.co
COMMENT= Hash data types for PostgreSQL
-USES= gmake zip
-USE_PGSQL= yes
+USES= gmake pgsql zip
MAKE_ARGS= USE_PGXS=1 MODULEDIR=extension
MODULEDIR= ${PREFIX}/share/postgresql/extension
-NO_STAGE= yes
post-install:
- @[ -f ${MODULEDIR}/${PORTNAME}.control ] || \
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.control ${MODULEDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.control ${STAGEDIR}${MODULEDIR}
.include <bsd.port.mk>
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index 87656ac4ea57..c2a2c36bd42b 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -14,8 +14,7 @@ DIST_SUBDIR= postgresql
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface for using perl5 to access PostgreSQL databases
-USE_PGSQL= yes
-USES= perl5
+USES= perl5 pgsql
USE_PERL5= configure
CONFIGURE_ENV= POSTGRES_INCLUDE=${LOCALBASE}/include POSTGRES_LIB=${LOCALBASE}/lib
diff --git a/databases/pg_rman/Makefile b/databases/pg_rman/Makefile
index 38e7bcfbb32b..1ccc6c82b0e1 100644
--- a/databases/pg_rman/Makefile
+++ b/databases/pg_rman/Makefile
@@ -2,17 +2,16 @@
PORTNAME= pg_rman
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://pg-rman.googlecode.com/files/
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Online backup and restore tool for PostgreSQL
-USE_GMAKE= yes
-USE_PGSQL= client server
-WANT_PGSQL_VER= 83+
+USES= gmake pgsql
+WANT_PGSQL= client server
MAKE_ARGS= USE_PGXS=1
PLIST_FILES= bin/pg_rman
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index d9f4f819a2bb..58139320a43f 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -16,9 +16,7 @@ BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
IGNORE_WITH_PGSQL= 82 83
-USES= gettext
-USE_PGSQL= yes
-USE_GMAKE= yes
+USES= gettext gmake pgsql
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/databases/pgagent/Makefile b/databases/pgagent/Makefile
index 60a57686414b..68b5e87dd5a5 100644
--- a/databases/pgagent/Makefile
+++ b/databases/pgagent/Makefile
@@ -11,15 +11,12 @@ DISTNAME= pgAgent-${PORTVERSION}-Source
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Job scheduler for PostgreSQL
-USES= cmake
+USES= cmake pgsql
CMAKE_ARGS= -DSTATIC_BUILD:BOOL=NO -DWX_CONFIG_PATH:FILEPATH="${WX_CONFIG}"
USE_WX= 2.8
WX_UNICODE= yes
-USE_PGSQL= yes
-IGNORE_WITH_PGSQL= 82 83
PLIST_FILES= bin/pgagent
PORTDATA= *
-NO_STAGE= yes
.include <bsd.port.mk>