aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-06-05 20:59:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-06-05 20:59:10 +0800
commit038a4c19f3d83733e1120039205e1f13ab506a97 (patch)
treed4b858c93538a38f31316467bfdfe1e194bfe432
parentd74512bc9203cc819df391bad8b83960703be4bd (diff)
downloadfreebsd-ports-gnome-038a4c19f3d83733e1120039205e1f13ab506a97.tar.gz
freebsd-ports-gnome-038a4c19f3d83733e1120039205e1f13ab506a97.tar.zst
freebsd-ports-gnome-038a4c19f3d83733e1120039205e1f13ab506a97.zip
- Update to 1.0
Changes: http://search.cpan.org/dist/App-GitGot/Changes
-rw-r--r--devel/p5-App-GitGot/Makefile13
-rw-r--r--devel/p5-App-GitGot/distinfo4
-rw-r--r--devel/p5-App-GitGot/pkg-plist21
3 files changed, 27 insertions, 11 deletions
diff --git a/devel/p5-App-GitGot/Makefile b/devel/p5-App-GitGot/Makefile
index cbb2a368f7b5..89bcbd9ae583 100644
--- a/devel/p5-App-GitGot/Makefile
+++ b/devel/p5-App-GitGot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= App-GitGot
-PORTVERSION= 0.9.2
+PORTVERSION= 1.0
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:GENEHACK
@@ -19,11 +19,14 @@ LICENSE_COMB= dual
LICENSE= ART20 GPLv1
RUN_DEPENDS= p5-Config-INI>=0:${PORTSDIR}/devel/p5-Config-INI \
+ p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
p5-Git-Wrapper>=0:${PORTSDIR}/devel/p5-Git-Wrapper \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-App-Cmd>=0:${PORTSDIR}/devel/p5-MooseX-App-Cmd \
p5-Net-GitHub>=0:${PORTSDIR}/net/p5-Net-GitHub \
p5-Term-ANSIColor>=0:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
@@ -35,15 +38,21 @@ MAN3= App::GitGot.3 \
App::GitGot::Command.3 \
App::GitGot::Command::add.3 \
App::GitGot::Command::chdir.3 \
+ App::GitGot::Command::clone.3 \
App::GitGot::Command::fork.3 \
+ App::GitGot::Command::gc.3 \
App::GitGot::Command::list.3 \
+ App::GitGot::Command::push.3 \
App::GitGot::Command::remove.3 \
App::GitGot::Command::status.3 \
App::GitGot::Command::update.3 \
+ App::GitGot::Command::update_status.3 \
App::GitGot::Command::version.3 \
App::GitGot::Outputter::dark.3 \
App::GitGot::Outputter.3 \
- App::GitGot::Outputter::light.3
+ App::GitGot::Outputter::light.3 \
+ App::GitGot::Repo.3 \
+ App::GitGot::Repo::Git.3
.include <bsd.port.pre.mk>
diff --git a/devel/p5-App-GitGot/distinfo b/devel/p5-App-GitGot/distinfo
index 6e0ea85e10bb..087676e954da 100644
--- a/devel/p5-App-GitGot/distinfo
+++ b/devel/p5-App-GitGot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (App-GitGot-0.9.2.tar.gz) = ce76784b045038708db4dc0eaceb642d54926c4f3a9a1f16e34c562f7ad21638
-SIZE (App-GitGot-0.9.2.tar.gz) = 23071
+SHA256 (App-GitGot-1.0.tar.gz) = f7d6fea0b14227d823aa57a5d887f48810ee6ded5478d0c9f409dda81dccb705
+SIZE (App-GitGot-1.0.tar.gz) = 25780
diff --git a/devel/p5-App-GitGot/pkg-plist b/devel/p5-App-GitGot/pkg-plist
index d5f53c9eb026..12b046585d5d 100644
--- a/devel/p5-App-GitGot/pkg-plist
+++ b/devel/p5-App-GitGot/pkg-plist
@@ -1,21 +1,28 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/GitGot/.packlist
+bin/got
%%SITE_PERL%%/App/GitGot.pm
%%SITE_PERL%%/App/GitGot/Command.pm
%%SITE_PERL%%/App/GitGot/Command/add.pm
%%SITE_PERL%%/App/GitGot/Command/chdir.pm
+%%SITE_PERL%%/App/GitGot/Command/clone.pm
%%SITE_PERL%%/App/GitGot/Command/fork.pm
+%%SITE_PERL%%/App/GitGot/Command/gc.pm
%%SITE_PERL%%/App/GitGot/Command/list.pm
+%%SITE_PERL%%/App/GitGot/Command/push.pm
%%SITE_PERL%%/App/GitGot/Command/remove.pm
%%SITE_PERL%%/App/GitGot/Command/status.pm
%%SITE_PERL%%/App/GitGot/Command/update.pm
+%%SITE_PERL%%/App/GitGot/Command/update_status.pm
%%SITE_PERL%%/App/GitGot/Command/version.pm
%%SITE_PERL%%/App/GitGot/Outputter/light.pm
%%SITE_PERL%%/App/GitGot/Outputter/dark.pm
%%SITE_PERL%%/App/GitGot/Outputter.pm
-bin/got
-@dirrmtry %%SITE_PERL%%/App/GitGot/Outputter
-@dirrmtry %%SITE_PERL%%/App/GitGot/Command
-@dirrmtry %%SITE_PERL%%/App/GitGot
-@dirrmtry %%SITE_PERL%%/App
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/App/GitGot
+%%SITE_PERL%%/App/GitGot/Repo.pm
+%%SITE_PERL%%/App/GitGot/Repo/Git.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/GitGot/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/App/GitGot
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/App
+@dirrm %%SITE_PERL%%/App/GitGot/Repo
+@dirrm %%SITE_PERL%%/App/GitGot/Outputter
+@dirrm %%SITE_PERL%%/App/GitGot/Command
+@dirrm %%SITE_PERL%%/App/GitGot
+@dirrmtry %%SITE_PERL%%/App