aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-08-10 23:50:54 +0800
committervanilla <vanilla@FreeBSD.org>2004-08-10 23:50:54 +0800
commit0973f187eff386652d6b53ebec22126361f31238 (patch)
treec163d73896c13e047b28590d046dfeb36b2e0894
parente126e0ecacff39597c259d6779a41703066bc9b7 (diff)
downloadfreebsd-ports-gnome-0973f187eff386652d6b53ebec22126361f31238.tar.gz
freebsd-ports-gnome-0973f187eff386652d6b53ebec22126361f31238.tar.zst
freebsd-ports-gnome-0973f187eff386652d6b53ebec22126361f31238.zip
Add gnometarget to USE_GNOME, that's better way.
-rw-r--r--databases/edb/Makefile4
-rw-r--r--devel/eet/Makefile4
-rw-r--r--graphics/epeg/Makefile4
-rw-r--r--graphics/imlib2/Makefile4
-rw-r--r--lang/embryo/Makefile4
5 files changed, 5 insertions, 15 deletions
diff --git a/databases/edb/Makefile b/databases/edb/Makefile
index 8392c81d1422..2cba34cae878 100644
--- a/databases/edb/Makefile
+++ b/databases/edb/Makefile
@@ -15,9 +15,7 @@ MAINTAINER= vanilla@FreeBSD.org
COMMENT= Enlightenment Database Library
USE_LIBTOOL_VER= 15
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack pkgconfig gnometarget
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
-
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/devel/eet/Makefile b/devel/eet/Makefile
index 32c84d8306d8..3a9af81f487a 100644
--- a/devel/eet/Makefile
+++ b/devel/eet/Makefile
@@ -17,11 +17,9 @@ COMMENT= Enlightenment Data Handling Library
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_LIBTOOL_VER= 15
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack pkgconfig gnometarget
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
-
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/graphics/epeg/Makefile b/graphics/epeg/Makefile
index 8802d617106d..ab98fd610a4b 100644
--- a/graphics/epeg/Makefile
+++ b/graphics/epeg/Makefile
@@ -17,11 +17,9 @@ COMMENT= An immensely fast jpeg thumbnailer library API
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_LIBTOOL_VER= 15
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack gnometarget
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
-
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 7ed3bc6b744b..71c584cafa51 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_LIBLTDL= yes
USE_LIBTOOL_VER= 15
USE_X_PREFIX= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack pkgconfig gnometartet
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -37,5 +37,3 @@ CONFIGURE_ARGS= --enable-mmx
.endif
.include <bsd.port.post.mk>
-
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/lang/embryo/Makefile b/lang/embryo/Makefile
index cb2e689760ca..31a562db7813 100644
--- a/lang/embryo/Makefile
+++ b/lang/embryo/Makefile
@@ -15,11 +15,9 @@ MAINTAINER= vanilla@FreeBSD.org
COMMENT= A C like scripting language used in parts of the Enlightenment
USE_LIBTOOL_VER= 15
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack pkgconfig gnometarget
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
-
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}