aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2015-07-19 00:33:15 +0800
committerdanilo <danilo@FreeBSD.org>2015-07-19 00:33:15 +0800
commit1145f21978179bf9f8937202a9143628c3be20d4 (patch)
tree5bd144d7e8cc29f9c67a5ee82b0feeace2315f8d
parentf1ba2bafec6e6762a33d5ace4843855a3615cec0 (diff)
downloadfreebsd-ports-gnome-1145f21978179bf9f8937202a9143628c3be20d4.tar.gz
freebsd-ports-gnome-1145f21978179bf9f8937202a9143628c3be20d4.tar.zst
freebsd-ports-gnome-1145f21978179bf9f8937202a9143628c3be20d4.zip
- Fix build
- Disable HTML support for now
-rw-r--r--x11/yad/Makefile1
-rw-r--r--x11/yad/files/patch-src_main.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/x11/yad/Makefile b/x11/yad/Makefile
index 48485364688d..1611ab687207 100644
--- a/x11/yad/Makefile
+++ b/x11/yad/Makefile
@@ -16,6 +16,7 @@ GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV+= DATADIRNAME=share
+CONFIGURE_ARGS+= --disable-html
OPTIONS_DEFINE= NLS ICONBROWSER
ICONBROWSER_DESC= Build YAD icon browser
diff --git a/x11/yad/files/patch-src_main.c b/x11/yad/files/patch-src_main.c
new file mode 100644
index 000000000000..9c739f44b98d
--- /dev/null
+++ b/x11/yad/files/patch-src_main.c
@@ -0,0 +1,18 @@
+--- src/main.c.orig 2015-07-18 16:00:17 UTC
++++ src/main.c
+@@ -765,6 +765,7 @@ main (gint argc, gchar ** argv)
+ ret = yad_print_run ();
+ break;
+
++#ifdef HAVE_HTML
+ case YAD_MODE_HTML:
+ /* Webkit doesn't handle focus for child dialogs when gtk_dialog_run() is used */
+ /* FIXME: maybe this solution must be expanded to all dialogs */
+@@ -775,6 +776,7 @@ main (gint argc, gchar ** argv)
+
+ gtk_main ();
+ break;
++#endif
+
+ default:
+ dialog = create_dialog ();