aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjase <jase@FreeBSD.org>2013-08-17 02:34:03 +0800
committerjase <jase@FreeBSD.org>2013-08-17 02:34:03 +0800
commit16be8ddeab6e335279441b9da06d0b1bea2e2359 (patch)
treea766b4c0cf0a58a11c52acc46829722599edb6b1
parentff1fa2768281d1c203aef5c4acc6300caf209a57 (diff)
downloadfreebsd-ports-gnome-16be8ddeab6e335279441b9da06d0b1bea2e2359.tar.gz
freebsd-ports-gnome-16be8ddeab6e335279441b9da06d0b1bea2e2359.tar.zst
freebsd-ports-gnome-16be8ddeab6e335279441b9da06d0b1bea2e2359.zip
- Update to 20130812
- Add pre-built manpage as build requirements for creating the manpage are somewhat excessive.
-rw-r--r--irc/weechat-devel/Makefile20
-rw-r--r--irc/weechat-devel/distinfo4
-rw-r--r--irc/weechat-devel/files/weechat.1.in261
-rw-r--r--irc/weechat-devel/pkg-plist2
4 files changed, 277 insertions, 10 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 701f8ec18b08..2b3754430db9 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= weechat
-PORTVERSION= 20130514
-PORTREVISION= 1
+PORTVERSION= 20130812
CATEGORIES= irc
MASTER_SITES= http://perturb.me.uk/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -19,14 +18,14 @@ CONFLICTS= weechat-0.3*
USE_LDCONFIG= yes
USES= cmake iconv
-CMAKE_ARGS+= -DENABLE_GUILE=no
+CMAKE_ARGS+= -DENABLE_GUILE=no -DENABLE_MAN=no
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
gcrypt:${PORTSDIR}/security/libgcrypt
-GITDESC= v0.4.1-rc2-2-g0c66b91
+GITDESC= v0.4.1-164-g7dea560
GITREV!= echo "${GITDESC}" | sed -E 's/^.*-g(.{7})$$/\1/'
#GITREV= 01a1316
WRKSRC= ${WRKDIR}/${PORTNAME}-${GITREV}
@@ -133,8 +132,13 @@ PLIST_SUB+= LUA="@comment "
.endif
.if ${PORT_OPTIONS:MDOCUMENTATION}
-BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
-BUILD_DEPENDS+= source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+.if defined(MAINTAINER_BUILD)
+BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
+ docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
+.endif
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+CMAKE_ARGS+= -DENABLE_DOC=yes
PLIST_SUB+= DOCUMENTATION=""
.else
CMAKE_ARGS+= -DENABLE_DOC=no
@@ -158,7 +162,7 @@ PLIST_SUB+= ICON=""
PLIST_SUB+= ICON="@comment "
.endif
-MAN1= weechat-curses.1
+MAN1= weechat.1
post-patch:
@${REINPLACE_CMD} -e 's|$${LIBDIR}/../pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
@@ -186,6 +190,6 @@ pre-configure:
.endif
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${FILESDIR}/weechat.1.in ${MAN1PREFIX}/man/man1/weechat.1
.include <bsd.port.mk>
diff --git a/irc/weechat-devel/distinfo b/irc/weechat-devel/distinfo
index dc76812ef6fe..b56fffda9953 100644
--- a/irc/weechat-devel/distinfo
+++ b/irc/weechat-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (weechat-devel-0c66b91.tar.gz) = a1e7d042babdf7a5bdff1a85855f928218e78cf7ed19d039ac0e95935278bbc3
-SIZE (weechat-devel-0c66b91.tar.gz) = 2567140
+SHA256 (weechat-devel-7dea560.tar.gz) = 0b35acaa1b59f29db359d730c066ed0327719ddb3705fcceef16c168802727cb
+SIZE (weechat-devel-7dea560.tar.gz) = 2699990
diff --git a/irc/weechat-devel/files/weechat.1.in b/irc/weechat-devel/files/weechat.1.in
new file mode 100644
index 000000000000..b0ea1061c7be
--- /dev/null
+++ b/irc/weechat-devel/files/weechat.1.in
@@ -0,0 +1,261 @@
+'\" t
+.\" Title: weechat
+.\" Author: [see the "AUTHORS" section]
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 08/14/2013
+.\" Manual: \ \&
+.\" Source: \ \& WeeChat 0.4.2-dev
+.\" Language: English
+.\"
+.TH "WEECHAT" "1" "08/14/2013" "\ \& WeeChat 0\&.4\&.2\-dev" "\ \&"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+weechat \- the extensible chat client
+.SH "SYNOPSIS"
+.sp
+.nf
+\fIweechat\fR [\-a|\-\-no\-connect] [\-d|\-\-dir <path>] [\-p|\-\-no\-plugin] [\-r|\-\-run\-command <command>] [\-s|\-\-no\-script] [\-\-upgrade] [plugin:option\&...]
+\fIweechat\fR [\-c|\-\-colors]
+\fIweechat\fR [\-h|\-\-help]
+\fIweechat\fR [\-k|\-\-keys]
+\fIweechat\fR [\-l|\-\-license]
+\fIweechat\fR [\-v|\-\-version]
+.fi
+.SH "DESCRIPTION"
+.sp
+WeeChat is a fast, light and extensible chat client\&.
+.sp
+It is modular (lightweight core with plugins), multi\-protocols (IRC and Jabber), extensible with C and scripts written in several languages\&.
+.SH "OPTIONS"
+.PP
+\fB\-a\fR, \fB\-\-no\-connect\fR
+.RS 4
+Disable auto\-connect to servers when WeeChat is starting\&.
+.RE
+.PP
+\fB\-c\fR, \fB\-\-colors\fR
+.RS 4
+Display default colors in terminal\&.
+.RE
+.PP
+\fB\-d\fR, \fB\-\-dir\fR \fI<path>\fR
+.RS 4
+Set path as home for WeeChat (used for configuration files, logs, user plugins and scripts), default value is
+\fI~/\&.weechat\fR
+(note: directory is created if not found by WeeChat)\&.
+.RE
+.PP
+\fB\-h\fR, \fB\-\-help\fR
+.RS 4
+Display help\&.
+.RE
+.PP
+\fB\-l\fR, \fB\-\-license\fR
+.RS 4
+Display WeeChat license\&.
+.RE
+.PP
+\fB\-p\fR, \fB\-\-no\-plugin\fR
+.RS 4
+Disable plugins auto\-load\&.
+.RE
+.PP
+\fB\-r\fR, \fB\-\-run\-command\fR \fI<command>\fR
+.RS 4
+Run command(s) after startup (many commands can be separated by semicolons)\&.
+.RE
+.PP
+\fB\-s\fR, \fB\-\-no\-script\fR
+.RS 4
+Disable scripts auto\-load\&.
+.RE
+.PP
+\fB\-\-upgrade\fR
+.RS 4
+Upgrade WeeChat using session files generated with command
+/upgrade \-quit\&.
+.RE
+.PP
+\fB\-v\fR, \fB\-\-version\fR
+.RS 4
+Display WeeChat version\&.
+.RE
+.PP
+\fBplugin:option\fR
+.RS 4
+Option for a plugin\&.
+.RE
+.SH "PLUGIN OPTIONS"
+.sp
+For complete doc on plugin options, please look at plugins documentation in WeeChat user\(cqs guide\&.
+.sp
+With irc plugin, you can connect to temporary server with an URL like:
+.sp
+.if n \{\
+.RS 4
+.\}
+.nf
+irc[6][s]://[[nickname][:password]@]server[:port][/#channel1[,#channel2\&.\&.\&.]]
+.fi
+.if n \{\
+.RE
+.\}
+.sp
+To join WeeChat IRC channel support with nick "mynick":
+.sp
+.if n \{\
+.RS 4
+.\}
+.nf
+irc://mynick@irc\&.freenode\&.net/#weechat
+.fi
+.if n \{\
+.RE
+.\}
+.sp
+IPv6 address can be enclosed in brackets to add a port after address, for example:
+.sp
+.if n \{\
+.RS 4
+.\}
+.nf
+irc://mynick@[2001:db8:0:85a3::ac1f:8001]:6668/#test
+.fi
+.if n \{\
+.RE
+.\}
+.SH "FILES"
+.PP
+$HOME/\&.weechat/weechat\&.conf
+.RS 4
+main WeeChat configuration file
+.RE
+.PP
+$HOME/\&.weechat/plugins\&.conf
+.RS 4
+plugins configuration file
+.RE
+.PP
+$HOME/\&.weechat/alias\&.conf
+.RS 4
+configuration file for
+\fIalias\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/aspell\&.conf
+.RS 4
+configuration file for
+\fIaspell\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/charset\&.conf
+.RS 4
+configuration file for
+\fIcharset\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/irc\&.conf
+.RS 4
+configuration file for
+\fIirc\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/logger\&.conf
+.RS 4
+configuration file for
+\fIlogger\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/relay\&.conf
+.RS 4
+configuration file for
+\fIrelay\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/rmodifier\&.conf
+.RS 4
+configuration file for
+\fIrmodifier\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/script\&.conf
+.RS 4
+configuration file for
+\fIscript\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/xfer\&.conf
+.RS 4
+configuration file for
+\fIxfer\fR
+plugin
+.RE
+.PP
+$HOME/\&.weechat/weechat\&.log
+.RS 4
+WeeChat log file
+.RE
+.SH "AUTHORS"
+.sp
+WeeChat is written by Sébastien Helleu and contributors (complete list is in the AUTHORS file)\&.
+.sp
+Copyright \(co 2003\-2013 Sébastien Helleu <flashcode@flashtux\&.org>
+.sp
+WeeChat is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 3 of the License, or (at your option) any later version\&.
+.sp
+Please read the COPYING file for more information\&.
+.sp
+Web: http://weechat\&.org/
+.SH "REPORTING BUGS"
+.sp
+Please report bugs or feature requests at Savannah website:
+.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+bugs:
+http://savannah\&.nongnu\&.org/bugs/?group=weechat
+.RE
+.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+feature requests:
+http://savannah\&.nongnu\&.org/task/?group=weechat
+.RE
diff --git a/irc/weechat-devel/pkg-plist b/irc/weechat-devel/pkg-plist
index bff95097d82a..c6d7e4eb45d2 100644
--- a/irc/weechat-devel/pkg-plist
+++ b/irc/weechat-devel/pkg-plist
@@ -1,3 +1,4 @@
+bin/weechat
bin/weechat-curses
include/weechat/weechat-plugin.h
lib/weechat/plugins/alias.so
@@ -63,6 +64,7 @@ libdata/pkgconfig/weechat.pc
%%NLS%%share/locale/pl/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/ru/LC_MESSAGES/weechat.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/weechat.mo
@dirrmtry lib/weechat/plugins
@dirrmtry lib/weechat
%%DOCUMENTATION%%@dirrmtry share/doc/weechat