aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-03-29 07:19:30 +0800
committerantoine <antoine@FreeBSD.org>2014-03-29 07:19:30 +0800
commit1b827cdfa01445382f0b2229efc94697fe4a7559 (patch)
tree706143a7568f4b58a2524497aa3c6b727a11ba8f
parent6b88e4613d60013e5cf23514e9c57a24574a44e1 (diff)
downloadfreebsd-ports-gnome-1b827cdfa01445382f0b2229efc94697fe4a7559.tar.gz
freebsd-ports-gnome-1b827cdfa01445382f0b2229efc94697fe4a7559.tar.zst
freebsd-ports-gnome-1b827cdfa01445382f0b2229efc94697fe4a7559.zip
- Stage support
- Conversion to OPTIONS - Remove support for deprecated NOPORTDATA
-rw-r--r--lang/mtasc/Makefile36
-rw-r--r--lang/mtasc/pkg-plist1
2 files changed, 12 insertions, 25 deletions
diff --git a/lang/mtasc/Makefile b/lang/mtasc/Makefile
index 521309ec0a72..d72eccde6915 100644
--- a/lang/mtasc/Makefile
+++ b/lang/mtasc/Makefile
@@ -14,6 +14,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/ocaml/site-lib/extlib/IO.cmi:${PORTSDIR}/devel/o
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
+OCAML_PKGDIRS= # This port uses ocaml-findlib but doesn't install one
OCAMLLEX?= ${LOCALBASE}/bin/ocamllex
OCAMLOPT?= ${LOCALBASE}/bin/ocamlopt
@@ -25,16 +26,11 @@ SWFLIB_FILES= as3.mli as3code.ml as3parse.ml swf.ml swfZip.ml actionScript.ml \
MTASC_OBJ= expr.cmx lexer.cmx parser.cmx typer.cmx class.cmx plugin.cmx\
genSwf.cmx main.cmx
-MAN1= mtasc.1
-
WRKSRC= ${WRKDIR}/ocaml
-.if !defined(NOPORTDATA)
PORTDATA= std std8
-.endif
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
do-build:
(cd ${WRKSRC}/extc && \
@@ -58,23 +54,13 @@ do-build:
${MTASC_OBJ} )
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mtasc-bin ${PREFIX}/bin/mtasc
-.if !defined(NOPORTDATA)
- @${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/mtasc && ${FIND} ${PORTDATA} -type f | ${CPIO} -pdmu ${DATADIR})
- @${FIND} ${DATADIR} -type d -exec ${CHMOD} 555 {} \;
- @${FIND} ${DATADIR} -type f -exec ${CHMOD} 444 {} \;
-.endif
-.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/mtasc/doc/mtasc.1 ${PREFIX}/man/man1
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/mtasc/doc/*.txt ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/mtasc/doc/HelloWorld.as ${EXAMPLESDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/mtasc-bin ${STAGEDIR}${PREFIX}/bin/mtasc
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/mtasc && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
+ ${INSTALL_MAN} ${WRKSRC}/mtasc/doc/mtasc.1 ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/mtasc/doc/*.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/mtasc/doc/HelloWorld.as ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/mtasc/pkg-plist b/lang/mtasc/pkg-plist
index b7a30e2c0aee..10e8f58079c8 100644
--- a/lang/mtasc/pkg-plist
+++ b/lang/mtasc/pkg-plist
@@ -1,4 +1,5 @@
bin/mtasc
+man/man1/mtasc.1.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
%%PORTDOCS%%%%DOCSDIR%%/Future.txt
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt