aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-10-27 05:04:21 +0800
committerswills <swills@FreeBSD.org>2014-10-27 05:04:21 +0800
commit1bef69b1cf78958e91373124e53110b701be5389 (patch)
tree43f8ad22dde713f3c4b00323750f35a4b326cce2
parentc01af5eee0eb1b0883d412ec76c6cb119b4d783c (diff)
downloadfreebsd-ports-gnome-1bef69b1cf78958e91373124e53110b701be5389.tar.gz
freebsd-ports-gnome-1bef69b1cf78958e91373124e53110b701be5389.tar.zst
freebsd-ports-gnome-1bef69b1cf78958e91373124e53110b701be5389.zip
Mark broken with Perl 5.18 and newer
-rw-r--r--databases/rrdtool10/Makefile8
-rw-r--r--devel/p5-Cdk/Makefile8
-rw-r--r--japanese/p5-Text-MeCab/Makefile4
-rw-r--r--mail/maildirsync/Makefile8
-rw-r--r--mail/p5-MIME-Fast/Makefile8
-rw-r--r--mail/qar-bufo/Makefile8
-rw-r--r--security/p5-Crypt-GOST/Makefile8
-rw-r--r--security/p5-Crypt-TEA/Makefile8
-rw-r--r--sysutils/rsnapshot/Makefile8
-rw-r--r--www/wml/Makefile4
10 files changed, 63 insertions, 9 deletions
diff --git a/databases/rrdtool10/Makefile b/databases/rrdtool10/Makefile
index 53f933f5d5c0..cee9a6abaaa2 100644
--- a/databases/rrdtool10/Makefile
+++ b/databases/rrdtool10/Makefile
@@ -34,6 +34,10 @@ LATIN2_DESC= ISO-8859-2 fonts support
LATIN2_CONFIGURE_ENABLE= latin2
-BROKEN_ia64= Does not build on ia64
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Cdk/Makefile b/devel/p5-Cdk/Makefile
index dd9b3f6fa9cb..98035d90f167 100644
--- a/devel/p5-Cdk/Makefile
+++ b/devel/p5-Cdk/Makefile
@@ -25,4 +25,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
post-stage:
@${SED} -i '' -e 's,${STAGEDIR},,g' ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Cdk/.packlist
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/p5-Text-MeCab/Makefile b/japanese/p5-Text-MeCab/Makefile
index a00bdc4b66fc..9b75c710b3ba 100644
--- a/japanese/p5-Text-MeCab/Makefile
+++ b/japanese/p5-Text-MeCab/Makefile
@@ -39,4 +39,8 @@ post-configure:
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
.include <bsd.port.post.mk>
diff --git a/mail/maildirsync/Makefile b/mail/maildirsync/Makefile
index 0b9a7ad9855a..4432d1427281 100644
--- a/mail/maildirsync/Makefile
+++ b/mail/maildirsync/Makefile
@@ -31,4 +31,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/contrib/mailbalance-0.2.0/* \
${STAGEDIR}${EXAMPLESDIR}/mailbalance
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-MIME-Fast/Makefile b/mail/p5-MIME-Fast/Makefile
index 88feb29dd7ca..5eae7e572508 100644
--- a/mail/p5-MIME-Fast/Makefile
+++ b/mail/p5-MIME-Fast/Makefile
@@ -19,4 +19,10 @@ USES= perl5
USE_PERL5= configure
CONFIGURE_ENV= PREFIX="${PREFIX}" CCFLAGS="${CCFLAGS} ${PTHREAD_CFLAGS}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/qar-bufo/Makefile b/mail/qar-bufo/Makefile
index 93284186be57..a9b27e763ad8 100644
--- a/mail/qar-bufo/Makefile
+++ b/mail/qar-bufo/Makefile
@@ -36,4 +36,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 \
${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-GOST/Makefile b/security/p5-Crypt-GOST/Makefile
index 8a16876e2b58..f04e1f21a29c 100644
--- a/security/p5-Crypt-GOST/Makefile
+++ b/security/p5-Crypt-GOST/Makefile
@@ -13,4 +13,10 @@ COMMENT= Perl extension for GOST Encryption Algorithm
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-TEA/Makefile b/security/p5-Crypt-TEA/Makefile
index 81f41fe78adf..d0e450a51e7a 100644
--- a/security/p5-Crypt-TEA/Makefile
+++ b/security/p5-Crypt-TEA/Makefile
@@ -13,4 +13,10 @@ COMMENT= Perl extension to Tiny Encryption Algorithm
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/rsnapshot/Makefile b/sysutils/rsnapshot/Makefile
index 5c8c96b4c357..5e51813925b6 100644
--- a/sysutils/rsnapshot/Makefile
+++ b/sysutils/rsnapshot/Makefile
@@ -27,4 +27,10 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/wml/Makefile b/www/wml/Makefile
index 0a0042742131..5df7fb3669d7 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -32,6 +32,10 @@ CONFIGURE_ARGS= --with-perl=${PERL5} --with-catdir=man \
.include <bsd.port.pre.mk>
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
post-patch:
@${PERL5} -pi -e 's!^(\s+have_\S+)=\S+!\1=1!' \
${WRKSRC}/wml_common/Makefile.in