aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2015-11-02 22:35:03 +0800
committerlev <lev@FreeBSD.org>2015-11-02 22:35:03 +0800
commit25b86e78e2ae70013febc453b774ddffb698b21a (patch)
tree508421e9b4ca3bff81fb583009446d2d76fc3903
parentfc17d313c2f3917185f4bb1c74cfa4977a0bb388 (diff)
downloadfreebsd-ports-gnome-25b86e78e2ae70013febc453b774ddffb698b21a.tar.gz
freebsd-ports-gnome-25b86e78e2ae70013febc453b774ddffb698b21a.tar.zst
freebsd-ports-gnome-25b86e78e2ae70013febc453b774ddffb698b21a.zip
Disable build of MCU-related gcc ports on platforms, where package building
is done on emulators, as it takes really long time (8 days in case of gcc-arm on arm itself, according to Sean Bruno). It looks sane for now, as most of ARM and MIPs-based machines are small router boxes, not powerful desktop-class machines.
-rw-r--r--devel/gcc-arm-embedded/Makefile6
-rw-r--r--devel/gcc-msp430-ti-toolchain/Makefile4
2 files changed, 8 insertions, 2 deletions
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index 590819d7f440..04fa11be84cf 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -20,7 +20,6 @@ HTML_DESC= Install HTML documentation
PDF_DESC= Install PDF documentation (requires TeX, it is huge)
PYGDB_DESC= Build and install pyhon-enabled gdb in addition to standard one
-
PURE_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-gcc-isl-0.15-compatibility
PURE_LIB_DEPENDS_OFF= \
libexpat.so:${PORTSDIR}/textproc/expat2 \
@@ -36,6 +35,10 @@ PDF_BUILD_DEPENDS= texi2dvi:${PORTSDIR}/print/texinfo
OPTIONS_SUB= yes
PYGDB_USES= python:2
+NOT_FOR_ARCHS= aarch64 arm armeb armv6 armv6hf \
+ mips mips64 mips64el mipsel mipsn32
+NOT_FOR_ARCHS_REASON= Very slow to build on emulator
+
USES= bison compiler cpe gmake iconv makeinfo tar:bzip2
GNU_CONFIGURE= yes
@@ -81,7 +84,6 @@ BUNDLED_VERSION_MPC= 0.8.1
BUNDLED_VERSION_ISL= 0.11.1
BUNDLED_VERSION_CLOOG= 0.18.0
-
VAR_TO_SUBMAKE= BUILD_DIR CC CFLAGS CHOSEN_COMPILER_TYPE CONFIG_SITE \
CONFIGURE_MAX_CMD_LEN CONFIGURE_SHELL CP CPP CPPFLAGS CXX \
CXXFLAGS DOCS_SUFFIX ECHO_MSG EXAMPLESDIR FILE FIND GMAKE \
diff --git a/devel/gcc-msp430-ti-toolchain/Makefile b/devel/gcc-msp430-ti-toolchain/Makefile
index a166b3064a4a..2a6762dc9944 100644
--- a/devel/gcc-msp430-ti-toolchain/Makefile
+++ b/devel/gcc-msp430-ti-toolchain/Makefile
@@ -41,6 +41,10 @@ PURE_LIB_DEPENDS_OFF= libgmp.so:${PORTSDIR}/math/gmp \
PURE_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-libgui_configure \
${PATCHDIR}/extra-patch-gdb_configure
+NOT_FOR_ARCHS= aarch64 arm armeb armv6 armv6hf \
+ mips mips64 mips64el mipsel mipsn32
+NOT_FOR_ARCHS_REASON= Very slow to build on emulator
+
USES= bison compiler cpe gmake libtool makeinfo tar:bzip2
USE_CSTD= gnu89