aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-12-12 21:50:47 +0800
committermiwi <miwi@FreeBSD.org>2009-12-12 21:50:47 +0800
commit46272b95b9a4307328e9e0c53144aa0c5b1bc383 (patch)
tree0d437d520a3be1ba2527618651354e32c856cb18
parentd62c79cc451d6f972d2d8f8579a214677ff1d23d (diff)
downloadfreebsd-ports-gnome-46272b95b9a4307328e9e0c53144aa0c5b1bc383.tar.gz
freebsd-ports-gnome-46272b95b9a4307328e9e0c53144aa0c5b1bc383.tar.zst
freebsd-ports-gnome-46272b95b9a4307328e9e0c53144aa0c5b1bc383.zip
This small app provides multi-host utilities to Django projects by using
threadlocals, middleware and simple utilities. Using the middleware provided, you can "easily" provide multi-site awareness to any project. WWW: http://bitbucket.org/bkroeze/django-threaded-multihost/ PR: ports/141302 Submitted by: Kevin Golding <ports at caomhin.org>
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-threaded-multihost/Makefile27
-rw-r--r--www/py-django-threaded-multihost/distinfo3
-rw-r--r--www/py-django-threaded-multihost/pkg-descr5
-rw-r--r--www/py-django-threaded-multihost/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 145a75fd570b..4915e780e726 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1322,6 +1322,7 @@
SUBDIR += py-django-devel
SUBDIR += py-django-registration
SUBDIR += py-django-tagging
+ SUBDIR += py-django-threaded-multihost
SUBDIR += py-dtflickr
SUBDIR += py-ez_web
SUBDIR += py-fcgi
diff --git a/www/py-django-threaded-multihost/Makefile b/www/py-django-threaded-multihost/Makefile
new file mode 100644
index 000000000000..42c52f05e7fd
--- /dev/null
+++ b/www/py-django-threaded-multihost/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-django-threaded-multihost
+# Date created: 8 December 2009
+# Whom: Kevin Golding <ports@caomhin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-threaded-multihost
+PORTVERSION= 1.3.2
+CATEGORIES= www python
+MASTER_SITES= http://cdn.bitbucket.org/bkroeze/django-threaded-multihost/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/([[:digit:]]\.[[:digit:]])\./\1-/g}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= Multi-host utilities to Django.
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_NOEGGINFO= yes
+PYEASYINSTALL_EGG= ${PYDISTUTILS_PKGNAME:C/[^A-Za-z0-9.]+/_/g}-${PORTVERSION:C/([[:digit:]]\.[[:digit:]])\./\1_/g}-${PYTHON_VERSION:S/thon//}${PYEASYINSTALL_OSARCH}.egg
+PYEASYINSTALL_UNINSTALLARGS= -q -m -S ${PYTHON_SITELIBDIR} \
+ ${PYDISTUTILS_PKGNAME}==${PYDISTUTILS_PKGVERSION:C/([[:digit:]]\.[[:digit:]])\./\1_/g}
+
+.include <bsd.port.mk>
diff --git a/www/py-django-threaded-multihost/distinfo b/www/py-django-threaded-multihost/distinfo
new file mode 100644
index 000000000000..ad2ff5ee55fe
--- /dev/null
+++ b/www/py-django-threaded-multihost/distinfo
@@ -0,0 +1,3 @@
+MD5 (django-threaded-multihost-1.3-2.tar.gz) = bba26d70c76028c9334c35dc439fed60
+SHA256 (django-threaded-multihost-1.3-2.tar.gz) = 7bc9b1eb5918a250cdd95efba7379188322623fb434aedf73ff114d0dedffd15
+SIZE (django-threaded-multihost-1.3-2.tar.gz) = 12971
diff --git a/www/py-django-threaded-multihost/pkg-descr b/www/py-django-threaded-multihost/pkg-descr
new file mode 100644
index 000000000000..e90bf5592ca9
--- /dev/null
+++ b/www/py-django-threaded-multihost/pkg-descr
@@ -0,0 +1,5 @@
+This small app provides multi-host utilities to Django projects by using
+threadlocals, middleware and simple utilities. Using the middleware provided,
+you can "easily" provide multi-site awareness to any project.
+
+WWW: http://bitbucket.org/bkroeze/django-threaded-multihost/
diff --git a/www/py-django-threaded-multihost/pkg-plist b/www/py-django-threaded-multihost/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/www/py-django-threaded-multihost/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%