aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-14 16:55:55 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-14 16:55:55 +0800
commit49c3758798dd665c186cc4b57d58eda980fc5f32 (patch)
tree01775abbaf3f9b79dda6bce3fdb3d45d19267c95
parentc07c9a8b7b596a27eb223a3e96249e4a1a5f74e8 (diff)
downloadfreebsd-ports-gnome-49c3758798dd665c186cc4b57d58eda980fc5f32.tar.gz
freebsd-ports-gnome-49c3758798dd665c186cc4b57d58eda980fc5f32.tar.zst
freebsd-ports-gnome-49c3758798dd665c186cc4b57d58eda980fc5f32.zip
Provide bandaid to fix the build for some people:
- add (missed?) `#include <glib.h>' into treestore.h; - ensure that local include path is searched before the global one, so that the build doesn't break if user occasionally has different includes with the same name in both paths (e.g. global.h). Submitted by: mjacobs
-rw-r--r--x11-fm/gnomemc/files/patch-src::Makefile.in14
-rw-r--r--x11-fm/gnomemc/files/patch-src::treestore.h14
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-fm/gnomemc/files/patch-src::Makefile.in b/x11-fm/gnomemc/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..478183a73e7e
--- /dev/null
+++ b/x11-fm/gnomemc/files/patch-src::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Makefile.in 2001/12/14 08:48:56 1.1
++++ src/Makefile.in 2001/12/14 08:49:23
+@@ -8,7 +8,7 @@
+ @MCF@
+
+ CFLAGS = $(XCFLAGS)
+-CPPFLAGS = $(XCPPFLAGS) @MCCFLAGS@
++CPPFLAGS = -I. $(XCPPFLAGS) @MCCFLAGS@
+ LDFLAGS = $(XLDFLAGS)
+ DEFS = $(XDEFS) -DREGEX_MALLOC -DLIBDIR=\""$(mclibdir)/"\" \
+ -DCONFDIR=\""$(confdir)/"\" -DLOCALEDIR=\""$(localedir)/"\"
diff --git a/x11-fm/gnomemc/files/patch-src::treestore.h b/x11-fm/gnomemc/files/patch-src::treestore.h
new file mode 100644
index 000000000000..dadba91b61b2
--- /dev/null
+++ b/x11-fm/gnomemc/files/patch-src::treestore.h
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/treestore.h 2001/12/14 08:39:52 1.1
++++ src/treestore.h 2001/12/14 08:40:21
+@@ -1,6 +1,8 @@
+ #ifndef __TREE_STORE_H
+ #define __TREE_STORE_H
+
++#include <glib.h>
++
+ /* Default filenames for the tree */
+
+ #ifdef OS2_NT