aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2011-01-05 13:02:23 +0800
committersumikawa <sumikawa@FreeBSD.org>2011-01-05 13:02:23 +0800
commit4ce751e97e292a079bed63f9d92faeb002f2921e (patch)
tree655709c64b3723cfdfb96e598417147c5b468f33
parentc090c0e1b63a43ddbb7821f6309f8ef735b0d470 (diff)
downloadfreebsd-ports-gnome-4ce751e97e292a079bed63f9d92faeb002f2921e.tar.gz
freebsd-ports-gnome-4ce751e97e292a079bed63f9d92faeb002f2921e.tar.zst
freebsd-ports-gnome-4ce751e97e292a079bed63f9d92faeb002f2921e.zip
Add knob to install ip6addrctl.conf which support Teredo prefix
-rw-r--r--net/miredo/Makefile14
-rw-r--r--net/miredo/distinfo1
-rw-r--r--net/miredo/files/ip6addrctl.conf11
-rw-r--r--net/miredo/pkg-plist2
4 files changed, 26 insertions, 2 deletions
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
index cba3dfc57f44..17492a7682b5 100644
--- a/net/miredo/Makefile
+++ b/net/miredo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= miredo
PORTVERSION= 1.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://www.remlab.net/files/miredo/archive/
@@ -21,6 +21,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
USE_LDCONFIG= yes
+OPTIONS= POLICYTABLE "Install policy table to support teredo" off
+
MAN1= teredo-mire.1
MAN5= miredo-server.conf.5 miredo.conf.5
MAN8= miredo-server.8 miredo.8 miredo-checkconf.8
@@ -38,4 +40,14 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
.endif
+.include <bsd.port.options.mk>
+
+post-install:
+.if defined(WITH_POLICYTABLE)
+ $(INSTALL_DATA) $(FILESDIR)/ip6addrctl.conf /etc
+PLIST_SUB+= POLICYTABLE=""
+.else
+PLIST_SUB+= POLICYTABLE="@comment "
+.endif
+
.include <bsd.port.mk>
diff --git a/net/miredo/distinfo b/net/miredo/distinfo
index 3d17e506ffeb..a9d4e41bc093 100644
--- a/net/miredo/distinfo
+++ b/net/miredo/distinfo
@@ -1,3 +1,2 @@
-MD5 (miredo-1.2.2.tar.bz2) = a04a40c4b42869968e00495636ff6d82
SHA256 (miredo-1.2.2.tar.bz2) = c0f597e3272975544c4d6f6296494ab17ff1e2dbdf58bd28d54e7fe1be365f9a
SIZE (miredo-1.2.2.tar.bz2) = 529200
diff --git a/net/miredo/files/ip6addrctl.conf b/net/miredo/files/ip6addrctl.conf
new file mode 100644
index 000000000000..79aedc314340
--- /dev/null
+++ b/net/miredo/files/ip6addrctl.conf
@@ -0,0 +1,11 @@
+# Revised default policy table to support teredo defined in the below draft
+# http://tools.ietf.org/id/draft-ietf-6man-rfc3484-revise-01.txt
+::1/128 60 0
+fc00::/7 50 1
+::/0 40 2
+::ffff:0:0/96 30 3
+2002::/16 20 4
+2001::/32 10 5
+::/96 1 10
+fec::/16 1 11
+3ffe::/16 1 12
diff --git a/net/miredo/pkg-plist b/net/miredo/pkg-plist
index 0726ff3b1dfc..658d1b750efb 100644
--- a/net/miredo/pkg-plist
+++ b/net/miredo/pkg-plist
@@ -29,3 +29,5 @@ etc/miredo/client-hook
@dirrm include/libtun6
@dirrm include/libteredo
@dirrm lib/miredo
+%%POLICYTABLE%%@cwd /
+%%POLICYTABLE%%/etc/ip6addrctl.conf