aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-20 00:27:17 +0800
committermiwi <miwi@FreeBSD.org>2013-02-20 00:27:17 +0800
commit5b700411b385b7a1208a01c4f6bd92603bc88e7c (patch)
tree4fdf2ef05494a37e489d68b0562c312984bdd2d7
parentbf396d8e1042c6bd80d19a45dfb60c841bc44b98 (diff)
downloadfreebsd-ports-gnome-5b700411b385b7a1208a01c4f6bd92603bc88e7c.tar.gz
freebsd-ports-gnome-5b700411b385b7a1208a01c4f6bd92603bc88e7c.tar.zst
freebsd-ports-gnome-5b700411b385b7a1208a01c4f6bd92603bc88e7c.zip
Extension to OCaml for deriving functions from type declarations. Includes
derivers for pretty-printing, type-safe marshalling with structure-sharing, dynamic typing, equality, and more. This is a version of the deriving library adapted for use with Ocsigen. WWW: http://github.com/hnrgrgr/deriving PR: ports/176162 Submitted by: Jaap Boender <jaapb@kerguelen.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-deriving-ocsigen/Makefile20
-rw-r--r--devel/ocaml-deriving-ocsigen/distinfo2
-rw-r--r--devel/ocaml-deriving-ocsigen/pkg-descr6
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 33753d7ef3df..55454d520b40 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1286,6 +1286,7 @@
SUBDIR += ocaml-cfg
SUBDIR += ocaml-classes
SUBDIR += ocaml-cppo
+ SUBDIR += ocaml-deriving-ocsigen
SUBDIR += ocaml-equeue
SUBDIR += ocaml-event
SUBDIR += ocaml-extlib
diff --git a/devel/ocaml-deriving-ocsigen/Makefile b/devel/ocaml-deriving-ocsigen/Makefile
new file mode 100644
index 000000000000..e77ec1477356
--- /dev/null
+++ b/devel/ocaml-deriving-ocsigen/Makefile
@@ -0,0 +1,20 @@
+# Created by: Jaap Boender <jaapb@kerguelen.org>
+# $FreeBSD$
+
+PORTNAME= deriving-ocsigen
+PORTVERSION= 0.3c
+CATEGORIES= devel www
+MASTER_SITES= http://ocsigen.org/download/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= Function derivation library
+
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
+USE_OCAML_LDCONFIG= yes
+
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-deriving-ocsigen/distinfo b/devel/ocaml-deriving-ocsigen/distinfo
new file mode 100644
index 000000000000..99d9eae6b38d
--- /dev/null
+++ b/devel/ocaml-deriving-ocsigen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (deriving-ocsigen-0.3c.tar.gz) = eb6e7e647b6f2effcc65c9b32076fbc12e366e16035447a762a93e5e1cba94c7
+SIZE (deriving-ocsigen-0.3c.tar.gz) = 61242
diff --git a/devel/ocaml-deriving-ocsigen/pkg-descr b/devel/ocaml-deriving-ocsigen/pkg-descr
new file mode 100644
index 000000000000..49140726398e
--- /dev/null
+++ b/devel/ocaml-deriving-ocsigen/pkg-descr
@@ -0,0 +1,6 @@
+Extension to OCaml for deriving functions from type declarations. Includes
+derivers for pretty-printing, type-safe marshalling with structure-sharing,
+dynamic typing, equality, and more. This is a version of the deriving library
+adapted for use with Ocsigen.
+
+WWW: http://github.com/hnrgrgr/deriving