aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-06-07 23:57:21 +0800
committerbsam <bsam@FreeBSD.org>2009-06-07 23:57:21 +0800
commit5b83e47086e5fa21c5924631137bf55ce8f93987 (patch)
tree640c846cec3b4f5d37e9bc5f7e1e84f6ed653a54
parent90c22c82a99d04901aca3658551ba97e27488925 (diff)
downloadfreebsd-ports-gnome-5b83e47086e5fa21c5924631137bf55ce8f93987.tar.gz
freebsd-ports-gnome-5b83e47086e5fa21c5924631137bf55ce8f93987.tar.zst
freebsd-ports-gnome-5b83e47086e5fa21c5924631137bf55ce8f93987.zip
Convert ports which use USE_GL=linux to USE_LINUX_APPS+=dri.
This is needed to switch a default linux base at 8-CURRENT to linux_base-f10. No PORTREVISION bump is needed since it's a mere infrastructure fix. Affected ports: ----- games/legends games/linux-quake3-demo games/rtcw net/skype-devel ----- Note: no more ports are using USE_GL=linux, it may be removed from Mk/bsd.ports.mk. Approved by: maintainer timeout (2 months, the needed changes were submitted to emulation@ at 2009-04-09)
-rw-r--r--games/legends/Makefile2
-rw-r--r--games/linux-quake3-demo/Makefile2
-rw-r--r--games/rtcw/Makefile3
-rw-r--r--net-im/skype-devel/Makefile2
-rw-r--r--net/skype-devel/Makefile2
5 files changed, 5 insertions, 6 deletions
diff --git a/games/legends/Makefile b/games/legends/Makefile
index f904cc38d829..01af8e420b70 100644
--- a/games/legends/Makefile
+++ b/games/legends/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_MAKESELF= yes
USE_LINUX= yes
-USE_GL= linux
+USE_LINUX_APPS+=dri
NO_BUILD= yes
NO_WRKSUBDIR= yes
DATADIR= ${PREFIX}/lib/${PORTNAME}
diff --git a/games/linux-quake3-demo/Makefile b/games/linux-quake3-demo/Makefile
index afc20c5f8c92..58f5c8177dba 100644
--- a/games/linux-quake3-demo/Makefile
+++ b/games/linux-quake3-demo/Makefile
@@ -23,7 +23,7 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Quake III Arena Demo
USE_LINUX= yes
-USE_GL= linux
+USE_LINUX_APPS+=dri
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/games/rtcw/Makefile b/games/rtcw/Makefile
index 1cce010f3f33..eedb685986a6 100644
--- a/games/rtcw/Makefile
+++ b/games/rtcw/Makefile
@@ -19,8 +19,7 @@ COMMENT= Return to Castle Wolfenstein for Linux
USE_MAKESELF= yes
USE_LINUX= yes
-USE_LINUX_APPS= xorglibs
-USE_GL= linux
+USE_LINUX_APPS= dri xorglibs
NO_WRKSUBDIR= yes
SUB_FILES= pkg-message
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
index 854d71d46184..e93ed3981bc5 100644
--- a/net-im/skype-devel/Makefile
+++ b/net-im/skype-devel/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux
.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-USE_GL= linux
+USE_LINUX_APPS+=dri
.endif
USE_BZIP2= yes
diff --git a/net/skype-devel/Makefile b/net/skype-devel/Makefile
index 854d71d46184..e93ed3981bc5 100644
--- a/net/skype-devel/Makefile
+++ b/net/skype-devel/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux
.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
-USE_GL= linux
+USE_LINUX_APPS+=dri
.endif
USE_BZIP2= yes