aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-01-26 00:34:53 +0800
committerdinoex <dinoex@FreeBSD.org>2008-01-26 00:34:53 +0800
commit60b9e43b3ff684126575e6244e05e2cfa8cb70b5 (patch)
tree0e28207a6559450c03d8e011e3652fb37da11b58
parent82899f191a10d1f00f2991d33e3c2f107d95a13d (diff)
downloadfreebsd-ports-gnome-60b9e43b3ff684126575e6244e05e2cfa8cb70b5.tar.gz
freebsd-ports-gnome-60b9e43b3ff684126575e6244e05e2cfa8cb70b5.tar.zst
freebsd-ports-gnome-60b9e43b3ff684126575e6244e05e2cfa8cb70b5.zip
UPnP IGD client lightweight library
The usage of the miniUPnP client library is useful whenever an application needs to listen for incoming connections. Examples : P2P applications, FTP clients for active mode, IRC (for DCC) or IM applications, network games, any server. WWW: http://miniupnp.free.fr/
-rw-r--r--net/Makefile1
-rw-r--r--net/miniupnpc/Makefile24
-rw-r--r--net/miniupnpc/distinfo3
-rw-r--r--net/miniupnpc/pkg-descr8
-rw-r--r--net/miniupnpc/pkg-plist9
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5272ceca1b7d..af081454bd3c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -329,6 +329,7 @@
SUBDIR += micro_inetd
SUBDIR += micro_proxy
SUBDIR += minisapserver
+ SUBDIR += miniupnpc
SUBDIR += miniupnpd
SUBDIR += miredo
SUBDIR += mknbi
diff --git a/net/miniupnpc/Makefile b/net/miniupnpc/Makefile
new file mode 100644
index 000000000000..166755ee611d
--- /dev/null
+++ b/net/miniupnpc/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: miniupnpc
+# Date created: 31 Oct 2007
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= miniupnpc
+PORTVERSION= 0.1.0.11
+CATEGORIES= net
+MASTER_SITES= http://miniupnp.free.fr/files/
+DISTNAME= ${PORTNAME}-1.0-RC11
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= UPnP IGD client lightweight library
+
+USE_GMAKE= yes
+MAKE_ENV+= INSTALLPREFIX=${PREFIX}
+USE_LDCONFIG= yes
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|--mode=|-m |' -e 's|--symbolic|-s|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/miniupnpc/distinfo b/net/miniupnpc/distinfo
new file mode 100644
index 000000000000..537265adf860
--- /dev/null
+++ b/net/miniupnpc/distinfo
@@ -0,0 +1,3 @@
+MD5 (miniupnpc-1.0-RC11.tar.gz) = 75d46c646e538829fad7ccac97f2cdf9
+SHA256 (miniupnpc-1.0-RC11.tar.gz) = f6e8a2607973ee13f0e25e946b6f3a5d3e690bb3bceb6718d20631b6dc0e4227
+SIZE (miniupnpc-1.0-RC11.tar.gz) = 32161
diff --git a/net/miniupnpc/pkg-descr b/net/miniupnpc/pkg-descr
new file mode 100644
index 000000000000..1af75a21991b
--- /dev/null
+++ b/net/miniupnpc/pkg-descr
@@ -0,0 +1,8 @@
+UPnP IGD client lightweight library
+
+The usage of the miniUPnP client library is useful whenever an application
+needs to listen for incoming connections.
+Examples : P2P applications, FTP clients for active mode, IRC (for DCC)
+or IM applications, network games, any server.
+
+WWW: http://miniupnp.free.fr/
diff --git a/net/miniupnpc/pkg-plist b/net/miniupnpc/pkg-plist
new file mode 100644
index 000000000000..1a41bc3f0fe4
--- /dev/null
+++ b/net/miniupnpc/pkg-plist
@@ -0,0 +1,9 @@
+include/miniupnpc/igd_desc_parse.h
+include/miniupnpc/miniupnpc.h
+include/miniupnpc/miniwget.h
+include/miniupnpc/upnpcommands.h
+include/miniupnpc/upnpreplyparse.h
+lib/libminiupnpc.a
+lib/libminiupnpc.so
+lib/libminiupnpc.so.1
+@dirrm include/miniupnpc