aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2014-01-26 02:06:08 +0800
committermadpilot <madpilot@FreeBSD.org>2014-01-26 02:06:08 +0800
commit674a73b91363b101437b15cbada4469566ceeae0 (patch)
tree49e08cf5ab1370984447df97afa13414155ffb2e
parent7b1070a99cd363b3368a3adcd5e4742135d17ce9 (diff)
downloadfreebsd-ports-gnome-674a73b91363b101437b15cbada4469566ceeae0.tar.gz
freebsd-ports-gnome-674a73b91363b101437b15cbada4469566ceeae0.tar.zst
freebsd-ports-gnome-674a73b91363b101437b15cbada4469566ceeae0.zip
- Fix build on 10 and head with clang
- Convert to staging - Improve library detection patch with a cleaner one - Mark jobs safe PR: ports/186060 Submitted by: Lapo Luchini <lapo@lapo.it> (maintainer)
-rw-r--r--devel/monotone/Makefile25
-rw-r--r--devel/monotone/files/patch-configure13
-rw-r--r--devel/monotone/files/patch-src_automate_reader.hh10
3 files changed, 36 insertions, 12 deletions
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index c6860097de59..39504973188e 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -24,6 +24,7 @@ USE_BZIP2= yes
USES= iconv pkgconfig gmake perl5
USE_PERL5= build
USE_LUA= 5.1+
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
@@ -50,13 +51,12 @@ PLIST_FILES= bin/mtn bin/mtn-cleanup bin/mtnopt \
"@dirrm share/monotone"
.if !defined(NO_INSTALL_MANPAGES)
INFO= monotone
-MAN1= mtn.1 \
- mtn-cleanup.1 \
- mtnopt.1
+PLIST_FILES+= man/man1/mtn.1.gz \
+ man/man1/mtn-cleanup.1.gz \
+ man/man1/mtnopt.1.gz
.endif
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -82,19 +82,20 @@ post-patch:
${REINPLACE_CMD} -Ee '/^install-info: /s/ install-info-am$$//' \
-e '/^install-data-am:/s/ install-info-am$$//' ${WRKSRC}/doc/Makefile.in
.endif
- ${REINPLACE_CMD} -e "s/\"lua/\"lua-${LUA_VER}/g" \
- -e "s/\"idn/\"libidn/g" \
- -e "s/\"pcre/\"libpcre/g" \
- -e "s/\"botan/\"botan-1.10/g" \
+ ${REINPLACE_CMD} \
-e "s/REBUILD_NLS=true/REBUILD_NLS=false/g" \
+ -e "s/std::tr1::/std::/g" \
${WRKSRC}/configure
+ ${REINPLACE_CMD} \
+ -e "s/std::tr1::/std::/g" \
+ ${WRKSRC}/src/hash_map.hh
post-install:
- ${MKDIR} ${PREFIX}/share/zsh/site-functions
- ${INSTALL_DATA} ${WRKSRC}/contrib/monotone.zsh_completion ${PREFIX}/share/zsh/site-functions/_mtn
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/contrib/monotone.zsh_completion ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_mtn
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} NEWS UPGRADE ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} NEWS UPGRADE ${STAGEDIR}${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/devel/monotone/files/patch-configure b/devel/monotone/files/patch-configure
new file mode 100644
index 000000000000..f8a804080121
--- /dev/null
+++ b/devel/monotone/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2014-01-22 00:48:12.855108408 +0100
++++ configure 2014-01-22 00:48:54.244105202 +0100
+@@ -4594,9 +4594,7 @@ fi
+
+ # The dummy "pkg-config" package is guaranteed to exist.
+ if test -n "$PKG_CONFIG"; then
+- mtn__full_pkg_config_path=`$PKG_CONFIG --debug pkg-config 2>&1 |
+- sed -ne "/^Scanning directory '/{; s///; s/'$//; p;}" |
+- tr "$as_nl" ':' | sed 's/:$//'`
++ mtn__full_pkg_config_path=`$PKG_CONFIG --variable=pc_path pkg-config 2>&1 | sed 's/:.*$//'`
+ #AC_MSG_NOTICE([detected pkg-config path: $mtn__full_pkg_config_path])
+ fi
+
diff --git a/devel/monotone/files/patch-src_automate_reader.hh b/devel/monotone/files/patch-src_automate_reader.hh
new file mode 100644
index 000000000000..837577efe321
--- /dev/null
+++ b/devel/monotone/files/patch-src_automate_reader.hh
@@ -0,0 +1,10 @@
+--- src/automate_reader.hh.orig 2014-01-22 01:04:27.675051506 +0100
++++ src/automate_reader.hh 2014-01-22 01:04:41.682040341 +0100
+@@ -13,6 +13,7 @@
+ #define __AUTOMATE_READER_HH__
+
+ #include <vector>
++#include <iostream>
+
+ class automate_reader
+ {