aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-05-14 04:11:10 +0800
committerrm <rm@FreeBSD.org>2012-05-14 04:11:10 +0800
commit682ea7994818d23954a3ae69b59de7f50683f211 (patch)
tree2adfd72fbcdcd4db231cc8ebd4d8dd27b00e4889
parentd36a979ab80e0ddc56e1420a7476fd17b6053b16 (diff)
downloadfreebsd-ports-gnome-682ea7994818d23954a3ae69b59de7f50683f211.tar.gz
freebsd-ports-gnome-682ea7994818d23954a3ae69b59de7f50683f211.tar.zst
freebsd-ports-gnome-682ea7994818d23954a3ae69b59de7f50683f211.zip
- strict python version to 2.x only
- convert to using PYTHON_PKGNAMEPREFIX in dependency entry
-rw-r--r--www/py-webware-component/Makefile4
-rw-r--r--www/py-webware/Makefile4
-rw-r--r--www/py-webware/pkg-descr2
-rw-r--r--www/session2/Makefile4
-rw-r--r--www/session2/pkg-descr2
5 files changed, 8 insertions, 8 deletions
diff --git a/www/py-webware-component/Makefile b/www/py-webware-component/Makefile
index ad0edc491c1c..0e56367815ad 100644
--- a/www/py-webware-component/Makefile
+++ b/www/py-webware-component/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}webware-
MAINTAINER= ports@FreeBSD.org
COMMENT= Webware servlet component extension
-RUN_DEPENDS= ${LOCALBASE}/share/webware/__init__.py:${PORTSDIR}/www/py-webware
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}webware>0:${PORTSDIR}/www/py-webware
-USE_PYTHON= yes
+USE_PYTHON= -2.7
do-build:
@${ECHO_MSG} -n ">> Compiling ..."
diff --git a/www/py-webware/Makefile b/www/py-webware/Makefile
index d2cb93d2fba9..6978ec9ae0d0 100644
--- a/www/py-webware/Makefile
+++ b/www/py-webware/Makefile
@@ -15,9 +15,9 @@ DISTNAME= Webware-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A versatile web application server written in Python
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/DateTime:${PORTSDIR}/lang/py-mx-base
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mx-base>0:${PORTSDIR}/lang/py-mx-base
-USE_PYTHON= yes
+USE_PYTHON= -2.7
NO_BUILD= yes
WEBWARE_USER?= webkit
diff --git a/www/py-webware/pkg-descr b/www/py-webware/pkg-descr
index b1e75513d690..bf9ad989752d 100644
--- a/www/py-webware/pkg-descr
+++ b/www/py-webware/pkg-descr
@@ -10,4 +10,4 @@ patterns and includes popular features such as:
- User manager with authentication
- CGI wrapper
-WWW: http://webware.sourceforge.net/
+WWW: http://webware.sourceforge.net/
diff --git a/www/session2/Makefile b/www/session2/Makefile
index 90c88b456928..2b2f66e4d9b7 100644
--- a/www/session2/Makefile
+++ b/www/session2/Makefile
@@ -16,7 +16,7 @@ DISTNAME= session2-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A quixote session manager with persistence support
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGVERSION= 0.6
@@ -30,7 +30,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
.endif
.if defined(WITH_POSTGRESQL)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psycopg
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg>0:${PORTSDIR}/databases/py-psycopg
.endif
post-install:
diff --git a/www/session2/pkg-descr b/www/session2/pkg-descr
index 85be1f11106d..6f0614a89d4b 100644
--- a/www/session2/pkg-descr
+++ b/www/session2/pkg-descr
@@ -2,4 +2,4 @@ The session2 package provides simple session handling for Quixote 2.0,
together with persistence mechanisms that can store sessions in a
variety of backends, including MySQL and PostgreSQL databases.
-WWW: http://quixote.idyll.org/session2/
+WWW: http://quixote.idyll.org/session2/