aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-08-28 14:10:52 +0800
committerijliao <ijliao@FreeBSD.org>2001-08-28 14:10:52 +0800
commit6ae7546833e76889d96e8311b4c9bdd1a71f1e56 (patch)
tree02068a0a12037a50cc5f317ff58eaa932312ebc3
parent9c9e21c257bc0b247c47145057bd130ca35d1eef (diff)
downloadfreebsd-ports-gnome-6ae7546833e76889d96e8311b4c9bdd1a71f1e56.tar.gz
freebsd-ports-gnome-6ae7546833e76889d96e8311b4c9bdd1a71f1e56.tar.zst
freebsd-ports-gnome-6ae7546833e76889d96e8311b4c9bdd1a71f1e56.zip
add source-highlight
Given a source file, produces a document with syntax highlighting
-rw-r--r--devel/Makefile1
-rw-r--r--devel/source-highlight/Makefile23
-rw-r--r--devel/source-highlight/distinfo1
-rw-r--r--devel/source-highlight/pkg-comment1
-rw-r--r--devel/source-highlight/pkg-descr3
-rw-r--r--devel/source-highlight/pkg-plist31
6 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eef70f579b29..15633f48dde8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -519,6 +519,7 @@
SUBDIR += shtool
SUBDIR += sip
SUBDIR += soup
+ SUBDIR += source-highlight
SUBDIR += sparc-rtems-binutils
SUBDIR += sparc-rtems-chill
SUBDIR += sparc-rtems-g77
diff --git a/devel/source-highlight/Makefile b/devel/source-highlight/Makefile
new file mode 100644
index 000000000000..d09cc7886b7a
--- /dev/null
+++ b/devel/source-highlight/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# New ports collection makefile for: source-highlight
+# Date created: Aug 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= source-highlight
+PORTVERSION= 1.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+.include <bsd.port.mk>
diff --git a/devel/source-highlight/distinfo b/devel/source-highlight/distinfo
new file mode 100644
index 000000000000..610d22ee0b48
--- /dev/null
+++ b/devel/source-highlight/distinfo
@@ -0,0 +1 @@
+MD5 (source-highlight-1.1.tar.gz) = c238eb186a52d5afd6d16fa0ca568038
diff --git a/devel/source-highlight/pkg-comment b/devel/source-highlight/pkg-comment
new file mode 100644
index 000000000000..299959afe624
--- /dev/null
+++ b/devel/source-highlight/pkg-comment
@@ -0,0 +1 @@
+Given a source file, produces a document with syntax highlighting
diff --git a/devel/source-highlight/pkg-descr b/devel/source-highlight/pkg-descr
new file mode 100644
index 000000000000..aaa0b56f6241
--- /dev/null
+++ b/devel/source-highlight/pkg-descr
@@ -0,0 +1,3 @@
+Given a source file, produces a document with syntax highlighting.
+
+WWW: http://www.gnu.org/software/src-highlite/
diff --git a/devel/source-highlight/pkg-plist b/devel/source-highlight/pkg-plist
new file mode 100644
index 000000000000..83ab3c04e97e
--- /dev/null
+++ b/devel/source-highlight/pkg-plist
@@ -0,0 +1,31 @@
+bin/cpp2html
+bin/java2html
+share/source-highlight/tags.j2h
+share/doc/source-highlight/COPYING
+share/doc/source-highlight/ChangeLog
+share/doc/source-highlight/Hello.css
+share/doc/source-highlight/Hello.java
+share/doc/source-highlight/Hello.java.html
+share/doc/source-highlight/Hello1.html
+share/doc/source-highlight/Hello2.css
+share/doc/source-highlight/Hello2.html
+share/doc/source-highlight/Hello3.html
+share/doc/source-highlight/Hello4.html
+share/doc/source-highlight/Hello5.html
+share/doc/source-highlight/Hello_h_f.html
+share/doc/source-highlight/INSTALL
+share/doc/source-highlight/NEWS
+share/doc/source-highlight/README
+share/doc/source-highlight/README.compile_VC6
+share/doc/source-highlight/THANKS
+share/doc/source-highlight/TODO.txt
+share/doc/source-highlight/cmdline.c.html
+share/doc/source-highlight/cmdline.h.html
+share/doc/source-highlight/colors.html
+share/doc/source-highlight/cpp2html.css
+share/doc/source-highlight/mono-alt.css
+share/doc/source-highlight/mono.css
+share/doc/source-highlight/source-highlight.html
+share/doc/source-highlight/startapp.cc.html
+@dirrm share/source-highlight
+@dirrm share/doc/source-highlight