aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-01-11 14:35:50 +0800
committerpi <pi@FreeBSD.org>2017-01-11 14:35:50 +0800
commit6e46bd16788958e4838b6de225c3442c050da3fa (patch)
treeba2b66a4234de68e55cf08ea576d797434ae55bc
parentb44e860f856a0cdedd81945068ceddd388b4adf5 (diff)
downloadfreebsd-ports-gnome-6e46bd16788958e4838b6de225c3442c050da3fa.tar.gz
freebsd-ports-gnome-6e46bd16788958e4838b6de225c3442c050da3fa.tar.zst
freebsd-ports-gnome-6e46bd16788958e4838b6de225c3442c050da3fa.zip
New port: audio/suil
Suil is a lightweight C library for loading and wrapping LV2 plugin UIs. Suil makes it possible to load a UI of any toolkit in a host using any other toolkit (assuming the toolkits are both supported by Suil). Hosts do not need to build against or link to foreign toolkit libraries to use UIs written with that toolkit; all the necessary magic is performed by dynamically loaded modules. The API is designed such that hosts do not need to explicitly support specific toolkits at all - if Suil supports a particular toolkit, then UIs in that toolkit will work in all hosts that use Suil automatically. Suil currently supports every combination of Gtk 2, Qt 4, and X11, e.g. with Suil a Gtk program can embed a Qt plugin UI without depending on Qt, and a Qt program can embed a Gtk plugin UI without depending on Gtk. On Windows, embedding native UIs in Gtk is also supported. I (David Robillard) would be happy to work with plugin authors to add support for new toolkits, please contact me if you're interested in writing a plugin UI using a toolkit that is not yet supported in the LV2 ecosystem. WWW: http://drobilla.net/software/suil/ PR: 213289 Submitted by: Michael Beer <beerml@sigma6audio.de> Reviewed by: Yuri Victorovich <yuri@rawbw.com>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/suil/Makefile35
-rw-r--r--audio/suil/distinfo3
-rw-r--r--audio/suil/pkg-descr21
-rw-r--r--audio/suil/pkg-plist10
5 files changed, 70 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 3e579760f47b..7b37f4c69773 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -744,6 +744,7 @@
SUBDIR += streamripper
SUBDIR += streamtranscoder
SUBDIR += stymulator
+ SUBDIR += suil
SUBDIR += sweep
SUBDIR += swhplugins
SUBDIR += taglib
diff --git a/audio/suil/Makefile b/audio/suil/Makefile
new file mode 100644
index 000000000000..d3cb07516b23
--- /dev/null
+++ b/audio/suil/Makefile
@@ -0,0 +1,35 @@
+# Created by: Michael Beer <beerml@sigma6audio.de>
+# $FreeBSD$
+
+PORTNAME= suil
+PORTVERSION= 0.8.2
+CATEGORIES= audio
+MASTER_SITES= http://download.drobilla.net/
+
+MAINTAINER= beerml@sigma6audio.de
+COMMENT= Suil is a C library for loading and wrapping LV2 plugin UIs
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>=1.14.0:audio/lv2
+LIB_DEPENDS= libQtCore.so:devel/qt4-corelib \
+ libQtGui.so:x11-toolkits/qt4-gui \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= pkgconfig python:build tar:bzip2 waf
+
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
+
+USE_LDCONFIG= yes
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig/*.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsuil-0.so.0.8.2
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/suil-0/libsuil_gtk2_in_qt4.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/suil-0/libsuil_qt4_in_gtk2.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/suil-0/libsuil_x11_in_gtk2.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/suil-0/libsuil_x11_in_qt4.so
+
+.include <bsd.port.mk>
diff --git a/audio/suil/distinfo b/audio/suil/distinfo
new file mode 100644
index 000000000000..f4974e8ca68a
--- /dev/null
+++ b/audio/suil/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483909687
+SHA256 (suil-0.8.2.tar.bz2) = 787608c1e5b1f5051137dbf77c671266088583515af152b77b45e9c3a36f6ae8
+SIZE (suil-0.8.2.tar.bz2) = 141929
diff --git a/audio/suil/pkg-descr b/audio/suil/pkg-descr
new file mode 100644
index 000000000000..cfe5f252e12a
--- /dev/null
+++ b/audio/suil/pkg-descr
@@ -0,0 +1,21 @@
+Suil is a lightweight C library for loading and wrapping LV2 plugin UIs.
+
+Suil makes it possible to load a UI of any toolkit in a host using any
+other toolkit (assuming the toolkits are both supported by Suil).
+Hosts do not need to build against or link to foreign toolkit libraries
+to use UIs written with that toolkit; all the necessary magic is performed
+by dynamically loaded modules. The API is designed such that hosts do not
+need to explicitly support specific toolkits at all - if Suil supports
+a particular toolkit, then UIs in that toolkit will work in all hosts
+that use Suil automatically.
+
+Suil currently supports every combination of Gtk 2, Qt 4, and X11, e.g. with
+Suil a Gtk program can embed a Qt plugin UI without depending on Qt,
+and a Qt program can embed a Gtk plugin UI without depending on Gtk.
+On Windows, embedding native UIs in Gtk is also supported.
+I (David Robillard) would be happy to work with plugin authors
+to add support for new toolkits, please contact me if you're interested
+in writing a plugin UI using a toolkit that is not yet
+supported in the LV2 ecosystem.
+
+WWW: http://drobilla.net/software/suil/
diff --git a/audio/suil/pkg-plist b/audio/suil/pkg-plist
new file mode 100644
index 000000000000..6ad98e6f5d99
--- /dev/null
+++ b/audio/suil/pkg-plist
@@ -0,0 +1,10 @@
+include/suil-0/suil/suil.h
+lib/libsuil-0.so
+lib/libsuil-0.so.0
+lib/libsuil-0.so.0.8.2
+lib/suil-0/libsuil_gtk2_in_qt4.so
+lib/suil-0/libsuil_qt4_in_gtk2.so
+lib/suil-0/libsuil_x11_in_gtk2.so
+lib/suil-0/libsuil_x11_in_qt4.so
+libdata/pkgconfig/suil-0.pc
+@dir lib/pkgconfig