aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-15 19:51:39 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-15 19:51:39 +0800
commit6eba92eecc359d1f57563da4e55bdd548fe23beb (patch)
tree006e69be6b89ba95c280c805bd594c995912cf3d
parent9867619fec9786a9429ba3d13b91a0057f4bcbb1 (diff)
downloadfreebsd-ports-gnome-6eba92eecc359d1f57563da4e55bdd548fe23beb.tar.gz
freebsd-ports-gnome-6eba92eecc359d1f57563da4e55bdd548fe23beb.tar.zst
freebsd-ports-gnome-6eba92eecc359d1f57563da4e55bdd548fe23beb.zip
- Try to unbreak parallel builds (-jX) by calling sub-makes correctly
- Do not mention PORTNAME in the COMMENT (according to PH section 5.6) - Avoid .for loop when installing portdocs, slightly cleanup Makefile - Reformat pkg-descr nicely (now perfectly aligned on both sides) and pacify portlint(1) by using correct delimiter after WWW line (space, per PH section 3.2.1). Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
-rw-r--r--shells/jailkit/Makefile16
-rw-r--r--shells/jailkit/files/patch-Makefile.in55
-rw-r--r--shells/jailkit/pkg-descr11
3 files changed, 60 insertions, 22 deletions
diff --git a/shells/jailkit/Makefile b/shells/jailkit/Makefile
index ebd8336a2bd8..34a78d61d88d 100644
--- a/shells/jailkit/Makefile
+++ b/shells/jailkit/Makefile
@@ -1,6 +1,5 @@
# Created by: Sylvio Cesar <sylvio@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= jailkit
PORTVERSION= 2.15
@@ -9,7 +8,7 @@ MASTER_SITES= http://olivier.sessink.nl/jailkit/ \
http://www.sfr-fresh.com/unix/privat/
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= Jailkit is a set of utilities to limit user account
+COMMENT= Utilities to limit user account
GNU_CONFIGURE= yes
USE_PYTHON= 2.5+
@@ -33,19 +32,18 @@ MANCOMPRESSED= yes
PORTDOCS= COPYRIGHT README.txt
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-install:
@${ECHO_MSG} "Updating ${SHELLS}"
@${CP} ${SHELLS} ${SHELLS}.bak
@(${GREP} -v ${PREFIX}/sbin/jk_chrootsh ${SHELLS}.bak; \
- ${ECHO_CMD} ${PREFIX}/sbin/jk_chrootsh) > ${SHELLS}
+ ${ECHO_CMD} ${PREFIX}/sbin/jk_chrootsh) > ${SHELLS}
@${RM} -f ${SHELLS}.bak
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/shells/jailkit/files/patch-Makefile.in b/shells/jailkit/files/patch-Makefile.in
index 8f35988b4afa..f6f2c7a45fef 100644
--- a/shells/jailkit/files/patch-Makefile.in
+++ b/shells/jailkit/files/patch-Makefile.in
@@ -1,9 +1,44 @@
--- Makefile.in.orig 2009-08-20 20:46:11.000000000 -0300
+++ Makefile.in 2009-08-20 20:46:51.000000000 -0300
-@@ -67,15 +67,6 @@
- @cd src/ && $(MAKE) install
- @cd py/ && $(MAKE) install
- @cd man/ && $(MAKE) install
+@@ -38,22 +38,22 @@
+ jailkit: all
+
+ all:
+- @cd src/ && $(MAKE) all
+- @cd py/ && $(MAKE) all
+- @cd man/ && $(MAKE) all
++ $(MAKE) -C src all
++ $(MAKE) -C py all
++ $(MAKE) -C man all
+
+ clean:
+ rm -f core *~ ini/*~
+- @cd src/ && $(MAKE) clean
+- @cd py/ && $(MAKE) clean
+- @cd man/ && $(MAKE) clean
++ $(MAKE) -C src clean
++ $(MAKE) -C py clean
++ $(MAKE) -C man clean
+
+ distclean: clean
+ rm -rf autom4te.cache/
+ rm -f Makefile config.log config.status config.cache
+- @cd src/ && $(MAKE) distclean
+- @cd py/ && $(MAKE) distclean
+- @cd man/ && $(MAKE) distclean
++ $(MAKE) -C src distclean
++ $(MAKE) -C py distclean
++ $(MAKE) -C man distclean
+
+ install:
+ ${INSTALL} -d -m 755 ${DESTDIR}${iniprefix}
+@@ -64,24 +64,13 @@
+ ${INSTALL} -m 0644 ini/$${file} ${DESTDIR}${iniprefix} ;\
+ fi ;\
+ done
+- @cd src/ && $(MAKE) install
+- @cd py/ && $(MAKE) install
+- @cd man/ && $(MAKE) install
- # test if the jk_chrootsh is already in /etc/shells
- # this previously had @echo but that fails on FreeBSD
- if test -w /etc/shells; then \
@@ -13,12 +48,18 @@
- fi \
- fi
-
++ $(MAKE) -C src install
++ $(MAKE) -C py install
++ $(MAKE) -C man install
uninstall:
rm -f ${iniprefix}/*.ini
-@@ -83,5 +74,3 @@
- @cd man/ && $(MAKE) uninstall
- @cd src/ && $(MAKE) uninstall
+- @cd py/ && $(MAKE) uninstall
+- @cd man/ && $(MAKE) uninstall
+- @cd src/ && $(MAKE) uninstall
++ $(MAKE) -C py uninstall
++ $(MAKE) -C man uninstall
++ $(MAKE) -C src uninstall
-rmdir --ignore-fail-on-non-empty ${DESTDIR}${iniprefix}
- @echo "You must manually remove jk_chrootsh from /etc/shells"
-# remove jk_chrootsh from /etc/shells
diff --git a/shells/jailkit/pkg-descr b/shells/jailkit/pkg-descr
index 48ba38d1ce5f..c9a8806ab42e 100644
--- a/shells/jailkit/pkg-descr
+++ b/shells/jailkit/pkg-descr
@@ -1,7 +1,6 @@
-Jailkit is a set of utilities to limit user accounts to specific
-files using chroot() and or specific commands.
-Setting up a chroot shell, a shell limited to some specific
-command, or a daemon inside a chroot jail is a lot easier and
-can be automated using these utilities.
+Jailkit is a set of utilities to limit user accounts to specific files
+using chroot() and or specific commands. Setting up a chroot shell, a
+shell limited to some specific command, or daemon inside a chroot jail
+is a lot easier and can be automated using these utilities.
-WWW: http://olivier.sessink.nl/jailkit/
+WWW: http://olivier.sessink.nl/jailkit/