aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-03-19 13:36:30 +0800
committermarcus <marcus@FreeBSD.org>2004-03-19 13:36:30 +0800
commit71f0626cf1f7905d7a17f8f8713e73f2d0f0ae99 (patch)
tree95243f2bd770fc427675ccd202bc2016275a6fe6
parent932168ba33ed62881c1c0faceba54f98bf7c7729 (diff)
downloadfreebsd-ports-gnome-71f0626cf1f7905d7a17f8f8713e73f2d0f0ae99.tar.gz
freebsd-ports-gnome-71f0626cf1f7905d7a17f8f8713e73f2d0f0ae99.tar.zst
freebsd-ports-gnome-71f0626cf1f7905d7a17f8f8713e73f2d0f0ae99.zip
Chase the gnutls shared lib version.
-rw-r--r--irc/bitlbee-otr/Makefile2
-rw-r--r--irc/bitlbee/Makefile2
-rw-r--r--mail/wmbiff/Makefile6
-rw-r--r--net/morebalance/Makefile2
-rw-r--r--security/xmlsec1/Makefile2
-rw-r--r--www/retawq/Makefile2
6 files changed, 8 insertions, 8 deletions
diff --git a/irc/bitlbee-otr/Makefile b/irc/bitlbee-otr/Makefile
index 34d97c1ab767..c2ef7f64703e 100644
--- a/irc/bitlbee-otr/Makefile
+++ b/irc/bitlbee-otr/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= glib20
PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_MSN)
-LIB_DEPENDS= gnutls.7:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--msn=1
pre-configure:
@${ECHO_CMD} "MSN support will be enabled."
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index 34d97c1ab767..c2ef7f64703e 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= glib20
PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_MSN)
-LIB_DEPENDS= gnutls.7:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--msn=1
pre-configure:
@${ECHO_CMD} "MSN support will be enabled."
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index 7ade7f2478f3..83665de1463c 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -18,13 +18,13 @@ USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libgnutls.so.7)
+.if exists(${LOCALBASE}/lib/libgnutls.so.13)
WITH_GNUTLS= yes
.endif
.ifdef WITH_GNUTLS
-LIB_DEPENDS+= gcrypt.6:${PORTSDIR}/security/libgcrypt \
- gnutls.7:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gcrypt.10:${PORTSDIR}/security/libgcrypt \
+ gnutls.13:${PORTSDIR}/security/gnutls
.endif
USE_XPM= yes
diff --git a/net/morebalance/Makefile b/net/morebalance/Makefile
index f7b836b2b76d..a90e2853b9e8 100644
--- a/net/morebalance/Makefile
+++ b/net/morebalance/Makefile
@@ -25,7 +25,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -lpcre
.endif
.if defined(WITH_TLS)
-LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls \
+LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls \
ggz.1:${PORTSDIR}/games/libggz
CFLAGS+= -DUSE_TLS
LDFLAGS+= -lggz -lgnutls -L${LOCALBASE}/lib
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 654b5cf54784..7cfb9eb20298 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -31,7 +31,7 @@ MAN1= xmlsec1.1 xmlsec1-config.1
.if defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --with-gnutls="${LOCALBASE}"
-LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+= --without-gnutls
.endif
diff --git a/www/retawq/Makefile b/www/retawq/Makefile
index c0cb992e8709..4db7c9af29ad 100644
--- a/www/retawq/Makefile
+++ b/www/retawq/Makefile
@@ -29,7 +29,7 @@ CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if defined(WITH_GNUTLS)
-LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --set-tls=1
.elif defined(WITH_OPENSSL)
USE_OPENSSL= yes