aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-24 01:00:53 +0800
committertijl <tijl@FreeBSD.org>2014-04-24 01:00:53 +0800
commit73a2e0bf00d8b4d19f9e654f54d39430635c889c (patch)
tree79aeb46db140fd315b214fd50c7838564dcd1602
parent16ac92001735b27f49611f2d175f4c84e007bec7 (diff)
downloadfreebsd-ports-gnome-73a2e0bf00d8b4d19f9e654f54d39430635c889c.tar.gz
freebsd-ports-gnome-73a2e0bf00d8b4d19f9e654f54d39430635c889c.tar.zst
freebsd-ports-gnome-73a2e0bf00d8b4d19f9e654f54d39430635c889c.zip
Link editors/gedit and graphics/evince with libICE. (Fixup for r351936)
Reported by: Mike Harding <mvharding@gmail.com>
-rw-r--r--editors/gedit/Makefile6
-rw-r--r--graphics/evince/Makefile3
2 files changed, 8 insertions, 1 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index eb0e40160a84..12d47a32eea4 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
pkgconfig tar:bzip2
-USE_XORG= sm
+USE_XORG= ice sm
INSTALLS_OMF= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -45,4 +45,8 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} '/EGG_SMCLIENT_LIBS =/s/$$/ -lICE/' \
+ ${WRKSRC}/gedit/smclient/Makefile.in
+
.include <bsd.port.post.mk>
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index b0fdf38b17c2..e5e8049e0e7f 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -28,6 +28,7 @@ INSTALLS_OMF= yes
USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
pkgconfig tar:bzip2
USE_GNOME= intlhack gnomeprefix gnomedocutils gconf2
+USE_XORG= ice sm
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
@@ -117,6 +118,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|execinfo.h|#|g' \
-e 's|" == "|" = "|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/SMCLIENT_LIBS =/s/$$/ -lICE/' \
+ ${WRKSRC}/cut-n-paste/smclient/Makefile.in
@${REINPLACE_CMD} -e '/^DOC_MODULE_VERSION/d' \
${WRKSRC}/help/reference/libdocument/Makefile.in \
${WRKSRC}/help/reference/libview/Makefile.in