aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-01-29 12:59:32 +0800
committerhrs <hrs@FreeBSD.org>2015-01-29 12:59:32 +0800
commit7549a0f25f881604ce860a73af367da2559be5d2 (patch)
treed8f772c84d60a2f0d0e4ac177c3264f3a4d48144
parent9255c32f6e5e285b983396857871924efb572206 (diff)
downloadfreebsd-ports-gnome-7549a0f25f881604ce860a73af367da2559be5d2.tar.gz
freebsd-ports-gnome-7549a0f25f881604ce860a73af367da2559be5d2.tar.zst
freebsd-ports-gnome-7549a0f25f881604ce860a73af367da2559be5d2.zip
- Fix egg-sim "invalid code(s)" issue[*].
- Reword pkg-descr. Reported by: ARAI Shun-ichi [*]
-rw-r--r--editors/tamago/Makefile2
-rw-r--r--editors/tamago/files/patch-egg-sim.el44
-rw-r--r--editors/tamago/pkg-descr15
3 files changed, 44 insertions, 17 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index 54f3be3e20df..687dc4d60813 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tamago
PORTVERSION= 4.0.6.0.20041122.19
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
diff --git a/editors/tamago/files/patch-egg-sim.el b/editors/tamago/files/patch-egg-sim.el
index 7ee7f5b9a85e..8ca01857b5ca 100644
--- a/editors/tamago/files/patch-egg-sim.el
+++ b/editors/tamago/files/patch-egg-sim.el
@@ -1,6 +1,38 @@
---- egg-sim.el.orig 2014-11-23 15:19:11.000000000 +0900
-+++ egg-sim.el 2014-11-23 15:20:02.000000000 +0900
-@@ -432,7 +432,7 @@
+--- egg-sim.el.orig 2001-01-28 03:53:13.000000000 +0900
++++ egg-sim.el 2015-01-28 19:42:32.000000000 +0900
+@@ -56,19 +56,23 @@
+ (<= to max)
+ (cond ((= (charset-dimension charset) 1)
+ (while (<= from to)
+- (setq result (cons (char-to-string
+- (make-char charset to))
+- result)
+- to (1- to)))
++ (let ((c (ignore-errors (make-char charset to))))
++ (if c (progn
++ (setq result (cons
++ (char-to-string c)
++ result)))))
++ (setq to (1- to)))
+ result)
+ ((= (charset-dimension charset) 2)
+ (while (<= from to)
+ (let ((code max))
+ (while (<= min code)
+- (setq result (cons (char-to-string
+- (make-char charset to code))
+- result)
+- code (1- code))))
++ (let ((c (ignore-errors (make-char charset to code))))
++ (if c (progn
++ (setq result (cons
++ (char-to-string c)
++ result)))))
++ (setq code (1- code))))
+ (setq to (1- to)))
+ result)))))
+
+@@ -432,7 +436,7 @@
(insert "-+")
(let ((i 0))
(while (< i 16)
@@ -9,7 +41,7 @@
(setq i (1+ i))))
(insert "\n")
-@@ -461,7 +461,7 @@
+@@ -461,7 +465,7 @@
(insert "-+")
(let ((i 0))
(while (< i 16)
@@ -18,7 +50,7 @@
(setq i (1+ i))))
(insert "\n")
-@@ -496,7 +496,7 @@
+@@ -496,7 +500,7 @@
(insert "-+")
(let ((i 0))
(while (< i 16)
@@ -27,7 +59,7 @@
(setq i (1+ i))))
(insert "\n")
-@@ -531,7 +531,7 @@
+@@ -531,7 +535,7 @@
(insert "-+")
(let ((i 1))
(while (<= i 94)
diff --git a/editors/tamago/pkg-descr b/editors/tamago/pkg-descr
index 63b2fb907100..02aee63bb689 100644
--- a/editors/tamago/pkg-descr
+++ b/editors/tamago/pkg-descr
@@ -1,14 +1,9 @@
-The Multilingual Input Method - Egg V4
+Egg V4 (tamago) is a multilingual input method for Emacsen
+written in only Emacs-Lisp. It supports the following translating servers:
+jserver, cserver, tserver, Wnn6, SJ3 ver 1 and ver 2, cannaserver, wxgserver,
+and anthy.
-This enables you to input Multilingual Characters.
-
-Tamago is only coded by emacs lisp.
-
-This input method is working with various translation servers
-(i.e. jserver, cserver, tserver, Wnn6, SJ3 ver 1 and ver 2,
- cannaserver and wxgserver).
-
-This package also includes enhancements from Debian, some of which are:
+This package also includes the following enhancements from Debian:
- Partial support for Wnn7/Wnn8.
- Support connection to cannaserver using UNIX domain socket.