aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-05-27 22:38:07 +0800
committerbsam <bsam@FreeBSD.org>2013-05-27 22:38:07 +0800
commit7766a1f2e681b661c2f7061e12fa1a9bd5224f36 (patch)
tree8e91d62ee7e20c5110b0043981f66f6026eaafed
parent8ba0b08dd531fbfb2b7171dd53d4e1b89495d67c (diff)
downloadfreebsd-ports-gnome-7766a1f2e681b661c2f7061e12fa1a9bd5224f36.tar.gz
freebsd-ports-gnome-7766a1f2e681b661c2f7061e12fa1a9bd5224f36.tar.zst
freebsd-ports-gnome-7766a1f2e681b661c2f7061e12fa1a9bd5224f36.zip
. remove shlib ABI cersion from LIB_DEPENDS;
. remove LICENSE_FILE of the standard one (GPLv2); . bump PORTREVISION; . trim Makefile headers; . NOPORTDOCS -> PORT_OPTIONS:MDOCS; . NOPORTEXAMPLES -> PORT_OPTIONS:MEXAMPLES; . do not run mkdir for the same directory multiple times; . use plain install instead of .for loops.
-rw-r--r--sysutils/metalog/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/sysutils/metalog/Makefile b/sysutils/metalog/Makefile
index 09bf5055fc3e..39d76e5fcb3f 100644
--- a/sysutils/metalog/Makefile
+++ b/sysutils/metalog/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: metalog
-# Date Created: 27 Aug 2002
-# Whom: Sergei Kolobov <sergei@kolobov.com>
-#
+# Created by: Sergei Kolobov <sergei@kolobov.com>
# $FreeBSD$
-#
PORTNAME= metalog
DISTVERSION= 0.8
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/old
@@ -16,9 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Modern syslogd replacement with PCRE support
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
USE_RC_SUBR= ${PORTNAME}
@@ -35,21 +30,21 @@ PORTDOCS= AUTHORS NEWS README
PORTEXAMPLES= metalog.conf
PLIST_FILES= sbin/metalog
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|' ${WRKSRC}/man/*[58]
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
-.for doc in ${PORTDOCS}
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
-.for ex in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${ex} ${EXAMPLESDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/,} ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>