aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2013-08-11 20:36:12 +0800
committeradamw <adamw@FreeBSD.org>2013-08-11 20:36:12 +0800
commit78b2f6de4da18ac9cf8f7493b824020bc84342dc (patch)
tree61b74da56ab29950ad48fa18f9a3e424a112ab02
parentd077d54fbe920f81a410d2fca364c8c08cdb3fb7 (diff)
downloadfreebsd-ports-gnome-78b2f6de4da18ac9cf8f7493b824020bc84342dc.tar.gz
freebsd-ports-gnome-78b2f6de4da18ac9cf8f7493b824020bc84342dc.tar.zst
freebsd-ports-gnome-78b2f6de4da18ac9cf8f7493b824020bc84342dc.zip
Use MDOCS instead of NOPORTDOCS.
Correct permissions on scripts. PORTREVISION bump for this.
-rw-r--r--textproc/multimarkdown/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index ac280cd5a00b..a12cff89d9c6 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -1,12 +1,11 @@
-# New ports collection makefile for: multimarkdown
-# Date created: 27 October 2011
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= multimarkdown
PORTVERSION= 3.7.1
+PORTREVISION= 1
DISTNAME= peg-${PORTNAME}-${PORTVERSION}
CATEGORIES= textproc
MASTER_SITES= http://github.com/fletcher/peg-${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
@@ -27,16 +26,20 @@ MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/multimarkdown bin/mmd bin/mmd2all bin/mmd2odf bin/mmd2opml bin/mmd2pdf bin/mmd2tex
PORTDOCS= LICENSE README.markdown
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -E "/CFLAGS/s/-arch [[:alnum:]]+//; /CFLAGS/s/\?=/\+=/" \
${WRKSRC}/Makefile
do-install:
- @${INSTALL} -m 755 ${WRKSRC}/multimarkdown ${PREFIX}/bin
- @${INSTALL} -m 755 ${WRKSRC}/scripts/* ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+ ${INSTALL_SCRIPT} ${WRKSRC}/multimarkdown ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/* ${PREFIX}/bin
+
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}; ${INSTALL} -m 644 LICENSE README.markdown ${DOCSDIR})
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.markdown ${DOCSDIR}
.endif
.include <bsd.port.mk>