aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 23:27:05 +0800
committerpav <pav@FreeBSD.org>2006-04-29 23:27:05 +0800
commit797448e8c7ffc9e860427db94668d42b2480bdcb (patch)
tree2171b142b7e379cd000d1b124a0cc62ba1101114
parentfd7a4b9b8a8fb22d874460cd97c6ec50aafd5686 (diff)
downloadfreebsd-ports-gnome-797448e8c7ffc9e860427db94668d42b2480bdcb.tar.gz
freebsd-ports-gnome-797448e8c7ffc9e860427db94668d42b2480bdcb.tar.zst
freebsd-ports-gnome-797448e8c7ffc9e860427db94668d42b2480bdcb.zip
GPSBabel converts waypoints, tracks, and routes from one format to another,
whether that format is a common mapping format like Delorme, Streets and Trips, or even a serial upload or download to a GPS unit such as those from Garmin and Magellan. By flattening the Tower of Babel that the authors of various programs for manipulating GPS data have imposed upon us, it returns to us the ability to freely move our own waypoint data between the programs and hardware we choose to use. It contains extensive data manipulation abilities making it a convenient for server-side processing or as the backend for other tools. WWW: http://www.gpsbabel.org/ PR: ports/96490 Submitted by: Laurent Courty <lrntct@gmail.com>
-rw-r--r--astro/Makefile1
-rw-r--r--astro/gpsbabel/Makefile21
-rw-r--r--astro/gpsbabel/distinfo3
-rw-r--r--astro/gpsbabel/files/patch-Makefile13
-rw-r--r--astro/gpsbabel/pkg-descr11
5 files changed, 49 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 233d3016584a..656ee1555ca7 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -17,6 +17,7 @@
SUBDIR += gkrellmoon2
SUBDIR += gkrellsun
SUBDIR += glunarclock
+ SUBDIR += gpsbabel
SUBDIR += gpsd
SUBDIR += gpsdrive
SUBDIR += gpsman
diff --git a/astro/gpsbabel/Makefile b/astro/gpsbabel/Makefile
new file mode 100644
index 000000000000..0fee5a3b7944
--- /dev/null
+++ b/astro/gpsbabel/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: gpsbabel
+# Date created: Apr 2006
+# Whom: Laurent Courty
+#
+# $FreeBSD$
+
+PORTNAME= gpsbabel
+PORTVERSION= 1.2.7
+CATEGORIES= astro
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= lrntct@gmail.com
+COMMENT= A gps file translating tool
+
+LIB_DEPENDS= usb:${PORTSDIR}/devel/libusb \
+ expat:${PORTSDIR}/textproc/expat2
+
+PLIST_FILES= bin/gpsbabel
+
+.include <bsd.port.mk>
diff --git a/astro/gpsbabel/distinfo b/astro/gpsbabel/distinfo
new file mode 100644
index 000000000000..847486cd44be
--- /dev/null
+++ b/astro/gpsbabel/distinfo
@@ -0,0 +1,3 @@
+MD5 (gpsbabel-1.2.7.tar.gz) = 535da9798714e53a9584e22ac7d651d3
+SHA256 (gpsbabel-1.2.7.tar.gz) = 08a28e8fb6e04eab170c8983da1601a2636a2a27f4d9aca90e3048c3e15f9d02
+SIZE (gpsbabel-1.2.7.tar.gz) = 1643528
diff --git a/astro/gpsbabel/files/patch-Makefile b/astro/gpsbabel/files/patch-Makefile
new file mode 100644
index 000000000000..d50c2dc41a44
--- /dev/null
+++ b/astro/gpsbabel/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- work/gpsbabel-1.2.7/Makefile Fri Aug 26 19:59:24 2005
++++ ../gpsbabel-1.2.7/Makefile Fri Apr 28 20:41:30 2006
+@@ -27,8 +27,8 @@
+ OPTIMIZATION=-O $(EXTRA_OPTIMIZATION)
+ DEBUGGING=-g $(EXTRA_DEBUGGING)
+ # add -DDEBUG_MEM to turn on memory allocation logging
+-CFLAGS=$(EXTRA_CFLAGS) $(DEBUGGING) -Icoldsync $(INHIBIT_EXPAT) $(INHIBIT_USB) $(OPTIMIZATION)
+-INSTALL_TARGETDIR=/usr/local/
++CFLAGS=$(EXTRA_CFLAGS) $(DEBUGGING) -Icoldsync $(INHIBIT_EXPAT) $(INHIBIT_USB) $(OPTIMIZATION) -I$(PREFIX)/include -L$(PREFIX)/lib
++INSTALL_TARGETDIR=$(PREFIX)
+
+ FMTS=magproto.o gpx.o geo.o mapsend.o mapsource.o garmin_tables.o \
+ gpsutil.o pcx.o cetus.o copilot.o gpspilot.o magnav.o \
diff --git a/astro/gpsbabel/pkg-descr b/astro/gpsbabel/pkg-descr
new file mode 100644
index 000000000000..8e6d12435228
--- /dev/null
+++ b/astro/gpsbabel/pkg-descr
@@ -0,0 +1,11 @@
+GPSBabel converts waypoints, tracks, and routes from one format to another,
+whether that format is a common mapping format like Delorme, Streets and Trips,
+or even a serial upload or download to a GPS unit such as those from Garmin and
+Magellan. By flattening the Tower of Babel that the authors of various programs
+for manipulating GPS data have imposed upon us, it returns to us the ability
+to freely move our own waypoint data between the programs and hardware we
+choose to use.
+It contains extensive data manipulation abilities making it a convenient for
+server-side processing or as the backend for other tools.
+
+WWW: http://www.gpsbabel.org/