aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-01-22 02:14:00 +0800
committerkwm <kwm@FreeBSD.org>2013-01-22 02:14:00 +0800
commit7e9838c0287d618dd5b9a25bba15132a3bccc444 (patch)
treed6bf59fbe1de9429ad826a24db6c51a7b4514f07
parentd061e94408f78bca5f2962f1df1268c31a650a82 (diff)
downloadfreebsd-ports-gnome-7e9838c0287d618dd5b9a25bba15132a3bccc444.tar.gz
freebsd-ports-gnome-7e9838c0287d618dd5b9a25bba15132a3bccc444.tar.zst
freebsd-ports-gnome-7e9838c0287d618dd5b9a25bba15132a3bccc444.zip
Fix the build with new glib.
While here trim Makefile header, remove shlib version in LIB_DEPENDS and register conflict in nautilus. Obtained from: gnome staging area.
-rw-r--r--www/gtkhtml3/Makefile14
-rw-r--r--x11-fm/nautilus/Makefile25
-rw-r--r--x11-toolkits/unique/Makefile15
3 files changed, 27 insertions, 27 deletions
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index c8df54b1b82d..3ac74e2fb805 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gtkhtml3
-# Date created: 12 March 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/www/gtkhtml3/Makefile,v 1.180 2011/03/19 17:33:16 mezz Exp $
-#
+# $MCom: ports/www/gtkhtml3/Makefile,v 1.184 2012/08/17 19:06:47 kwm Exp $
PORTNAME= gtkhtml3
PORTVERSION= 3.32.1
@@ -20,8 +16,8 @@ COMMENT= Lightweight HTML rendering/printing/editing engine
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
-LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
- enchant.1:${PORTSDIR}/textproc/enchant
+LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
+ enchant:${PORTSDIR}/textproc/enchant
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
@@ -46,5 +42,7 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gtkhtml-editor-test[$$]|gtkhtml3-editor-test$$|' \
${WRKSRC}/components/editor/Makefile.in
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN||g' \
+ ${WRKSRC}/a11y/*.[ch]
.include <bsd.port.mk>
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 3cbf582d3262..0f6b95849a79 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: nautilus2
-# Date created: 28th August 2000
-# Whom: ade, archie
-#
+# Created by: ade, archie
# $FreeBSD$
-# $MCom: ports/x11-fm/nautilus/Makefile,v 1.206 2010/11/13 12:53:45 kwm Exp $
-#
+# $MCom: ports/x11-fm/nautilus/Makefile,v 1.212 2012/09/03 16:28:29 mezz Exp $
PORTNAME= nautilus
PORTVERSION= 2.32.2.1
@@ -17,9 +13,11 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT?= File manager for the GNOME desktop
BUILD_DEPENDS= g-ir-compiler:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- exempi.3:${PORTSDIR}/textproc/exempi
+LIB_DEPENDS= exif:${PORTSDIR}/graphics/libexif \
+ unique-1.0:${PORTSDIR}/x11-toolkits/unique \
+ exempi:${PORTSDIR}/textproc/exempi
+
+CONFLICTS= nautilus-3.[0-9]*
INSTALLS_ICONS= yes
USE_BZIP2= yes
@@ -27,7 +25,6 @@ USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
librsvg2 desktopfileutils ltverhack gvfs ltasneededhack
-GNOME_DESKTOP_VERSION=2
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv" \
@@ -41,10 +38,14 @@ GCONF_SCHEMAS= apps_nautilus_preferences.schemas
MAN1= nautilus-connect-server.1 nautilus-file-management-properties.1 \
nautilus.1
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
+ ${WRKSRC}/eel/eel-*.[ch] \
+ ${WRKSRC}/libnautilus-private/*.[ch] \
+ ${WRKSRC}/src/nautilus-zoom-control.c
post-install:
@${MKDIR} ${PREFIX}/lib/nautilus/extensions-2.0
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/unique/Makefile b/x11-toolkits/unique/Makefile
index 6ccefdb77ba2..0265c5227ff0 100644
--- a/x11-toolkits/unique/Makefile
+++ b/x11-toolkits/unique/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libunique
-# Date created: 22 Feb 2009
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11-toolkits/unique/Makefile,v 1.9 2010/06/29 21:14:06 kwm Exp $
-#
+# $MCom: ports/x11-toolkits/unique/Makefile,v 1.12 2012/09/03 16:28:30 mezz Exp $
PORTNAME= unique
PORTVERSION= 1.1.6
@@ -16,7 +12,7 @@ DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Library for single instance applications
-LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
USE_XORG= ice
USE_BZIP2= yes
@@ -33,5 +29,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
${WRKSRC}/configure ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
+ ${WRKSRC}/unique/uniqueapp.c \
+ ${WRKSRC}/unique/uniquebackend.[ch] \
+ ${WRKSRC}/unique/uniqueinternals.h \
+ ${WRKSRC}/unique/uniquemessage.[ch]
.include <bsd.port.mk>