aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-11-04 15:20:38 +0800
committerjhale <jhale@FreeBSD.org>2012-11-04 15:20:38 +0800
commit7ef1062c18dc492f0c202b116e43aab459401f29 (patch)
tree206961df08b023093af8e8970212d5011e75834f
parent5292781b4deae2bdd08bfdf35e8d1752ecfa8665 (diff)
downloadfreebsd-ports-gnome-7ef1062c18dc492f0c202b116e43aab459401f29.tar.gz
freebsd-ports-gnome-7ef1062c18dc492f0c202b116e43aab459401f29.tar.zst
freebsd-ports-gnome-7ef1062c18dc492f0c202b116e43aab459401f29.zip
- Update to 0.3.4
- Trim Makefile header PR: ports/173327 Submitted by: Marco Broeder <marco.broeder@gmx.eu> (maintainer) Approved by: makc, avilla (mentors, implicit) Feature safe: yes
-rw-r--r--devel/hg-git/Makefile16
-rw-r--r--devel/hg-git/distinfo4
-rw-r--r--devel/hg-git/files/patch-setup.py17
-rw-r--r--devel/hg-git/pkg-plist22
4 files changed, 46 insertions, 13 deletions
diff --git a/devel/hg-git/Makefile b/devel/hg-git/Makefile
index 3bfcbc1ed1c6..f21349c15f8b 100644
--- a/devel/hg-git/Makefile
+++ b/devel/hg-git/Makefile
@@ -1,12 +1,8 @@
-# Ports collection makefile for: hg-git
-# Date created: 2009-10-24
-# Whom: Marco Broeder <marco.broeder@gmx.eu>
-#
+# Created by: Marco Broeder <marco.broeder@gmx.eu>
# $FreeBSD$
-#
PORTNAME= hg-git
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,17 +12,15 @@ COMMENT= Mercurial extension to pull from or push to a Git repository
LICENSE= GPLv2
-RUN_DEPENDS= ${PKGNAMEPREFIX}dulwich>=0.8.5:${PORTSDIR}/devel/dulwich \
- mercurial>=2.0.2:${PORTSDIR}/devel/mercurial
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dulwich>=0.8.5:${PORTSDIR}/devel/dulwich \
+ mercurial>=2.3.2:${PORTSDIR}/devel/mercurial
MAKE_JOBS_SAFE= yes
USE_PYTHON= yes
-USE_PYDISTUTILS=easy_install
+USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/-/_/}
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/devel/hg-git/distinfo b/devel/hg-git/distinfo
index d6335d22a126..c6d272edb74a 100644
--- a/devel/hg-git/distinfo
+++ b/devel/hg-git/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hg-git-0.3.3.tar.gz) = 51fb0cbe0364e3515f498b428466adddf5423b77e4882b6663320cb4fbd8d20f
-SIZE (hg-git-0.3.3.tar.gz) = 17295
+SHA256 (hg-git-0.3.4.tar.gz) = 3770dd4ce9f230fedff9c699f3a8f8d7210510b799c2ee7df774758026612c50
+SIZE (hg-git-0.3.4.tar.gz) = 18554
diff --git a/devel/hg-git/files/patch-setup.py b/devel/hg-git/files/patch-setup.py
new file mode 100644
index 000000000000..adceafea0bd6
--- /dev/null
+++ b/devel/hg-git/files/patch-setup.py
@@ -0,0 +1,17 @@
+--- ./setup.py.orig 2012-11-01 15:10:46.000000000 +0100
++++ ./setup.py 2012-11-03 10:28:03.799021557 +0100
+@@ -1,7 +1,4 @@
+-try:
+- from setuptools import setup
+-except:
+- from distutils.core import setup
++from distutils.core import setup
+
+ setup(
+ name='hg-git',
+@@ -20,5 +17,4 @@
+ license='GPLv2',
+ packages=['hggit'],
+ package_data={ 'hggit': ['help/git.rst'] },
+- install_requires=['dulwich>=0.8.0'],
+ )
diff --git a/devel/hg-git/pkg-plist b/devel/hg-git/pkg-plist
new file mode 100644
index 000000000000..cebe734e6558
--- /dev/null
+++ b/devel/hg-git/pkg-plist
@@ -0,0 +1,22 @@
+%%PYTHON_SITELIBDIR%%/hggit/__init__.py
+%%PYTHON_SITELIBDIR%%/hggit/__init__.pyc
+%%PYTHON_SITELIBDIR%%/hggit/__init__.pyo
+%%PYTHON_SITELIBDIR%%/hggit/_ssh.py
+%%PYTHON_SITELIBDIR%%/hggit/_ssh.pyc
+%%PYTHON_SITELIBDIR%%/hggit/_ssh.pyo
+%%PYTHON_SITELIBDIR%%/hggit/git_handler.py
+%%PYTHON_SITELIBDIR%%/hggit/git_handler.pyc
+%%PYTHON_SITELIBDIR%%/hggit/git_handler.pyo
+%%PYTHON_SITELIBDIR%%/hggit/gitrepo.py
+%%PYTHON_SITELIBDIR%%/hggit/gitrepo.pyc
+%%PYTHON_SITELIBDIR%%/hggit/gitrepo.pyo
+%%PYTHON_SITELIBDIR%%/hggit/hgrepo.py
+%%PYTHON_SITELIBDIR%%/hggit/hgrepo.pyc
+%%PYTHON_SITELIBDIR%%/hggit/hgrepo.pyo
+%%PYTHON_SITELIBDIR%%/hggit/overlay.py
+%%PYTHON_SITELIBDIR%%/hggit/overlay.pyc
+%%PYTHON_SITELIBDIR%%/hggit/overlay.pyo
+%%PYTHON_SITELIBDIR%%/hggit/util.py
+%%PYTHON_SITELIBDIR%%/hggit/util.pyc
+%%PYTHON_SITELIBDIR%%/hggit/util.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/hggit